Skip navigation

Frontrow under Mountain Lion it works!

28418 Views 36 Replies Latest reply: Feb 24, 2014 7:23 AM by nessviewer RSS
1 2 3 Previous Next
OlliHappyOnMac Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 12, 2012 11:15 AM
A lot of people want frontrow back, which has been removed since LION.


To get Frontrow running under Mountain Lion 10.8.2: here are the instructions that worked on the two macs I tested:


Copy these files from a snow-leopard installation (e.g. your backup) to the appropriate folders in Mountain Lion:






Confirm the copy process by typing in your password when required.


Open Apple Script Editor and type in:


#launch Front Row

tell application "/System/Library/CoreServices/Front"


end tell

tell application "System Events"

  key code 53

end tell

Save this as an Application. Store the created App in your Application folder end enjoy!


As usual, music files do not play, but all other things work beautiful. This is due to the fact that the actual iTunes Versions use a different Library format.


  • I am Mel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2012 12:20 PM (in response to OlliHappyOnMac)

    I just found a similar solution and was coming here to find more info.


    To get Front Row to work under LION (not Mountain Lion), the following files were needed (Note: I got this info from elsewhere months ago, but I don't remember where.)








    When I updated to Mountain Lion today, all those files were still in place, but the app no longer worked.


    BUT... Similarly to what you found, I noticed that if I manually launched the Front Row app that's in




    It launched the app! - NOT the one that was in my applications folder, but the one in the above directory. Once that was launched, I clicked "ESC" and was in.


    - Pretty much the same solution as above, but done manually without the applescript.


    HOWEVER, I'm only able to control the app and watch movies with the keyboard. I'd like to control it with the IR remote like before, but that's not working.


    Any idea how to enable that?

  • I am Mel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2012 4:34 PM (in response to OlliHappyOnMac)

    OlliHappyOnMac wrote:


    Hi Mel,


    the trick is: using the Apple-Script i posted. It starts frontrow and sends a keystroke to display FR.


    Right. Key code 53 is the ESC keystroke


    On my mac pressing escape to start FR did not work. Instead it closed some windows.


    That's weird. That yours will accept the script keystroke for ESC but not the actual ESC keystroke! Works ok on mine whether I click ESC manually or run a script. So long as Front Row is launched first (the one in the Core Services directory)

    IR is not interesting for me (Retina MB has no IR-Port).


    Using iPhone with Hippo Remote.


    I suppose I could use my phone as a remote. Wish I could get the IR one to work though. (Since I do have IR on mine.) My remote just seems to want to open itunes. Works ok in VLC too, but can't get it to do a thing in front row now - except open itunes behind it!


    Thanks for the phone suggestion. May end up doing that.

  • potny Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 20, 2013 10:35 PM (in response to I am Mel)

    Launching from the Core Services folder works for me.  I placed that app in my dock, it's not the nice looking theater chair but it at least it works for movie trailers, which is what I realy wanted back.  Just click and then hit the Escape key and ther it is.  Thank You!


    Oh, the wierd thing is that I trashed my App that was in applications and emptied the trash thinking it wasn't working before reading this post and it still works.

  • Douglas McLaughlin Level 9 Level 9 (63,735 points)
    Currently Being Moderated
    Jan 28, 2013 5:07 PM (in response to potny)

    The "Front" that's in the Applications folder is just an alias or shortcut to the real application that lives in the /System/Library/Core Services/ folder.



  • leeboski Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 15, 2013 8:53 PM (in response to OlliHappyOnMac)


  • barkayabc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 24, 2013 4:26 AM (in response to leeboski)

    Can some help here? I am using macmini with Lion and manage to migrate FR (thanks all).

    I also running ITunes 11 and cannot for the life of me make FR recognise anything on IT.

    I have followed the post

    But nothing. Can anyone help? Might need an idiot guidance




  • teobalsamo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 28, 2013 2:31 PM (in response to OlliHappyOnMac)

    Hi OlliHappyOnMac,


    I've got the files you told in my Time Machine backups of Snow Leopard.

    Before proceding with your instructions I have compared the folders in ML and in SL and noticed that, for instance, the BackRow.framework folder in ML weights 8.7 MB instead of the almost 3 in SL.

    So now the question is how the substitution of the newest folder with the older one will affect the whole Mac OS X 10.8.3 system.


    Thank you so much in advance

  • Alexandros1965 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 4, 2013 1:42 AM (in response to OlliHappyOnMac)

    Thanks! It does work, shows photos and outlays of movies, but when i select a movie, it cannot display the trailer! It stays at the spinning of the initial second. Please help!

  • Alexandros1965 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 9, 2013 10:49 PM (in response to potny)

    You can take frontrow.icns from original app, rename it to applet.icns and replace it in \Applications\FrontRow\Contents\Resources. Then your script-made app, will have the icon you like!

  • Applecub69 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 11, 2013 8:04 PM (in response to OlliHappyOnMac)

    Hi there. First off.. i want to say THANK YOU!!! IT WORKED!!!


    Secondly i need a bit more help

    I did as yout typed (of course cause it worked) BUT...

    Upon saving the script and placing it my apps folder.. it still shows as a script..

    when i double click on it.. the apple script editor comes up and then i have to hit the RUN button..

    is there a way to resolve this?

    Here is a screenshot of the script.. as i wrote it..


    Secondly.. I was able to open Front row ONCE and after i closed it.. i go to open it a second time.. and i am unable to do so until i reboot.. Any Ideas?


    Screen Shot 2013-07-11 at 7.56.37 PM.png

  • togglehd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2013 11:45 AM (in response to OlliHappyOnMac)



    first: thanks a lot for the instructions how to get Front Row to work under 10.8.4, OlliHappyOnMac's posting helped me, it works fine, even I don't know how to get my (Apple) IR remote control to do more than adjustung the loudness (it starts iTunes, of course, but that's not what I want to use it for).



    Now to the "Music" point:

    "As usual, music files do not play, but all other things work beautiful. This is due to the fact that the actual iTunes Versions use a different Library format."


    At home I use a NAS-Server for movies, music, pictures etc. (to have access to all my media on any device incl. my Galaxy S3) - this NAS-Server is not an Apple product but offers the possibility to use it as an iTunes server, too. I don't know if this is the trick, but when I open Front Row and go to "Sources" (I don't know what it's called in English systems, so it's the last line in the main menue, in my German system it's called "Quellen" = English: "Sources") I'm offered to choose between my MacMini and my NAS-Server. If I choose the second and switch to "Music", I can play all of the music stored on this device as well as all movies if I switch to "Movies" and so on...


    Maybe this could be from interest for you or for someone else...


    Anyway - if somebody could give me a hint to get my IR remote control to work with Front Row on my 10.8.4 system - this would be really great! Thanx.

  • togglehd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2013 11:49 AM (in response to Applecub69)



    did you save the script as an "Application"?


    After a restart it shoud work...

  • on parole Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2013 9:02 PM (in response to OlliHappyOnMac)

    Your script worked perfectly thanks i have Front Row back , i had just upgraded from 10.6.8 to 10.8.4 for Logic X and had no idea Front Row had been discontinued. I have just downloaded "Remote Buddy" from and this gives you complete control of your apple remote back and works for Front Row in 10.8.4 (though its not supported in that version because of course it technically doest exist anymore) , i also downgraded my itunes to 10.3 using the method from  (i tried downgrading to 10.7 and 10.6 but neither  fixed front row not playing music so i downgraded to 10.3 and that worked perfectly!!!...its still freely available from apple support and this put my music back in Front Row  .I just bought a single from the itunes store to make sure 10.3 still worked fine in that regard and it does. The only thing is that i had to remove my itunes library playlist completely during the step in downgrading in which it says to just delete the last library update as 10.3 is from too long ago and i just kept getting an error msg that my playlists were created by a newer version so wouldnt open...So make sure you have backed up your drive so u can load them back in although it should just be able to search them all on your drive..i dont think it deleted the files just the reference to them but not absolutely better to be safe!!

    So now Front Row is Back, and the remote is working again!!! (take that Apple LOL)...just have to redo all the playlists again... i should have manually dragged and dropped them in instead of letting itunes reload them all as one long list of individual tracks !!! But i guess i can redo that step another day

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (4)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.