3 Replies Latest reply: Dec 12, 2012 4:50 PM by Eric Root
shadow Level 1 Level 1 (5 points)

Hi all,

 

I have a strange problem, i know that ML dont come with Java so i downloaded the latest Java from their page (version 7) and installed it.

Now whenever i was to use java in either Firefox or Safari OSX wants to install version 6 and wont use the one i just installed.

I have just made a clean ML install.

 

Any idea how to solve this?


MBP 15" i7, Mac OS X (10.6.3)
  • 1. Re: Java problem under OSX 10.8.2
    Eric Root Level 6 Level 6 (16,210 points)

    You aren't the only one having this problem.

     

    Maybe this will help:

     

    Java: http://www.reedcorner.net/using-java-in-mac-os-x/

  • 2. Re: Java problem under OSX 10.8.2
    shadow Level 1 Level 1 (5 points)

    Thanks for the link. Good read but i'm even more confused

     

    I went ahead and installed the version OSX wants me to install (article says to do this as well i think).

     

    End result is my browser Firefox now can detect version 7 update 10.

    But i tested in terminal Jave - version and it shows

    java version "1.6.0_37"

    Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)

    Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)

     

    No idea what to make of it. Since Firefox sees the correct version it should be fine. But i dont like the fact that i have no clue or control as to how to remove this old reference or version. In the Java Control Panel i can only see Version 1.7 so where this 1.6 exist is just beyong me.

     

    Any way thank you for the reply mate.

  • 3. Re: Java problem under OSX 10.8.2
    Eric Root Level 6 Level 6 (16,210 points)

    You are welcome.