Skip navigation

Can't wake Lion over wifi (or ethernet) using iPad and home sharing.

48075 Views 227 Replies Latest reply: Mar 21, 2014 1:39 PM by IIIMOODIII RSS
  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    What changes did you do?

     

    Mine or others?

  • namuh Calculating status...

    The ones I described on page 7 of this topic.  It worked then and still does on my system. 

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    I made yours and it totally messed up my iMac, with Back to my Mac nothing worked, so I've redonne mine, and now everything's back to normal.

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    I don't think it's a software trouble, since my MacBook Pro works fine, it's more a firmware trouble, I think the problem occured on iMac since the WiFi upgrade which was in a Firmware update.

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    I've checked Computer/Library/Preferences/SystemConfiguration

     

    There is a file called "preferences.plist"

    Into it I found:

     

    </dict>

                                  <key>PPP</key>

                                  <dict>

                                            <key>ACSPEnabled</key>

                                            <integer>0</integer>

                                            <key>CommDisplayTerminalWindow</key>

                                            <integer>0</integer>

                                            <key>CommRedialCount</key>

                                            <integer>1</integer>

                                            <key>CommRedialEnabled</key>

                                            <integer>1</integer>

                                            <key>CommRedialInterval</key>

                                            <integer>5</integer>

                                            <key>CommUseTerminalScript</key>

                                            <integer>0</integer>

                                            <key>DialOnDemand</key>

                                            <integer>0</integer>

                                            <key>DisconnectOnFastUserSwitch</key>

                                            <integer>1</integer>

                                            <key>DisconnectOnIdle</key>

                                            <integer>1</integer>

                                            <key>DisconnectOnIdleTimer</key>

                                            <integer>600</integer>

                                            <key>DisconnectOnLogout</key>

                                            <integer>1</integer>

                                            <key>DisconnectOnSleep</key>

                                            <integer>1</integer>

                                            <key>IPCPCompressionVJ</key>

                                            <integer>1</integer>

                                            <key>IdleReminder</key>

                                            <integer>0</integer>

    <key>IdleReminderTimer</key>

                                            <integer>1800</integer>

                                            <key>LCPEchoEnabled</key>

                                            <integer>0</integer>

                                            <key>LCPEchoFailure</key>

                                            <integer>4</integer>

                                            <key>LCPEchoInterval</key>

                                            <integer>10</integer>

                                            <key>Logfile</key>

                                            <string>/var/log/ppp.log</string>

                                            <key>VerboseLogging</key>

                                            <integer>0</integer>

     

    Do you think we could solve the problem by changing some of the values?

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    And what about: pmset -g networkoversleep 1

    By default it's 0

  • namuh Level 1 Level 1 (0 points)

    I would first try changing networkoversleep to 1.

     

    The other stuff looks like it is for a PPP connection.

     

    Good luck.

  • Charles Lindauer Calculating status...

    Where did you find pmset -g networkoversleep 1? I'd like to try it.

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    Try to google it, I tried that without success, although I solved my problem 3 days ago. Now everything works just fine. In fact it was a really stupid issue and during a few months I didn't find the solution.

     

    My iMac is connected to my Time Capsule with 5GHz and there are several rooms between. So I guess the signal go off when it is asleep for a while.

     

    What I did was to connect it to the AirPort Express 2.4GHz in the very same room. I restarted and BAM now it is always connect and wake from sleep.

  • Obii-wan Calculating status...

    Freducken wrote:

     

    namuh wrote:

     

    I have an imac with Lion 10.7.3 and a linksys (cisco) router.  I wanted to access it when it was sleeping, but couldn't by wifi, even though the wake on lan option was set. 

     

    After reading a bit about the problem and the various fixes, I was searching in the /Library/Preferences/SystemConfiguration folder and I saw the com.apple.PowerManagement.plist file.  I opened it in an editor, and then noticed a line that had a key of PrioritizeNetworkReachabilityOverSleep.

    The value was 0, so I changed it to 1 and saved the file.

     

    Now I have no trouble accessing the Mac by my iphone, even after it sits overnight.  You may want to try it.

     

     

     

    /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

    This solved the issue for me!!!! You sir, are awesome. Now I can't start putting my computer back to sleep instead of just putting the display to sleep. Before making this ONE, SIMPLE CHANGE, I could not use the VNC app to wake my iMac wake from my iPad. Now it works!!!! Very, very, cool! Can you tell how pleased I am at this fix? LOL.

     

    Also, I am pretty newbie when it comes to this stuff, so for any other newbies out there, remember to change the permissions for the folder in which the plist file resides with Right Click, Get Info. In essence, this is the most difficult part of the fix, which is obviously not.

    Both you guys just made my day! Excellent. My remote app wakes the Mac up with no issues now. Might want to add that when you change permissions for the folder, you also need to apply it to the contents of the folder by using the settings button  - looks like a gear.

  • Tony T1 Level 6 Level 6 (8,115 points)

    No need to edit the plist file.  In Terminal: sudo pmset networkoversleep 1

     

    From the man page:

    networkoversleep - this setting affects how OS X networking presents

    shared network services during system sleep. This setting is not used by

    all platforms; changing its value is unsupported.


    MacBook Air, MacBook, Mac mini, OS X Mountain Lion (10.8.1)
  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    Hello Obii-wan,

     

    Could you tell me the step by step in order to change the PrioritizeNetworkReachabilityOverSleep settings the right way and have it to work?

     

    Cause I already changed the values but it didn't work, that's why, I think I made a mistake somewhere

  • Tony T1 Level 6 Level 6 (8,115 points)

    In Terminal:

       sudo pmset networkoversleep 1

    Then

      pmset -g

    to confirm that it was set

    You can also do:

      cat /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

    to see that PrioritizeNetworkReachabilityOverSleep was changed in the .plist file.

    MacBook Air, MacBook, Mac mini, OS X Mountain Lion (10.8.1)
  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    I am pretty newbie when it comes to this stuff, so for any other newbies out there, remember to change the permissions for the folder in which the plist file resides with Right Click, Get Info.

    About this part where we have to change the permissions...

  • Tony T1 Level 6 Level 6 (8,115 points)

    loïcfernandezcastrillon wrote:

     

     

    I am pretty newbie when it comes to this stuff, so for any other newbies out there, remember to change the permissions for the folder in which the plist file resides with Right Click, Get Info.

     

    About this part where we have to change the permissions...

     

    Why are you editing the .plist directly and messing around with permissions?

    Use pmset

1 ... 9 10 11 12 13 ... 16 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.