Skip navigation

New Macbook requires serial numbers every time.

335 Views 6 Replies Latest reply: Dec 12, 2012 2:54 PM by shuttersp33d RSS
A Liter of Light Calculating status...
Currently Being Moderated
Dec 10, 2012 1:49 PM

Recenty purchased the new Macbook SSD Drive and loving it. However, EVERYTIME I go to open Aperture it requires me to re-enter my serial number information.


1. I move Aperture over from my old macbook, but not through Migration.

2. Once I enter the serail number information for Aperture 3, I am notified it is a new serial number and the original needs to be entered. So I then enter the serial number for Aperture 2. Then it opens.

3. Unfortunately I have had to repeat this process a couple times.

4. Why?


Much Thanks in advance!

MacBook Pro with Retina display, OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,735 points)

    How are you entering the serial number? From an administrator account or a regular user account?

    Aperture is installed for all users on your mac, so the serial number is written to the system library, not the user library, and this requires read/write access for administrators. Do you enter your serial number using an administrator account?


    Also, you may have a corrupted "ProAppSystemID" file or Aperture cannot write to the System Library.


    To stop Aperture asking for the serial number, first check, if you still have an old file "ProAppSystemID" in your System Library.


    • Quit Aperture.
    • Go to your MacintoshHD and open the folder "Library", then "Application Support", then "ProApps".
    • Remove the File "ProAppsSystemID" to the Desktop, if it exist and restart Aperture.
    • Reenter your serial number, hopefully for the last time.


    Sometimes Aperture writes this file to a temporary directory, when it cannot write to the Library. If the above does not work, look at the temporary directory /tmp


    Use the Finder's "Go" menu


         Go > Got to folder    and  enter /tmp into the textfield. If you see the file there, move it to its proper location.


    In this case you may want to repair the permissions on your system drive; you can do this using the "First Aid" tools in "Disk Utility" (located in Applications > Utilities)




  • Owen A Level 2 Level 2 (215 points)
    Currently Being Moderated
    Dec 10, 2012 4:37 PM (in response to léonie)

    Also, make sure you are on Aperture 3.4.3 as it is supposed to resolve this issue.


    About Aperture 3.4.3

    Addresses an issue that could cause a licensed copy of Aperture to prompt for a serial number with each launch

  • Owen A Level 2 Level 2 (215 points)

    I missed this in your original post, but just dragging over the Application is not nessessarily supported for Aperture, if that is what you did. The installer from the DVD puts down a lot of supporting files such as ProAppSystemID. Have you tried deleting the app and installing again from the DVD?

  • shuttersp33d Level 4 Level 4 (1,540 points)

    Did you do all your updates?


    Sounds like you may have to update to the latest version of RAW support, version 4.02. You can check which version you are running by opening Aperture, clicking on the Aperture menu and choosing About Aperture. You should see the RAW version number in the window that opens.


    If you are up to date, try reprocessing the images that are coming up as unsupported Photos > Reprocess Original...


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.