1 Reply Latest reply: Dec 12, 2012 4:04 PM by stevejobsfan0123
mrwesleycrusher Level 1 Level 1 (0 points)

So I have a 3Gs and I want to update from 4.2.1  to 6, but when I go into Itunes and select Check for Updates, It says that 4.2.1 is the latest software. It is not. I know the 3Gs is compatible. Please Help


iPhone 3GS, iOS 4.2