9 Replies Latest reply: Dec 13, 2012 9:38 AM by OSX Tiger T
OSX Tiger T Level 1 Level 1 (0 points)

Even though this issue was reported in 10.7, the issue still remains in 10.8.

 

Background:

I have a home network consisting of a iMac (2011) and two Windows 7 PCS connected to a Netgear Gigabit switch. I on occasion transfer files to and from my Mac and my Windows PCs.

Pre OSX Lion, This situation worked fine. But since Lion and now Mountain Lion I am no longer able to copy files to my Mac from my Windows Pcs. Copying files from my Mac to my Windows Pcs work fine. In troubleshooting this issue, I found out in the Network system preference option after selecting ethernet and then the advanced button, then clicking on the Wins tab, that the Netbois and Workgroup fields are blank. After providing a Netbois name and the workgroup name the same as the Windows Pcs, then selecting the OK button generally works. Sometimes I have to go in multiple times before it takes the information but once it does everything works as it suppose until I reboot or shutdown and startup. If I do either when I go back into the Network in the System Preferences the fields are blank again.

 

 

I've followed some of the suggestions from the other support documents but they did not work for me:

 

1. Deleting the com.apple.systemperference.plist file and .lockfile

2. Create a duplicate ethernet service add the necessary changes then make that ethernet service the active one after disabling the original one.

 

None of these worked. I submitted on Apple Feedback this issue when I was still running OSX 10.7.2 but it never was fixed and now Mountain Lion behaves the same way. I will be submitting once again in hopes someone at Apple pays attention.

 

It seems this issue has to do with the Apple inhouse developed SMB share implementation. When they was using the SAMBA software I had no issues.

 

I even did a clean install of Mountain Lion to make sure the problem would not be transferred from Lion. Didn't make a difference.

 

Any help would be appreciated.


iMac (27-inch Mid 2011), OS X Mountain Lion
  • 1. Re: Workgroup setting won't stay after system reboot
    Justbrady Level 1 Level 1 (0 points)

    Im having the same issue, had it with OSX lion and now also OSX Mountain lion. Doe you have an SSD installed by anychance?

  • 2. Re: Workgroup setting won't stay after system reboot
    OSX Tiger T Level 1 Level 1 (0 points)

    Yes sir I do. I thought of that as well. But it doesn't make sense.

  • 3. Re: Workgroup setting won't stay after system reboot
    Shootist007 Level 6 Level 6 (16,640 points)

    OSX Tiger T wrote:

     

    Yes sir I do. I thought of that as well. But it doesn't make sense.

    Had the exact same issue when I had a SSD installed in my MBP.

     

    Only workaround was to go into Sharing and uncheck File Sharing then Recheck it.

     

    Once I replaced the SSD with a Seagate XT drive the problem went away.

     

    I suspect the OS is loading so fast from the SSD that some config files, or parts of some config files, gets skipped over. that is the only reason I could come up with Why this was happening.

     

    Just another Bug in the Most Advanced Operating System in the World.

  • 4. Re: Workgroup setting won't stay after system reboot
    OSX Tiger T Level 1 Level 1 (0 points)

    Thanks,

    That work around is great. A lot easier that typing in the info repeated before it takes just to have to do it again after the next reboot. If anyone has access to the Apple Bug Reporter, please add this bug for all of our sakes.

     

    Two things.

     

    1. After the initial ML install, the word workgroup was in the workgroup field. And that did not disappear after each reboot. Only when changing it to something else is when the problem manifests.

     

    2. I wonder if the Macbook Air and The new Retina Macbook Pro has this same issue being that they too come with SSD styled storage. If anyone have these macs please reply with your findings.

     

    Thanks

     

    p.s. Again would really appreciate someone with Apple Bug Reporter access to log this issue. Thanks again

  • 5. Re: Workgroup setting won't stay after system reboot
    Len Flier Level 1 Level 1 (0 points)

    Same problem here. My experience, too, is that this is an ongoing problem from 10.7 to 10.8.2.

     

    And, for what it's worth, I, too, have an SSD.

     

    My solution until now has been to enter the workgroup name and wait, sometimes as long as 5 or 10 minutes, for it to "take." But I just tried unchecking and rechecking file sharing and it works like a charm. Many thanks.

     

    Message to Apple: The more popular OSX becomes, the more users will be running it in environments with Windows machines. This has to work, people!

  • 6. Re: Workgroup setting won't stay after system reboot
    Howard_K Level 1 Level 1 (0 points)

    I am having the same problem. . . Tried the suggestions above, but each time I restart the WorkGroup in the WINS is blank and I can not connect to this OSX Lion computer with my Windows 7 computer. As soon as I enter the WorkGroup I am able to connect. Restart and problem reoccurs.

     

    I too have a SSD drive and running OSX 10.7.4.

     

    This is very frustrating as OSX to Windows networking has worked for many years, but no longer.

  • 7. Re: Workgroup setting won't stay after system reboot
    Shootist007 Level 6 Level 6 (16,640 points)

    It's some type of bug in OS X when combined with an SSD. As stated before the SSD loads the OS and support files so fast that something gets skipped over.

     

    The real work around is to Disable File Sharing then Re-enable it. That will place the correct Workgroup name in the WINS section.

     

    Then be like most Mac users and Never Shut the system down. Just put it into Sleep Mode.

  • 8. Re: Workgroup setting won't stay after system reboot
    OSX Tiger T Level 1 Level 1 (0 points)

    Again I would like to thank Shootist007 for his fine workaround. But it is important to be reminded that it is a workaround not a solution. Hopefully by APC users continuely to add to this thread maybe Apple will take notice and fix the problem.

     

    There is one additional question I hope people will respond to in this thread with this issue:

     

    Through consenus, it looks like the problem manifest itself on a SSD drive. I'm currently using a OWC MercuryExtreme Pro 6G drive as my system drive. It's using the Sandforce controller as well as over-provisioning.

     

    Does this issue only rears its ugly head with third-party SSD? Or are users with Apple supplied SSD having the same issue?

     

    Discuss

  • 9. Re: Workgroup setting won't stay after system reboot
    OSX Tiger T Level 1 Level 1 (0 points)

    What's different is that Apple changed how it implements SMB file-sharing. Before Lion, SMB file-sharing was handled by Samba. People who develop Samba move it to the more strict GPLv3 license which doesn't allow Samba to be used in a commercial distribution. http://apple.slashdot.org/story/11/03/24/1546205/apple-remove-samba-from-os-x-10 7-because-of-gplv3

     

    So Apple had to create an in house SMB solution.

     

    Message was edited by: OSX Tiger T