1 2 Previous Next 16 Replies Latest reply: Dec 13, 2012 9:53 PM by fruhulda
travelingG Level 1 Level 1 (0 points)

I have a 2009 intel iMac running Snow Leopard (10.6.8).  After installing a new hard drive, the OS, and all my programs, none of the iWork 09 programs (Pages, Numbers, Keynote) will open.  (All other programs work fine.)  For example, when I click on the Pages icon, it says "Pages could not open because of a problem... Click Report to see more detailed information and send a report to Apple."  When I click on Report, it says:

 

Process:     Pages [5683]
Path:        /Applications/iWork '09/Pages.app/Contents/MacOS/Pages
Identifier:  com.apple.iWork.Pages
Version:     ??? (???)
Build Info:  Pages-7270000~9
Code Type:   X86 (Native)

Parent Process:  launchd [5264]

 

Date/Time:   2012-12-10 06:52:01.480 +0000
OS Version:  Mac OS X 10.6.8 (10K549)

Report Version:  6

Sleep/Wake UUID: CF45A385-A5A1-495A-ABD4-5FA08FD560A5

 

Interval Since Last Report:      600344 sec
Crashes Since Last Report:       14

Per-App Crashes Since Last Report:   9

Anonymous UUID:                  39E2D0B7-95B8-433E-A50B-8070BC9FF2F9

 

Exception Type:  EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread:  0

 

Dyld Error Message:

  Library not loaded: @rpath/Inventor.framework/Versions/C/Inventor

  Referenced from: /Library/Application Support/iWork '09/Frameworks/SFCompatibility.framework/Versions/A/SFCompatibility

  Reason: image not found

 

Binary Images:

0x8fe00000 - 0x8fe4163b  dyld 132.1 (???) <4CDE4F04-0DD6-224E-ACE5-3C06E169A801> /usr/lib/dyld

 

Model: iMac9,1, BootROM IM91.008D.B08, 2 processors, Intel Core 2 Duo, 2.66 GHz, 4 GB, SMC 1.37f3

Graphics: NVIDIA GeForce 9400, NVIDIA GeForce 9400, PCI, 256 MB

Memory Module: global_name

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8E), Broadcom BCM43xx 1.0 (5.10.131.42.4)

Bluetooth: Version 2.4.5f3, 2 service, 19 devices, 1 incoming serial ports

Network Service: AirPort, AirPort, en1

Serial ATA Device: WDC WD1002FAEX-00Z3A0, 931.51 GB

Serial ATA Device: OPTIARC DVD RW AD-5670S

USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8502, 0x24400000 / 3

USB Device: Keyboard Hub, 0x05ac  (Apple Inc.), 0x1005, 0x24300000 / 2

USB Device: Apple Optical USB Mouse, 0x05ac  (Apple Inc.), 0x0304, 0x24310000 / 5

USB Device: Apple Keyboard, 0x05ac  (Apple Inc.), 0x021d, 0x24320000 / 4

USB Device: IR Receiver, 0x05ac  (Apple Inc.), 0x8242, 0x04500000 / 2

USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000 / 2

USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8215, 0x06110000 / 3

FireWire Device: FreeAgent FW, Seagate, Up to 800 Mb/sec

 

 

I tried reinstalling iWork, but it has no impact.  How can I fix this?  Thanks.


iWork, Mac OS X (10.6.8)
  • 1. Re: Pages won't open after installing new HD
    mende1 Level 10 Level 10 (89,570 points)

    Welcome to the Apple Support Communities

     

    If you restored from your Time Machine backup, you'll have to reinstall iWork from the disc

  • 2. Re: Pages won't open after installing new HD
    travelingG Level 1 Level 1 (0 points)

    I did reinstall it from disc.  That didn't work and resulted in the message I posted above.  I then tried it again.  Still doesn't work.

  • 3. Re: Pages won't open after installing new HD
    Jerrold Green1 Level 7 Level 7 (28,990 points)

    G,

     

    Try deleting the com.apple.iwork.pagess.plist located in HD > Users > (your account) > Library > Preferences.

     

    If you are using Lion or Mountain Lion, you can access the User Library folder from the Go menu in Finder while holding down the Option key.

     

    This sometimes clears that SFCompatibility error.

     

    Jerry

  • 4. Re: Pages won't open after installing new HD
    fruhulda Level 6 Level 6 (15,110 points)

    Did you do the Software updates after installing from the disc? You need to update to iWork 9.0.4. You can use this link

    http://support.apple.com/kb/DL1435

  • 5. Re: Pages won't open after installing new HD
    travelingG Level 1 Level 1 (0 points)

    Jerrold Green1, I am using Snow Leopard (10.6.8).  Should I still delete com.apple.iwork.pagess.plist?

  • 6. Re: Pages won't open after installing new HD
    travelingG Level 1 Level 1 (0 points)

    Fruhulda,

     

    I did Software Update after installing all my programs, and then I also used your link to update, but it didn't seem to have any impact on the problem.  Any other ideas?

  • 7. Re: Pages won't open after installing new HD
    fruhulda Level 6 Level 6 (15,110 points)

    Do delete the com.apple.iwork.pages.plist and also restart the computer with the shift key pressed. If Pages works  restart again without the shift key pressed.

  • 8. Re: Pages won't open after installing new HD
    Jerrold Green1 Level 7 Level 7 (28,990 points)

    travelingG wrote:

     

    Jerrold Green1, I am using Snow Leopard (10.6.8).  Should I still delete com.apple.iwork.pagess.plist?

    Yes, and use the path I listed. You can confirm if this is necessary before doing it if you wish.

     

    Switch to a different User Account and see how Pages works there. If necessary, go to Users and Groups in System Preferences and create a new, auxilliary, admin account for testing purposes.

     

    Jerry

  • 9. Re: Pages won't open after installing new HD
    travelingG Level 1 Level 1 (0 points)

    OK, I did this, and Pages still doesn't open.  This time the report says:

     

    Process:     Pages [135]
    Path:        /Applications/iWork '09/Pages.app/Contents/MacOS/Pages
    Identifier:  com.apple.iWork.Pages
    Version:     ??? (???)
    Build Info:  Pages-8290000~1
    Code Type:   X86 (Native)

    Parent Process:  launchd [100]

     

    Date/Time:   2012-12-11 07:05:42.513 +0000
    OS Version:  Mac OS X 10.6.8 (10K549)

    Report Version:  6

     

    Interval Since Last Report:      632994 sec
    Crashes Since Last Report:       16

    Per-App Crashes Since Last Report:   11

    Anonymous UUID:                  39E2D0B7-95B8-433E-A50B-8070BC9FF2F9

     

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000

    Crashed Thread:  0

     

    Dyld Error Message:

      Library not loaded: @rpath/Inventor.framework/Versions/C/Inventor

      Referenced from: /Library/Application Support/iWork '09/Frameworks/SFCompatibility.framework/Versions/A/SFCompatibility

      Reason: image not found

     

    Binary Images:

    0x8fe00000 - 0x8fe4163b  dyld 132.1 (???) <4CDE4F04-0DD6-224E-ACE5-3C06E169A801> /usr/lib/dyld

     

    Model: iMac9,1, BootROM IM91.008D.B08, 2 processors, Intel Core 2 Duo, 2.66 GHz, 4 GB, SMC 1.37f3

    Graphics: NVIDIA GeForce 9400, NVIDIA GeForce 9400, PCI, 256 MB

    Memory Module: global_name

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8E), Broadcom BCM43xx 1.0 (5.10.131.42.4)

    Bluetooth: Version 2.4.5f3, 2 service, 19 devices, 0 incoming serial ports

    Network Service: AirPort, AirPort, en1

    Serial ATA Device: WDC WD1002FAEX-00Z3A0, 931.51 GB

    Serial ATA Device: OPTIARC DVD RW AD-5670S

    USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8502, 0x24400000 / 3

    USB Device: Keyboard Hub, 0x05ac  (Apple Inc.), 0x1005, 0x24300000 / 2

    USB Device: Apple Optical USB Mouse, 0x05ac  (Apple Inc.), 0x0304, 0x24310000 / 5

    USB Device: Apple Keyboard, 0x05ac  (Apple Inc.), 0x021d, 0x24320000 / 4

    USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000 / 2

    USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8215, 0x06110000 / 4

    USB Device: IR Receiver, 0x05ac  (Apple Inc.), 0x8242, 0x04500000 / 2

    FireWire Device: FreeAgent FW, Seagate, Up to 800 Mb/sec

  • 10. Re: Pages won't open after installing new HD
    travelingG Level 1 Level 1 (0 points)

    Pages does not open even when I start from a different user account. 

  • 11. Re: Pages won't open after installing new HD
    Jerrold Green1 Level 7 Level 7 (28,990 points)

    travelingG wrote:

     

    Pages does not open even when I start from a different user account. 

    That rules out any plist file problem in the main User account. So the problem seems to be isolated to one of the System Library files or the app itself, or some problem with the OS. Grasping at straws here, but here are some other things to try, assuming that you have the original media for installing iWork:

     

    Use OnyX to purge caches and repair permissions for a general maintenance of your system.

     

    Use Yvan Koenig's iWork '09 uninstaller script to wipe all traces of iWork and it's ancilliary files from your system. Find it on this page.

     

    Reinstall iWork

     

    Jerry

  • 12. Re: Pages won't open after installing new HD
    travelingG Level 1 Level 1 (0 points)

    Jerry,

     

    Thanks so much.  That did the trick.  I appreciate your help!

     

    travelingG

  • 13. Re: Pages won't open after installing new HD
    Jerrold Green1 Level 7 Level 7 (28,990 points)

    Thanks for the feedback, tG.

     

    Good luck.

     

    Jerry

  • 14. Re: Pages won't open after installing new HD
    fruhulda Level 6 Level 6 (15,110 points)

    What exactly did the trick?

1 2 Previous Next