Skip navigation

Drag and drop manually ALBUMS in iPhoto 11 (9.4.2) !?

468 Views 12 Replies Latest reply: Feb 13, 2013 9:09 AM by Old Toad RSS
Henrik_Denmark Calculating status...
Currently Being Moderated
Dec 13, 2012 8:10 AM

I  want to again be able to drag and drop manually ALBUMS in iPhoto 11 (9.4.2) !? to a place I find correct ... I used to be able to do that in previous versions of iPhoto so when dragging an ALBUM in between two other ALBUMS a red line would appear and I could drop it there ... not anymore though ... am I missing something in the lates iPhoto or is this a bug!?!?

iMac (21.5-inch Mid 2011), Mac OS X (10.7.5)
  • Terence Devlin Level 10 Level 10 (121,655 points)

    Check your mouse/trackpad settings. It's not an issue with iPhoto.

  • Terence Devlin Level 10 Level 10 (121,655 points)

    I don't know but the problem doesn't exist on any of my machines, and a similar post last week was fixed in the mosue settings iirc.

  • Terence Devlin Level 10 Level 10 (121,655 points)

    Well it's a pretty esoteric bug then, as I say I've seen one report of it on here.


    Create a new account (systempreferences -> accounts or Users & Groups on 10.7 and 10.8), make a new Library in that account, import some shots  and see if the problem is repeated there.

  • Old Toad Level 10 Level 10 (113,135 points)

    Do you not get this indication when trying to move an album between two others?


    When that appears between the two other albums you can release it.  Using a trackpad certainly is more difficult in that than a mouse.



  • gospyro Level 1 Level 1 (0 points)

    As the shown in the photo in the post above, the answer is NO, I no longer get the line... it just trys to force me to create a folder for the album I am moving.  It USED to show the line, and everything worked great then.  The problem suddenly appeared about a month ago, but only in ONE of several iPhoto Libraries I have.  All the other libraries work just fine when I got to manualy place/sort an album, but not the one that I am having trouble with.  And 'esoteric' or not, it's really annoying, and is a bug/problem and it would be nice if someone had some legitmate suggestions for how to fix with it.

  • Old Toad Level 10 Level 10 (113,135 points)

    Try the following:


    1 - delete the iPhoto preference file,, that resides in your

         User/Home/Library/ Preferences folder.


    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/ folder (Snow Leopard and Earlier).


    or with Mt. Lion from the User/Library/Containers/



    3 - launch iPhoto and try again.


    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.


    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

  • gospyro Level 1 Level 1 (0 points)

    Thanks Old Toad... unfortunately, (if I did it right), it didn't work.  My other iPhoto libraries are working fine, but the one will still not let me move albums around,


    I'd just make a new library and move stuff over, but I've done a lot of sorting and labeling, and I really don't want to loose all that.  Better to just work around the problem until I find a solution.  But thanks!


    p.s.  Still open to ideas!!!

  • Old Toad Level 10 Level 10 (113,135 points)

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button,

        iPhoto Library Manager002.jpg 

        navigate to your Home/Pictures folder and select your iPhoto Library folder.

      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the Library ➙ Rebuild Library menu option

        iPhoto Library Manager001.jpg

      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments. However, books, calendars, cards and slideshows will be lost. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.



    Or you can use the paid version of  iPhoto Library Manager  to copy  the Events and albums from the problem library to the new library or just merge the problem library into the new library.  But the books, calendars, cards, etc. can't be copied just like in the rebuild function.  I'd try the rebuild first as you can do it with the free, demo version.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.