Skip navigation

Is my Magic Mouse Dead?

63396 Views 112 Replies Latest reply: Apr 9, 2014 2:37 PM by msigler RSS
  • Dylrob Calculating status...
    Currently Being Moderated
    Jul 1, 2012 7:04 PM (in response to jandarc)

    jandarc wrote:

     

    Sooo amazed and impressed with IB Retired's answer - I had swapped batteries but no green light on mine either. Can't believe that simple move got it back and would love to know why it died in the first place...

    Control+Option+Shift+Power actually resets the power management unit found in intel-based Macs. When the PMU malfunctions it can cause, among other things, peripherals to not be recognized by the system.

  • saxboda Calculating status...
    Currently Being Moderated
    Jul 19, 2012 6:09 PM (in response to smartsale)

    For me, it was a battery contact problem. I swiped the contacts with a Q-tip dipped in isopropyl alcohol, put in new batteries, tried IB Retired's reset, but nothing worked until I pressed both batteries hard into the recessed contacts. That finally worked. I hadn't seen the pushing trick mentioned, so I thought I'd post.

  • ipadpadi Calculating status...
    Currently Being Moderated
    Sep 22, 2012 5:09 AM (in response to DaveLord)

    I tried what Davelord has posted. Thanks.

    Opened the mighty mouse battery compartment and with a small flat screwdriver, carefully scraped off some form of white film build up on both positive and negative contacts and replaced the batteries and instantly.....mighty mouse is back to life. Try it.....really worked.

  • Harrisonau Calculating status...
    Currently Being Moderated
    Sep 27, 2012 4:55 AM (in response to Phuphan)

    Thanks Phuphan.

     

    Quite obvious once I took a closer look.

     

    Thanks again

  • hilltop2 Calculating status...
    Currently Being Moderated
    Oct 11, 2012 11:03 PM (in response to smartsale)

    I just changed to Energizers and mouse now works a treat! Thank you from not making me throw the mouse out the window, was getting very very........well you get it.

  • danrA2 Calculating status...
    Currently Being Moderated
    Nov 3, 2012 7:38 PM (in response to zberuko)

    How did you open the Magic Mouse? Did you pry off the top or something?

  • zberuko Calculating status...
    Currently Being Moderated
    Nov 4, 2012 8:43 AM (in response to danrA2)

    I've watched an youtube clip about how to do this.Here you have it.

    http://www.youtube.com/watch?v=2sk8pR3AmT4

    Good luck!

  • chandrakanta Calculating status...
    Currently Being Moderated
    Nov 20, 2012 1:31 AM (in response to opportunity)

    I had the same issue but fortunately could figure it myself. There are different manufacturers of AA batteries. Some have a small dot  which is somewhat protruding upwards at the positive side and some batteries have a flat plate at the positive side.

    In Mighty Mouse only the AA batteries having a flat plate at the positive side will work. The dot somehow will not work though the batteries are of the same power and specifications.

     

    Though strange this is the problem definitely.

     

    I tried with so many batteries, only the one specified above worked. For an example, Energizer works fine, but not Duracell..................

  • Miryo Calculating status...
    Currently Being Moderated
    Dec 13, 2012 3:14 PM (in response to smartsale)

    This happened to me today. Changed the batteries, no light.

    After reading this thread I gave the inside of the mouse a little dust and it works again.

    But it shouldn't have happend.

    I'm assuming there's USB mice which will let you side scroll and flip between pages?

  • PrincessBene Calculating status...
    Currently Being Moderated
    Jan 15, 2013 6:52 AM (in response to smartsale)

    Yesterday while powering down my MAChine, my Magic Mouse opted to not be a participant in the daily festivities. I changed the batteries "right-side up" and even had a stare-fest of sorts with this now non-working gizmo. So, thinking it may be due to dated batteries which had been given to me by a CubeMate that were the last two in a box of a gazillion, I changed to yet and still another pair of batteries. Still no power. I swiped a usb mini-mouse from another computer long enough to see if I'm the only one who had to engage in a magically stare-fest and search for possible solution(s). Since my Magic Mouse is tethered via Bluetooth I looked to see if there would be a dialogue such as "hold hands" or "reignite the love" or "communicate from the big guy to the little guy"...or simply "Connect." And sure enough, after following the Blue Tooth icon -->  Devices --> Apple Magic Mouse --> "Connect" path, we are as one again.   (Remind me to go retrieve the other batteries from the "trash".)

     

     

    Hope this helps!

    B.

  • Pedro Taquelim Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jan 19, 2013 5:16 PM (in response to smartsale)

    Hi,

    My Apple Wireless Magic Mouse does not track/move the cursor on screen, but it's connected to the iMac bluetooth. The batterys are full. I also replace them with new ones.

     

    I can left-click, right-click, double-click, scroll and swipe with one/two fingers. You name it! Everything works, except I cannot move the cursor, it does not track at all.

     

    I started having this problem when I went on vacation and turned the iMac off and also disconnected the power cable from the power socket for a couple of weeks. When I came back and turn it on, the Apple Wireless Mouse had this problem. But still, I could make it work if:

     

    1) I remove the mouse from the Bluetooth Preferences list clicking the "-" (minus) button and then put it back on again in the Bluetooth Configuration Assistant.

    2) After a while I noticed that after a restart I could click the mouse and I could just wait a while (3 to 5 minutes) and the mouse will start moving again, although the cursor would not track/move and behave as expected for 1 or 2 minutes (jittery, jumpy, slow, fast), but after that 1 or 2 minutes would eventually come back to normal.

    The problem would return after I would Pause the iMac. After I wake him up again the Mouse was not moving again and I had to go trough the process described on step 1 or 2 to make it behave correctly again.

     

    I think, in the beginning when I restarted the iMac in Safe Mode (keep pressing Shift in the restart process) the mouse would behave normal. So I thought that this was a software problem/conflict with some third party login files, etc. I deleted the LaunchAgents form the User Library. Didn't work. And also look inside the folder StartUpItems in the System Folder, but it was empty. But now, even if I restart in Safe Mode the mouse doesn't move. :-(

     

    Also, I tried all of this without success:

    http://support.apple.com/kb/HT1492

    http://lex1963.home.xs4all.nl/mm/Magic_Mouse_troubles/Main.html

    http://alvinalexander.com/blog/post/mac-os-x/problem-solved-apple-bluetooth-wire less-mouse-clicks-but-won-t

     

    Any ideas, please? I need help.

     

    Thanks!

  • Pedro Taquelim Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jan 20, 2013 3:52 PM (in response to Pedro Taquelim)

    Ok, forget it.

    I conected the magic mouse to other iMac (and to Windows 7 in Bootcamp) and the problem continues.

    So it's an hardware problem. the lens are dead probably. I'm a little ****** off rigth now. My mouse has 1 year and 2 months, this is no time span for a mouse do die. Bad luck or bad design? You decide... Apple.

     

    - Hello Mighty Mouse, can I join you in this box of retired and hopeless Apple artificial rodents, please? -.-

  • JezzinJapan Calculating status...
    Currently Being Moderated
    Feb 22, 2013 8:27 AM (in response to smartsale)

    I had the same problem, tried all the suggestions, nothing worked. So just as I was going to bed, defeated I thought I would try the batteries out of the TV remote and guess what, it worked. I don't pretend to understand it, maybe Apple has had a falling out with Duracell, who knows....

  • flakarek Calculating status...
    Currently Being Moderated
    Mar 2, 2013 5:57 PM (in response to IB Retired)

    Thanks IB Retired it worked for me. You saved me £59 thank you!

  • samdaams Calculating status...
    Currently Being Moderated
    Mar 6, 2013 1:36 AM (in response to smartsale)

    IB Retired's solution also worked for me. There seems to be two main issues people posting in this thread are having. One is the PMU that needs resetting (IB Retired's fix), the other is that there is an issue with the batteries (wrong type/thin layer of film on connectors etc). You can tell which of the solutions to choose based on the green light on the mouse.

     

    If the green light is showing, but no connection, try resetting the PMU using IB Retired's Ctrl+Shift+Option fix.

    If the green light is not showing, this is a battery issue (kind of obvious ).

1 2 3 4 5 6 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.