Skip navigation

'ubd' process huge cpu load

46126 Views 53 Replies Latest reply: Jul 11, 2013 5:34 PM by jessefromsanta barbara RSS
  • D1234r Calculating status...
    Currently Being Moderated
    Nov 8, 2012 2:47 AM (in response to D1234r)

    A little bit more on the problem, when my iMessage inbox (on my mac) was clear, after deleting files the UBD process was exibiting normal behaviour, however, after a few imessages have come through the UBD process is back to its normal huge processor activity though it seems less constant than before

  • djlee Calculating status...
    Currently Being Moderated
    Nov 18, 2012 10:26 PM (in response to hamster116)

    Thank you for that info Hamster. My 2012 MBAir was chewing up battery and running hot since updating to 10.8.2. I had 9 certificates and keys for this Ubiquiy thing so I exported them and then deleted them out of the Keychain. Everything seems to be working fine without them.

     

    Anyone else who tries this should take a full backup in case my advice proves wrong!

     

    Edit: I've just had 6 Ubiquity related items appear in the Keychain, but this time there is no heating, chewing battery, or excess CPU usage.

  • antoniofaoro Calculating status...
    Currently Being Moderated
    Dec 11, 2012 6:38 AM (in response to hamster116)

    Disabling Documents&Data in iCloud worked for me.

  • TomorrowPlusX Calculating status...
    Currently Being Moderated
    Dec 14, 2012 10:46 AM (in response to antoniofaoro)

    Disabling Documents & Data is for me the only fix as well, but it's hardly a *real* a fix, though, is it? It's a workaround, and honestly there are some situations where I'd like to have documents and data enabled.

  • RiggerIII Calculating status...
    Currently Being Moderated
    Mar 28, 2013 9:25 PM (in response to D1234r)

    I just signed out of iCloud, restarted the Macbook Air and signed back into iCloud. Now all is good with ubd and the fan and process are back to normal and quite.

  • wizbang_fl Level 1 Level 1 (45 points)
    Currently Being Moderated
    May 4, 2013 9:52 PM (in response to RiggerIII)

    I found my issue was photostream.  I had enabled it on my iPhone (someone wanted to show me how "great" it was)  I never really was interested in it, I like to manage my photos manually.  Anyway, I didn't enable it on my laptop, but did on the desktop.  So every photo I took or was added to my friends photo stream was synced to the cloud and then to my desktop.  The laptop kept running the error "unknown dataclass shared streams" with ubiquity (UBD) eating up cycles, memory, and internet bandwidth with all the syncing and trying to sync. 

     

    As a side note I also have had issues with setting up Google accounts in Mountain Lion (email, calendar, google drive, etc)  Seems that it also wants to try to sync constantly and tries to update every couple minutes via Keystone, somehow UBD gets in the mix as well.  I took all the google software and accts out and it cleared up the Keystone & UBD related issues. 

     

    Back to Photo Stream... As soon as I disabled (Photo Stream and Shared Streams) on the phone and iMac things quickly settled down to a quasi calm state.  (At least for Mountain Lion)

  • EIF1966 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2013 4:36 AM (in response to wizbang_fl)

    He There,

     

    I have read through all this post and tried everything ya'll suggested. Nothing worked after 10 minutes ubd was back :-(

     

    Only after login out iCloud the udb process stopped eating my processor time...

    I don't use iCoud actually and don't understand why it is on!

     

    Hope my 2 cents helps someone.

  • EIF1966 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2013 5:13 AM (in response to EIF1966)

    Still my Keychain Access will not start. It give a Not responding........grmph!!

  • jessefromsanta barbara Calculating status...
    Currently Being Moderated
    Jul 11, 2013 5:34 PM (in response to An Average User)

    Thank you for this elegant solution.  I followed suit and my one-week old 13" Macbook Air is back to 92% idle - for the time being.  Again, here is the link to the process that worked for me: http://support.apple.com/kb/TS1544

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.