4 Replies Latest reply: Dec 16, 2012 5:25 AM by Philip Kalina1
Philip Kalina1 Level 1 Level 1 (5 points)

I had to restore my entire hard disk due to corruption by Apple's iPhotoLibrary Upgrader utility. After a Time Machine restore (suggested by Apple Support), I realized that I did not backup the AP3 application. I got out my original AP3 install DVD, installed it, then upgraded it thru Software Update to vs 3.3.2.

 

After spending a day reconnecting my images to their references and updating the previews, I realized that my movie/video files are no longer playable in AP3.

 

The movie thumbnail appears distorted. Clicking on it opens the Viewer, but no movie appears. When I select 'Show in Finder' for a movie, the master file is correctly shown. The Master file is fine, it plays in Quicktime just fine.

 

I tried to reonnect the video files, but they have 'Online' status and the reconnection accomplishes nothing. I did note that when I go into the reconnect panel, I cannot see any movies in the bottom window, just jpegs and raw image files.

 

I took a new movie with my camera and tried to import it. Aperture does not see the movie on my flash card.

 

I tried opening my other libraries and observe the same behavior. So this problem is with the application and NOT the specific library.

 

I've also repaired permissions, and rebuilt the library, with no success.

 

The only thing I haven't tried is to reinstall AP3, which I just did yesterday. It just feels like my copy of AP3 doesn't have all the 'movie parts' included.

 

Any help or suggestions are appreciated. Thanks.


Aperture 3, OS X Mountain Lion, imac i7