Skip navigation

pages and numbers not emailing after update

465 Views 14 Replies Latest reply: Dec 17, 2012 8:15 AM by Escaport RSS
rossannett Calculating status...
Currently Being Moderated
Dec 12, 2012 6:03 AM

Hi all,

 

I am relatively new to mac, but love it.

 

i have had my iphones for the last 5 years, and iPads for the last 3, but only had my 27" iMac for 2 months, but find it amazing.

 

i have always used the feature share>pages / pdf / word, and it has always sent no problems, however today (after the latest update) i am unable to.

 

tried the usual windows problem solving method (restart!!!) and that hasn't worked, so I'm kinda at a loss.

 

I saved the document from iCloud to my desktop, and manually attached it to the email, but that is a windows way of doing things, and I dont like it!!!

 

 

so can someone please help me?

 

many thanks

 

Ross

 

mid 2010 27" running OS X 10.8.2

pages '09 version 4.3 (1048)

 

thanks

iMac, OS X Mountain Lion (10.8.2)
  • fruhulda Level 6 Level 6 (14,775 points)
    Currently Being Moderated
    Dec 12, 2012 6:35 AM (in response to rossannett)

    You could try deleting the com.apple.iwork.pages.plist from the preference folder on the users Library folder. To find that Library you click on Go in the Finder menu bar while holding down the Option/Alt key. Do this with Pages quitted.

  • Escaport Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2012 10:09 AM (in response to rossannett)

    I'm having the same issue. When I attempt to email from the share menu, nothing happens. If I attempt to export Word from the Share menu, I get a error that an unknown error has occurred. I have deleted preferences. Deleted Pages and reinstalled as well. Issue is still happening.

  • Jerrold Green1 Level 7 Level 7 (28,215 points)
    Currently Being Moderated
    Dec 13, 2012 3:12 PM (in response to rossannett)

    Ross,

     

    Share Menu:

    Screen Shot 2012-12-13 at 6.01.52 pm.png

    Do you not have this Share menu? Or, does nothing happen when you choose one of the options?

     

    Jerry

  • Escaport Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2012 3:20 PM (in response to Jerrold Green1)

    For me:

     

    Screen+Shot+2012-12-13+at+6.01.52+pm.png

     

    Actually, I'm remembering it doesn't crash pages, it brings up an "Unknown Error has Occured" dialog.

  • Jeff Shenk Level 4 Level 4 (2,000 points)
    Currently Being Moderated
    Dec 13, 2012 3:36 PM (in response to Escaport)

    Are you trying a name for your file with unusual characters in it? Something other than letters and numerals?

  • fruhulda Level 6 Level 6 (14,775 points)
    Currently Being Moderated
    Dec 13, 2012 9:59 PM (in response to Escaport)

    When an application isn't working as it should there are several things to try. Repair permission using the free Onyx application, delete cashes, delete and reinstall Pages.

    You could first try Pages in another user account on the computer. You can create a new account in System Preferences > Accounts

  • Jeff Shenk Level 4 Level 4 (2,000 points)
    Currently Being Moderated
    Dec 17, 2012 4:25 AM (in response to rossannett)

    You shouldn't be too embarrassed; it doesn't seem like it would have been too difficult for the developers to display some kind of error message like "The operation failled because the filename contained an illegal character."

     

    That would, of course, violate the Guidelines for Error Messages (based, I believe, on the older Code for Carnival Fortunetellers) that stipulates that error messages should be sufficiently cryptic that they are only meaningful after the error has been independently explained, and that furthermore they should be ambiguous enough to apply to a multitude of possible failures.

  • Escaport Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2012 5:27 AM (in response to Jeff Shenk)

    Just verified, and that does not solve my issue. Using iCloud, I can convert to Word in my iPad. Just the updated MBP is having issues. My desktop that has not been updated can convert as well.

  • Jeff Shenk Level 4 Level 4 (2,000 points)
    Currently Being Moderated
    Dec 17, 2012 7:40 AM (in response to Escaport)

    I am not sure what you verified and what you tried that did not solve your issue.

     

    I do not use Mountain Lion, I don't export to Word and if I did, I probably would not use the Share menu to do it. I just asked a question, based on what I have read here, which apparently did answer Ross' issue.

     

    Based on what I've read, there are two common reasons why the Share > Send via Mail > Word process fails on Mountain Lion.

     

    First, apparently Mountain Lion has tightened its requirement that filenames not include illegal characters (possibly only when exporting to a Mail attachment). Earlier systems would let these illegal names pass, and often there would be no problems. If your desktop is not running Mountain Lion, it would not have this issue, nor, as faar as I have read, would your IPad. If the Share > Send via Mail > Word process fails on your MacBook Pro, even though you specify a filename that contains only letters, this is not your issue.

     

    The second reason I've seen for this process to fail is when Mail is not set up to send email. Some people mistake the menu item to mean email as a generic term, whereas, at least on my Snow Leopard system (and in Jerry's screenshot), it specifically refers only to Apple's Mail program. Since you report problems with a simple export as well as with sending to Mail, I would not expect this to be your problem.

     

    Does it still fail to export if you create a very simple document, say one word: "Test." typed into the blank wordprocessing template and exported as test.doc?

  • Escaport Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2012 8:15 AM (in response to Jeff Shenk)

    I am using Mountain Lion. I'm not aware of any differences between File>Export>Word and Share>Export>Word. Share>Send via Mail>Word is as far as I know, an normal export with an added script of sending via Services to Mail. Apparently it does have the added issues of suppressing export error dialogs though.

     

    So the plot thickens a bit now. I tried a few things.

     

    1. Altering the name of an existing document that was exhibiting the issue and save. Then export.
    2. Creating new basic test document. Then export.

     

    The first case still showed the issue. The second case worked as expected. From this I looked a bit more into the first case's document. The only part of the document that was not just standard text was a few unordered bullet points and a page break or two.

     

    This led to creating a third test document that had bullet points and page breaks. This document exported without issues as in the second test case.

     

    After this I coppied the text of the first case's document and pasted it into a brand new test document. Then tried to export. The new document failed to export and resulted in the "An unknown error has occurred" error dialog. (Note: This is using Export>Word, not the Word>Send via Mail command. Word>Send via Mail results in no action at all, as if you have not given a command. For all purposes it reacts exactly like the Export>Word command to these test, just without the error dialog.)

     

    I'm guessing that there is some corruption with my document that didn't show itself until the v4.3 update.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.