1 2 3 4 Previous Next 51 Replies Latest reply: Apr 1, 2013 11:30 PM by LaiPod
L-I-B Level 1 Level 1 (0 points)

Has anyone else notice that TurboTax for 2012 will require OS X v 10.6.8 or newer? How can we get them to support 10.5.8?


MacBook Pro, Mac OS X (10.5.8)
1 2 3 4 Previous Next