11 Replies Latest reply: Dec 22, 2012 4:27 AM by stagger82
stagger82 Level 1 Level 1 (0 points)

I use Outlook 2010 on a Windows machine at work. On my MacBook I use Outlook 2011 and have the Exchange calendar configured for iCal. Sync'ing works fine, except this one annoyance.

 

Since upgrading to Mountain Lion copies of existing, repeating calendar events keep appearing in my Outlook drafts folder. Every few days I have to empty it, sometimes from 50 event copies or more.


MacBook Air (11-inch, Mid 2012), Mac OS X (10.7.4)
  • 1. Re: How can I stop Exchange calendar event copies appearing in drafts?
    Boinus Level 1 Level 1 (0 points)

    I have the same problem too!

     

    since I upgraded to ML, a calendarentry goes into drafts (multible)!

    If I kill this event from the calendar, the next entry goes into drafts.

    It happens with both onetime-calendar-entrys and also serial-calendar-entrys.

    Also tried to delete the ExchangeProfile on the IMac and recreate it - no change.

     

    My Setup is: CompanyExchange2007 - Win-Outlook2010 in Company - Standard-Mail-App and iCal on my Home-IMac - Iphone 4S

     

    Hoping this problem will be solved and not pushed from Apple to MS and viceversa.....but it definitley started when I upgrade to ML!

     

    Other communities also reports this error:

    .) http://apple.stackexchange.com/questions/63163/how-to-prevent-calendar-alerts-fr om-becoming-drafts-in-mail-app

    .) http://social.technet.microsoft.com/Forums/da-DK/outlook/thread/76aefaaa-6e96-47 7d-b66d-cd7e7b5aca60

     

    kind regards

     

    Boinus

  • 2. Re: How can I stop Exchange calendar event copies appearing in drafts?
    PhantomSoul Level 1 Level 1 (10 points)

    This is apparently a bug in either Mountain Lion or iOS 6 (or both) in which if you have any calendar syncing over Microsoft's ActiveSync protocol (most commonly used with either MS Exchange or Google Calendar), any all-day events created on the remote system, i.e. not the iPhone, iPad, or Mac, do not get reported back to the remote system correctly by the Apple device, and as a result, the remote system creates a new unsaved calendar entry each time the two systems sync. In Outlook (with Exchange), for example, this appears as a draft, complete with an alert if you initially requested one, even if you dismissed it already.

     

    Until Apple fixes this bug, there's really only 2 things you can do to prevent all the drafts and alerts from constantly piling up:

    • Disable the affected calendars from syncing with your iPhone/iPad/Mac, or consider a different protocol, like CalDAV, if available.
    • Avoid using all-day events on the remote calendar. This may be difficult to do though, since many all-day events may be created by someone else inviting you to an event, and changing it from an all-day event may change it for everyone. However, you can avoid this problem with all-day events you create for yourself by simply making them run from 12:00 am to 11:59 pm instead of marking them all-day events.
  • 3. Re: How can I stop Exchange calendar event copies appearing in drafts?
    darwinp5101 Level 1 Level 1 (5 points)

    I too, was experiencing this. There seems to be no indication of a solution anywhere on the web. HOWEVER, I figured it out.

    Here's the solution: Strangely, it's not really an exchange issue, but rather an issue with calendaring on the OSX side.

    So you understand, here's the configuration that can cause problems:

    • you are using an exchange server to connect your email/calendar/notes/tasks...
    • You use a PC (or VM PC) for some/most of your exchange/outlook activities
    • You may or may not have MS Office 2011 (Mac) installed.
    • You have one or more Apple devices connected to your exchange account (iPhone, iPad, any Mac)

    After installing Mountain lion, you start noticing events being magically duplicated every few minutes in your outlook draft folder. If you delete an event, another one takes its place.

    HERE IS THE FIX:

    Short answer: Sync all calendars on all devices

    On the apple side (OSX, IOS) you MUST turn on calendar sync in all the exchange accounts on all your devices. I thought I had, then discovered that my MS Office Outlook on my Mac was missing that sync. It doesn't seem to matter which apple device is missing the sync, it only takes one of them. Once you set calendar sync to "on" for all the apple devices that access that calendar, just like magic, the phantom multi event creation stops.

    You should check all MS products on the OSX/IOS devices AND all apple devices that allow syncing. I haven't turned on notes sync through the cloud, so that isn't one of the items that cause problems.

    If you do this and the multi still appears, you missed something on one of your apple devices.

    Sweet!

  • 4. Re: How can I stop Exchange calendar event copies appearing in drafts?
    stagger82 Level 1 Level 1 (0 points)

    Exchange calendar syncing was active on the both my two Apple devices (MacBook and iPhone) right from the start. I am glad if doing what you described solves the problem for some, but unfortunately it doesn't solve the problem for me.

  • 5. Re: How can I stop Exchange calendar event copies appearing in drafts?
    darwinp5101 Level 1 Level 1 (5 points)

    Screen Shot 2012-12-18 at 9.20.16 AM.pngOk, I just looked again.

    Further information: I'm not using the Cloud for any of the calendar synching. Try turning off cloud sync for calendaring and on your mac, under Mail, Contacts & Calendar, sync your exchange account calendars, turn off cloud calendars.

    Screen Shot 2012-12-18 at 9.23.20 AM.png

    Write back is that helps.

  • 6. Re: How can I stop Exchange calendar event copies appearing in drafts?
    stagger82 Level 1 Level 1 (0 points)

    Thanks for posting the screenshots. You can view my current settings below. iCloud calendards are all turned off. The Gmail calendar I can't turn off, I need it.

     

    Bildschirmfoto 2012-12-19 um 17.52.39.png

    Bildschirmfoto 2012-12-19 um 17.52.46.png

    Bildschirmfoto 2012-12-19 um 17.52.54.png

  • 7. Re: How can I stop Exchange calendar event copies appearing in drafts?
    darwinp5101 Level 1 Level 1 (5 points)

    Ok, I assume that you have the same settings on each of your other apple devices.

    Google should not be an issue.

     

    The only other thing i can think of: if you are using MS Office 2011 for Mac, there is one more set of settings. From outlook on your mac, go to preferences, then select Sync Services

     

    I've done this:

    Screen Shot 2012-12-18 at 9.20.16 AM.png

     

    Cross your fingers (we use it to generate more luck).

    Then go back to your draft folder and (hopefully) delete the duplicate entries for the last time.

     

    Let me know.

  • 8. Re: How can I stop Exchange calendar event copies appearing in drafts?
    stagger82 Level 1 Level 1 (0 points)

    Unfortunately I can't see your Outlook sync settings because the screenshot shows the OS X "Mail, Contacts  & Calendars" OS X preference pane. In the Outlook Sync Services pref pane all is deactivated.

  • 9. Re: How can I stop Exchange calendar event copies appearing in drafts?
    darwinp5101 Level 1 Level 1 (5 points)

    Sorry about that. Let's try this one.

    It may be your key to success.

    Screen Shot 2012-12-19 at 10.12.13 AM.png

    I believe this may be what is creating the multiple drafts. Without sync on this side, it appears that the mac can't resolve the events properly.

  • 10. Re: How can I stop Exchange calendar event copies appearing in drafts?
    stagger82 Level 1 Level 1 (0 points)

    Thanks for the suggestion! When I remove the Exchange account from the system preferences and use only Outtlook's calendar sync the duplicates are gone. Unfortunately that way my Exchange calendars are unsuable, because they are all merged into a single calendar in iCal, plus one iCal calendar for every Outlook category. So I'm switching back to Exchange in the system preferences / iSync. I'd rather be annoyed by the duplicates than not have a one-in-all calendar solution on the MacBook.