2 Replies Latest reply: Dec 19, 2012 11:01 AM by Chris Connors
Chris Connors Level 1 Level 1 (120 points)

If I select Share > Email/Email Link to this page' in Safari, and Mail is already running, rather than just creating a new message, it launches a second instance of Mail (same executable though) and then creates a new message.

 

Screen Shot 2012-12-19 at 11.42.30 AM.PNG

 

I have already rebuilt Launchservices with Cocktail, to no avail.

  • 1. Re: Safari 'Email/Email Link to this page' launches Mail Again
    Linc Davis Level 10 Level 10 (118,525 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether your problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:
    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click  Log in.
    *Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • 2. Re: Safari 'Email/Email Link to this page' launches Mail Again
    Chris Connors Level 1 Level 1 (120 points)

    Thanks for those detailed suggestions.

     

    Logging in as another user, Safari does not launch a second instance of Mail.

     

    After booting and then logging in to my user account in Safe Mode; Safari does not launch a second instance of Mail.

     

    After rebooting and logging in to my user account in normal mode, Safari does not launch a second instance of Mail.

     

    However, I should have mentioned that before I knew how to rebuild launch services, I had tried these same steps and thought it was fixed by the Safe Boot; I know now that with time it will return. What we've learned:

     

    It seems local to my account.

     

    Something that Safe Boot does temporarily fixes it.

     

    It returns with time.

     

    Looking at my Startup Items, I'm betting Liteswitch X is the culprit; I'll disable it and see if that staves off the recurrence.