1 2 Previous Next 20 Replies Latest reply: Jun 14, 2013 10:08 PM by Robert Schwenkler
Robert Schwenkler Level 1 Level 1 (10 points)

Help!   I updated to iphoto11 a month or two ago and now when I start iphoto it loads but is unresponsive for 5-10 minutes... afterwhich all if fine.  I quit and restart iphoto and the same thing all over again.  the activity monitor shows maybe 10%cpu use for iphoto during this startup time... there are no messages or alerts as to anything happening.  Help please!


iMac (27-inch Mid 2010), OS X Mountain Lion (10.8.2), 8gig ram
  • 1. Re: iphoto freeze for 5-10 min. @ startup
    LarryHN Level 9 Level 9 (56,645 points)

    In the iPhoto preferences turn off all web sync, sharing and item counts

     

    LN

  • 2. Re: iphoto freeze for 5-10 min. @ startup
    Robert Schwenkler Level 1 Level 1 (10 points)

    Under Sharing- Look for shared photo's and Share my photo's are unchecked all ready.

     

    Under Accounts- I had email accounts that had imported that never worked correctly... I just got rid of them and set the email to go via mac mail not iphoto.   Facebook account is still there.. I use this and don't want to get rid of it...

    I restarted iphoto after getting rid of email accounts and no help... I timed it this time- iphoto took 14 minutes to become responsive

     

    ps: This was not a problem at all, ever, before the upgrade to iphoto 11

  • 3. Re: iphoto freeze for 5-10 min. @ startup
    LarryHN Level 9 Level 9 (56,645 points)

    And web syncing? FaceBook, Flickr, etc?

     

    Something you have set is looking for something that it can not be found and is hanging looking for it

     

    LN

  • 4. Re: iphoto freeze for 5-10 min. @ startup
    Robert Schwenkler Level 1 Level 1 (10 points)

    Just facebook... I hesitate deleting that since I do use this... it says:

    12 albums will be removed from your iPhoto library.

     

    Would time machine let me recover these albums if needed?

  • 5. Re: iphoto freeze for 5-10 min. @ startup
    Keith Barkley Level 5 Level 5 (5,250 points)

    I thought this was fixed, but do you have boot camp?

    Turn off spoltlight indexing for the bootcamp volume.

  • 6. Re: iphoto freeze for 5-10 min. @ startup
    Old Toad Level 10 Level 10 (115,660 points)

    You can delete your Facebook account, check to see if it makes a difference and then add it back in either case. 

     

    Also Try this:  launch iPhoto with the Option key held down and create a new, test library.  Import some photos and check to see if the same problem persists. If the problem persists in the new library then it's a system wide problem so try the following: make a temporary, backup copy (if you don't already have a backup copy) of the library and try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).

    home.PNG

    or with Mt. Lion from the User/Library/Containers/com.apple.iPhoto/
    Data/Library/Caches/com.apple.iPhoto
    folder

     

    iP11mtlioncache.png

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

     

    If the problem didn't appear in the new library then your current library is the culprit.  In that case post back and we'll try a different approach.

     

    OT

  • 7. Re: iphoto freeze for 5-10 min. @ startup
    Robert Schwenkler Level 1 Level 1 (10 points)

    No boot camp

  • 8. Re: iphoto freeze for 5-10 min. @ startup
    Robert Schwenkler Level 1 Level 1 (10 points)

    Thanks Toad for getting in...

    1. I try the Test iphoto account with about 6 photo's and all is good- no freeze on restart.

    2. I go back to original iphoto (wait 10+ minutes for it to become responsive) and delete facebook account. Restart... wait 10+ minutes again... that didn't help so it seems like the iphoto install is good- unless the problem is dependent on # of photo's in library... I got 12,475 photo's and 96 iphone vid clips  20.7gig

     

    Otherwise I'm thinking this must have to do with a faulty indexing... I think I remember the upgrade to iphoto11 had a waiting period where it was re-indexing my library...   I think this indexing must be happening every time I restart iphoto for this library.

  • 9. Re: iphoto freeze for 5-10 min. @ startup
    Old Toad Level 10 Level 10 (115,660 points)

    Your library's size is not anywhere near reaching its limit. How much free space do you have on your hard drive?

     

    Did you try the repairs that I listed in my last post?

  • 10. Re: iphoto freeze for 5-10 min. @ startup
    Robert Schwenkler Level 1 Level 1 (10 points)

    I'm still working with this... haven't had time to get into this in detail and not the use for iphoto since... so just getting back now...

    I did the option start and make a new library and all is good, I did the facebook stuff and no difference...  so "If the problem didn't appear in the new library then your current library is the culprit.  In that case post back and we'll try a different approach."

     

    One other bit of info... since the last post I have a new imac and brought over only files and user settings.  When I first started iphoto it did a library repair/rebuild  BUT   the library is still freezing for 10+ minutes on startup...

    So what do we do with this library???  I do have time machine... maybe I need to pull out the recent photo's and then go back a few months on the library... re import thenew photo's???  Pain in the butt   but....

  • 11. Re: iphoto freeze for 5-10 min. @ startup
    LarryHN Level 9 Level 9 (56,645 points)

    turn off internet access and launch iPhoto - if this cures it then we know where to start

     

    LN

  • 12. Re: iphoto freeze for 5-10 min. @ startup
    Robert Schwenkler Level 1 Level 1 (10 points)

    Thanks for keeping w/me on this... wifi / internet access off and same problem...

    Iphoto loads right up and looks OK BUT nothing is selectable- iphoto is non-functional for the 10+ minutes. There is no spinning wheel, no high cpu use (5-10%), no freeze indicated in Activity Monitor... I can work fine in other programs...

  • 13. Re: iphoto freeze for 5-10 min. @ startup
    LarryHN Level 9 Level 9 (56,645 points)

    Back up your iPhoto library, Depress and hold the option (alt) and command keys and launch iPhoto - rebuild your iPhoto library database

     

    LN

  • 14. Re: iphoto freeze for 5-10 min. @ startup
    Robert Schwenkler Level 1 Level 1 (10 points)

    I did as you say and rebuild went smooth- only took 2-3 minutes, iphoto was up and functioning... Yea!   BUT   I close it and restart and the freeze is back again!     This time I waited 25 minutes and it didn't unfreeze so I force quit.  I did a diskutility repair permissions.  Restart iphoto and it says I need to rebuild library... I do so and when iphoto comes up after rebuild it is froze again... I'm thinking I need to export/save any recent photo's and go back to an old time machine version...    pain in the butt!

1 2 Previous Next