1 2 Previous Next 23 Replies Latest reply: Jan 31, 2014 10:51 AM by Tamarajean
swarmowski Level 1 Level 1 (0 points)

Weird happenings in MobileMe - iCloud conversion on email.

 

The incoming mail server is showing p02-imap.mail.me.com instead of the imap.mail.me.com.

Can't change the server, for the Incoming Mail Server field is greyed out, and you can't mouse click to activate the field.

When I try to tab into the field it skips over to User Name field.

 

Get error message

Invalid Incoming Mail Server

The "Incoming Mail Server" field cannot be empty.

 

Any ideas on what's going on?


iMac, OS X Mountain Lion (10.8.1), 3.4 GHz i7
  • 1. Re: icloud incoming mail server field cannot be empty
    RotnDog Level 1 Level 1 (0 points)

    I'm not sure if you have an iPad or iPhone but I was having the same problem until I set up my @me.com email address on my iPad. I just went to settings > iCloud and turned the mail "on." It immediately changed the incoming server on my desktop and now I can send and receive emails from that account.

     

    Hope this helps..

  • 2. Re: icloud incoming mail server field cannot be empty
    litldannyh II Level 1 Level 1 (0 points)

    I had the same issue and I kept trying to solve the grayed out p03-imap.mail.me.com or grayed out mail.example.com.       

    But your post RotnDog got me headed in the right direction.    

    Someone else provided the clue of turning off mail in iCloud.     Then enabling my email accounts in Mail entering email address and password for each account.    But this time...
    I ignored the grayed out settings and went to the next step.

    I went to my iPhone & my iPad and setup those email accounts there with matching on/off triggers....and now my Mac  finished the correct setup.     

     

    In Mail, all I had to enter was my "full name", email address, and password for each email account.
    Move on to each mobile device and confirm a matching mail setup there...

    Then just close that prefs window...and go back to iCloud prefs.

     

    All my email then began to repopulate.

     

    It was much simpler that I had tried to make it.     
    But what a painful experience uncovering how simple it could have been.

  • 3. Re: icloud incoming mail server field cannot be empty
    jazzfan_1 Level 1 Level 1 (0 points)

    I thought Apple is the reference for easy use (and setup)  

     

    What a nightmare .....

  • 4. Re: icloud incoming mail server field cannot be empty
    Roger Wilmut1 Level 9 Level 9 (65,525 points)

    The 'p-' number is normal. You should not need to set iCloud email up in Mail, it's done automatically when you sign into System Preferences>iCloud and enable Mail in the checklist there. The p- number appears to reference different geograhically located servers, so that everyone in the world isn't trying to collect their mail from just one server. As long as your email is working you should leave the settings alone: they are greyed out to stop you messing about with them.

  • 5. Re: icloud incoming mail server field cannot be empty
    jazzfan_1 Level 1 Level 1 (0 points)

    Hi Roger ...

    But doing it that way (Via the System Preferences>iCloud and enable Mail) I receive ... "iCloud Mail couldnt' be enabled from the iCloud  Preferences Pane" .... and so .... still stuck with all this complicated Set-Up ....

  • 6. Re: icloud incoming mail server field cannot be empty
    Roger Wilmut1 Level 9 Level 9 (65,525 points)

    Obviously that shouldn't be happening. Are you able to set up Calendar and Contacts syncing? Can you access your mail at http://icloud.com ?

  • 7. Re: icloud incoming mail server field cannot be empty
    jazzfan_1 Level 1 Level 1 (0 points)

    Yes for all your questions ... iPhone 4s & iPad syncing perfectly for contacts and calendar entries ... and everyhing appearing correctly on http://icloud.com ... :-(

  • 8. Re: icloud incoming mail server field cannot be empty
    jazzfan_1 Level 1 Level 1 (0 points)

    iCloud mail account works fine on iPad & iCloud .... also ...

  • 9. Re: icloud incoming mail server field cannot be empty
    Roger Wilmut1 Level 9 Level 9 (65,525 points)

    If you try setting it up manually in Mail don't worry about the p-number - just enter imap.mail.me.com and it will probably change automatically to the correct number for your location.

  • 10. Re: icloud incoming mail server field cannot be empty
    jazzfan_1 Level 1 Level 1 (0 points)

    That's what I tried several times ... Unfortunaltely, my appleID adresse ends with @gmail.com ... So entering this adress, gives after hitting continue an error, this as he is trying to connect to the gmail imap server ... :-(

     

    I tryed entering my @icloud.com mail adress, than I was able to step through all the screen, but at the end, after confirming the last setup step and creating this iCloud account, this one remains offline ....

     

    Trying to change any information gives the error message other users commented here in this support, that the incoming mail server field must not be empty! But this one is greyed and cannot be changed .... It shows up mail.example.com instead of the imap.mail.me.com initialy showed up whilst setting up the account ....

     

    Wht a mess ... !!!!!!

  • 11. Re: icloud incoming mail server field cannot be empty
    Roger Wilmut1 Level 9 Level 9 (65,525 points)

    Where are you entering the gmail address? It should presumably go in the username field as it's your iCloud login: the 'Email address' field would be your iCloud email address. The poster above found he didn't need to enter the username, just the iCloud email address (in the Email Address field I assume).

  • 12. Re: icloud incoming mail server field cannot be empty
    jazzfan_1 Level 1 Level 1 (0 points)

    Yes ... you all are right ... but this is what I did with my iCloud address ... I put it in the Email Address field ... and there we are back at my prior post (29, 2012 2:50 AM ) ... second paragraph ... " I tried entering ..." :-( ..

  • 13. Re: icloud incoming mail server field cannot be empty
    swisskent Level 1 Level 1 (0 points)

    I had this issue too and, after hours of troubleshooting including testing on a new user account, I was able to resolve with these steps:

     

    1. In Mail, deleted the iCloud mail account; (in my case it was a me.com account).
    2. Added the iCloud email account I used prior to the initial delete; (my email address is an alias).
    3. After accepting the standard configuration, in Mail's Preferences > Accounts > Advanced, I changed the "Authentication" from "Password" to "Apple Token".  (You might be able to simply choose "Apple Token" during the mail account setup process.)
    4. Saved the changes.
    5. My account was restored & is now working again.

     

    I hope this helps someone else experiencing the same problem. 

     

     

  • 14. Re: icloud incoming mail server field cannot be empty
    glenn246 Level 1 Level 1 (0 points)

    This one was SO frustrating.

     

    Using the info from swisskent as a guide, I deleted the iCloud account, went to System Preferences, and opened the iCloud item.

     

    That had buttons for "Account Details" and "Sign Out" on the left, and a prompt to enter the password on the right. If I entered an incorrect password, it noted the invalid login immediately. If I entered the correct password, it started the spinner, beeped once after about a second, and kept spinning until finally I selected "Cancel". Insane person that I am on occasion, I tried the same thing a few times, expecting different results, and always ending with the spinning-forever cursor and having to hit Cancel.

     

    Finally I selected "Sign Out", and from there it was all smooth sailing. When at last I ended up with the list of apps to use with iCloud, I flipped back over to Mail, and wouldn't you know it, the iCloud account was there all set up, with the p-name for the incoming mail server.

     

    Bloody heck; what a mess!

1 2 Previous Next