4 Replies Latest reply: Jan 3, 2013 12:18 AM by Warwick Teale
Billchuck Level 1 Level 1 (0 points)

Help


Compressor, Mac OS X (10.6.8)
  • 1. Re: I cannot compress my video in compressor. everything  was alright until I clicked the submit button. I received a dialogue box asking for the following: Name; Cluster and Priority.I cannot click the submit button. Thanks
    Russ H Level 6 Level 6 (14,245 points)

    Sounds like something somehow got broken…perhaps in an update. Have you been able to use Compressor previously?

     

    Russ

  • 3. Re: I cannot compress my video in compressor. everything  was alright until I clicked the submit button. I received a dialogue box asking for the following: Name; Cluster and Priority.I cannot click the submit button. Thanks
    Russ H Level 6 Level 6 (14,245 points)

    If you don't have Digital Rebellion's Compressor Repair app, download it here to see whether it can get Compressor and Qmaster to talk to each other properly. When you run it, see that the trash preferences box is checked.

     

    Let us know whether that works.

     

    Russ

  • 4. Re: I cannot compress my video in compressor. everything  was alright until I clicked the submit button. I received a dialogue box asking for the following: Name; Cluster and Priority.I cannot click the submit button. Thanks
    Warwick Teale Level 3 Level 3 (575 points)

    Hi Bill, again just trawling these forums in search of another prolem solution and ran over your post. I'm not sure if every problem reported in these forums requires removing the app's preferences or running a third party product that does it as well.. Sometimes it will work. Usually there's a process somewhere in Compressor or its subcomponents used in the OS that need to kicked in the arse or terminated and restarted or is handed a flawed structure it can't handle entirely and fails.

     

    These failures are sometime echoed in /var/logs/folder/... or ~/Library/Logs/"this_application's.log" or ~/Library/LogsDiagnosticReports/"this_application's" dump. Yep u can view these with the /Applications/Utilities/Console.app or jump in to Qmaster through the Share Monitor.app as well.

     

    Anyway not all these events get logged so sometimes it's difficult to know where to look especially with compressor and qmaster. Qmaster has its logs also in a temproary place then then are magically moved to /var/logs.

     

    A good practice is to see if you can determine one of these flaws before getting the chainsaw and axe out for a "hack and bash session". Chances are you will have this again.

     

    Elsewhere in these Apple Support forums and on the creativecow forums is a wealth of knowledge on compressor or Qmaster and other products. Always worth a simple Google search

     

    Now, I'd propose that is likely that the current structure used by compressor and qmaster are in a less than optimum state!. Most of these are rebuilt if they are removed. All except the SETTINGS and LAYOUTS. So if you have any of your own settings, layouts or destinations and you dont want to lose them, go and make a second instance of these else where of fetch and reinstate them from Timemachine.app once you have restarted everthing after some suggestion I'm going to propose to you shortly.

     

    The probable sources of state information may be deleted and Compressor and Qmaster can be started again. However before embarking on this easy walkthrough ......

     

    Step 1: Stop Apple Qmaster your current host. (Compressor.app/Application Menu Apple Qmaster/Share This Computer / Setup tab/ and untick "Share This Computer").

    count to 10 slowly and all the compressord tasks will stop. Qmasterd is still active...thats cool.

     

    Step 2: QUIT Compressor.app on your current host.

     

    Step 3: Make a second instance of your Compressor.app Settings , Destinations and Layouts: As stated a tonne of time in so many threads , that in Compressor 4, these structures for Qmaster and some of Compressors have been moved into the users home domain (i.e. ~/) in the ~/Library/Application Support/Compressor/Settings and ~/Library/Application Support/Compressor/Layouts directories. If you dont have any then move to the next step....

     

    THerefore simply DUPLICATE or COPY them to another place such as your ~/Desktop. U can use the FINDER or simple unix cli commands such as:

     

    cp -Rv ~/Library/Application\ Support/Compressor/Settings ~/Desktop

    cp -Rv ~/Library/Application\ Support/Compressor/Layouts ~/Desktop

     

    Step 4: remove | purge | delete compressors Lion/ML saved state.... ~/Library/Saved Application State/com.apple.Compressor.savedState

     

    You can also remove the the saved state entry for Compressor.app so tha you wont be bothered with it trying to resstablish where it was when it failed or you last quit it.

     

    rm ~/Library/Saved\ Application\ State/com.apple.Compressor.savedState or just selct and +del it in the trash (hold the OPTION key and select the Finder GO menu to access your homes ~/Library/)

     

    After doing  this you can basically destroy | delete | purge | remove your ~/Library/Application Support/Compressor and also your ~/Library/Application Support/Apple Qmaster directories

     

     

    OK if you're up to it I will refer you to a post where this procedure is comprehensivley detailed. I'm fairly certain that when you follow this procedure and remove these compressor and Qmaster structure and restart then re-set up any clusters and networking, tha compressor will work amazingly well again.... probably like it used to.

     

    Step 5: click over to ths apple forum post and follow the steps in there. No need to duplicate its contents here. The link is at https://discussions.apple.com/message/17356372#17356372%2317356372

     

    Step n: well if you have returned to here hopefully compressor V4..app with Qmaster is running and its like brand new. 9 of 10 times this is the case.

     

    Basically you have purged your current folders:

     

    ~/Library/Application Support/Compressor and

    ~/Library/Application Support/Apple Qmaster

     

    Now a few more things to consider as mentioned in the post at https://discussions.apple.com/message/17356372#17356372%2317356372 is not to be too impatient. THese compressor and qmaster components take a little time to communicate and ready themselves. You will be able to see this via teh activity monitor.app and also right-gear-down on the compressor.app icon n the dock. Look for SERVICES. If you only have one, add some more in the qmaster prefs.

     

    ALso make sure you c=can use Compressor.app / File /Mount Cluster Storage and tha you get a voluem for your cluster apearing in the list box.

    No volume then qmaster is not set up.

     

    You may have to do all the above again.

     

    Lastly, the NETWORK settings used between hosts for Qmaster are often a point of noise and frustration. If u can disable your network  just to get compressor/qmaster going on a single host. Often  the comms causes a great deal of "waiting"scenarios in Compressor. U can see these in the Share Monitor.app.

     

    Please report back you progress so tha others my benefit..


    HTH

     

    warwick