Skip navigation

Java for OS X 2012-006 Problem Failed Installation

6307 Views 6 Replies Latest reply: Dec 21, 2012 1:55 PM by Jacobn617 RSS
Jacobn617 Level 1 Level 1 (5 points)
Currently Being Moderated
Dec 21, 2012 5:36 AM

Hi, I have this problem with my Java for OS X 2012-006. I wanted to use a Java using application, but tells me to install a new version of Java (2012-006).

Startup runs fine but then says that the Installation Failed.

I tried this multiple times then gave up. I searched Google and it led me to:

http://support.apple.com/kb/HT5493

I downloaded it, Mounted the DMG and ran the .pkg

I agree to everything and then ran Install. Then the error "The Installation Failed" with a warning sign comes up, telling me to contact the software manufacturer.

So i go on to the Java website, Searched up Installation Fail "Java" and then told me to Uninstall and then Re-Install.

For Uninstalling, the files were not there. So I Ignored it.

I then donwloaded Java 7 Update 10, but soon to be the same error as the Java OS X 2012-006 error.

 

My Computer is a Late 2012 Macbook Pro 13-Inch.

 

Is there any text that logs what I am doing in the installer? If you tell me where that is, i'll give it to you.

 

Thanks for reading. And Please help.

MacBook Pro (13-inch, Mid 2012), OS X Mountain Lion (10.8.2), Really Awesome
  • Linc Davis Level 10 Level 10 (107,825 points)
    Currently Being Moderated
    Dec 21, 2012 10:48 AM (in response to Jacobn617)

    If you have more than one user account, these instructions must be carried out as an administrator.

    Launch the Console application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.

    Select "/var/log/install.log" from the file list. Post the messages from the last installation or update attempt, starting from the time when you initiated it. If you're not sure when that was, start over and note the time.

    Post the log text, please, not a screenshot. If there are runs of repeated messages, post only one example of each. Don’t post many repetitions of the same message.

    When posting a log extract, be selective. Don't post more than is requested.

    Please do not indiscriminately dump thousands of lines from the log into a message.

     

    Important: Some private information, such as your name, may appear in the log. Edit it out by search-and-replace in a text editor before posting.

  • Linc Davis Level 10 Level 10 (107,825 points)
    Currently Being Moderated
    Dec 21, 2012 1:53 PM (in response to Jacobn617)

    Your downloads are being corrupted.

     

    Step 1

     

    Disconnect all wired peripherals except those needed to boot, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:
    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click  Log in.
    *Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Try the update in safe mode, then reboot as usual. If you have the same problem in safe mode, go to the next step.
       
    Step 2

       

    Reboot your router. Reboot your modem, if separate.

    If you're connecting wirelessly, try Ethernet.

    If you're connecting with Ethernet, try a different port on the router/switch.

    Try a different Ethernet cable.

    If you have access to another Mac, test it on the same network.

    If your Mac is portable, test it on another network.

    If your router is separate from your modem, connect directly to the modem.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.