Skip navigation

How can I fix this recurring network error in the Messages App?

761 Views 9 Replies Latest reply: Dec 21, 2012 3:40 PM by Alan Trewartha HC RSS
talbotini Calculating status...
Currently Being Moderated
Nov 13, 2012 12:21 PM

I use the Messages app all the time at work to chat with co-workers about jobs, etc... We have it set up using our company accounts hosted by gmail. Since upgrading to Mountain Lion we have all experienced the following issue:

 

At the end of the day, or when I am away from my computer for meetings, or lunch, or whatever, I log out of my user account. A lot of the time I will log back in and the messages app will act as though it is fine, but it will not actually be connected. The program makes no attempt to let me know somthing is wrong unless I try to send a message and I am prompted with "Your message could not be sent. Your account “<my account name>” is not logged in." If I go into the "Buddies" window and change the status to "Available" nothing happens, and the account bar will have the lightning bolt symbol and say "Offline" If I click on the lightning bolt an error message pops up and says, "Messages lost connection to the Jabber account "<my account name>". A Network Error Occured."

 

The only way to solve the problem that I have found, has been to competely re-start the computer. I have tried disabling and re-enabling the account in preferances, but it still doesn't connect.

  • Linc Davis Level 10 Level 10 (107,540 points)

    That sounds like a problem with the IM server. As a workaround, don't log out so often. Just lock the screen when you leave the computer.

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)

    HI,

     

    I have seen this with AIM Logins that use the SSL Server and not the original server that was non SSL

    Since iChat 6 the server name has also changed as has the Login port (Although we were suggesting using the port 443).

     

    The AIM SSL server "Falls Over" more frequently than the other server.

    Also iChat/Messages reconnects automatically to the NON SSL server but not to the SSL one (It is a security risk)

    You had to manually Log out by Untick "Enable this Account" then Log back in again.

     

    I have not seen this happen in Jabber accounts but I don't use my computer the same way you  do.

    Jabber Servers tend to either use SSL or Not and can rarely login if you change to not using SLL.

     

    It also seems a bit strange that Disabling the account, as you phrase it, and re-enabling does not work.

     

    For Googletalk Logins try logging out then changing the port to 443 (Googletalk allows this port as well as 5223)

     

    Also check the Keychain (Applications/Utilities > Keychain Access)  and see if there is an issue with any Gmail or Googletalk certificate.

     

     

    Sigcopy2.png
    10:35 PM      Wednesday; November 14, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)

    Hi,

     

    Most evenings I sit here logged in to GoogleTalk (as I said using port 443) and have no problems at all.

     

    I have seen threads that refer to times when the Google Servers have gone off line for a while.

    I have seen threads that refer to people not adding their details in the right way or not Activating the Talk option on their Google Settings.

     

    I have not seen wholesale issues with Logins to GoogleTalk.

     

    Try setting the "Automatically Find Server and Port" option in the Server Settings for the Google talk account.

     

     

     

     

     

     

    http://www.ralphjohns.co.uk/images/Sigcopy2.png
    7:25 PM      Thursday; November 15, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • humph_ecg Level 1 Level 1 (0 points)

    Hi,

     

    I have the same problem as Talbotini. If my iMac awake from sleep, messages doesn't reconnct to my jabber & aol accounts. A network error occured .

     

    I have tested to disable and reanable the accounts and to kill the imagent, but no change. Only a reboot fixed the problem. No entrys in logfile or somthing.

     

    On another Mac it works without problems. What can it be ??

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)

    HI,

     

    Part of this will be the way the computer starts up apps again at the same time as re-establishing the Network.

     

    I would compare the System Preferences > Users and Groups > your account > Login Items across both computers.

    It may also have something to do with the number of apps open.

     

     

     

     

     

     

    Sigcopy2.png
    7:56 PM      Monday; November 19, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • humph_ecg Level 1 Level 1 (0 points)

    Hi Ralph,

     

    on both computers I have Messanges as LoginItem configured. On the one starts Messages without problems after sleep automaticly, on the other not. Now I have deactivated Messages at the LoginItem and then it works when it starts manually. But that isn't comfortable. It should go differently.

     

    But okay, small errors amusing the live.

     

    humph

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)

    Hi,

     

    Were the Login Items listed different ?

    For instance was Messages near the bottom of the list on one and near the top in another ?

     

    In terms of the speed of modern processors it should not make much difference.

    However if there is something that holds up the processor  on one of the Macs it may just be long enough for Message to then log back in again.

     

    I would also check the Date and Time settings and compare those with the router's settings

     

     

     

    Sigcopy2.png
    8:40 PM      Wednesday; November 21, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Alan Trewartha HC Calculating status...

    I have found that after an overnight sleep, the next morning when you log in to your desktop and start Messages (not as a login item, just manually at any time), the jabber accounts fail to connect as described. (And if you stop the mac from sleeping it's always fine.)

     

    The fixes I've found are restarting, OR manually going to sleep and waking it back up again!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.