Skip navigation

Much slower wake-up from sleep since upgrade to ML

78294 Views 191 Replies Latest reply: Nov 29, 2013 8:56 PM by whappen\'d? RSS
  • crackers8199 Level 1 Level 1 (0 points)

    also to confirm, i set hibernate to turn off when plugged in - still the same thing happens. only when plugged in.

  • W M R Level 1 Level 1 (145 points)

    That makes no sense at all, that my Mac hibernates only if plugged in! Isn't it supposed to save battery and hibernate when running on battery? This is really annoying me and I often don't have the patience to wait until it finally wakes up!...

  • mxo11 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Dec 19, 2012 4:54 AM (in response to W M R)

    Ok.  I tried every likely and unlikely (short of praying to the gods) potential solution and nothing worked.  Last resort was to unplug my MBP last night and... voila!  The laptop woke up immediately this morning!  So... C'mon Apple!  Don't tell us that it's the weather or the stars; definitely, something is not working in ML and needs to be fixed.  Hopefully, not every effort will be devoted to please iPhone 5 users.  Those of us who paid > $2,000 for a piece of equipment deserve some attention.

  • W M R Level 1 Level 1 (145 points)
    Currently Being Moderated
    Dec 19, 2012 7:24 AM (in response to mxo11)

    @ mxo11: I'm absolutely your opinion!

  • MikeTheBike2010 Level 1 Level 1 (0 points)

    I have exactly the same issue as this one below,

     

    Any chance of help please?

     

     

     

     

    When the screen comes up it is a transparent grey, you can see the desktop behind it.  No spinning icon, but a segmented progress bar which I had never seen before.  After the progress bar completes, maybe 10 seconds, then the grey goes away and the desktop is clearly visible but can't move mouse and keyboard is not responsive.  20-30 seconds go by then the keyboard backlighting flashes and then it is fully awake.

     

    I'm thinking about doing the clean install to see if that fixes it, otherwise I'm done with it.

  • Dan Cornett Calculating status...

    This is a result of the 'hibernate' mode:  You can change the delay before the system actually goes into hibernate mode (which is different than sleep mode).

     

    See details and use of the 'pmset' Terminal command here: http://www.ewal.net/2012/09/09/slow-wake-for-macbook-pro-retina/  (This applies to all recent machines, not just Retina and includes Lion as well as Mountain Lion.)

  • MikeTheBike2010 Level 1 Level 1 (0 points)

    Dan,

     

    Many thanks for the pointer (I do indeed have a non Retina display so useful to know it also applies to me!

     

    I have gone into Terminal - slightly scary but managed it - and changed my settings so hopefully all will wake quickly henceforth, A key reason I like Macs!

     

    Thanks again and Merry Christmas!

     

    Mike

  • mxo11 Level 1 Level 1 (25 points)

    The reasoning behind this problem and the solution posted at ewal.net, are the same as the ones posted elsewhere (alexanderwilde.com) a while ago.  When I tried it, Terminal wouldn't take the command.  I just tried it again and this time I was successful.  The big test will be leaving the laptop plugged in overnight and see what happens next.

     

    Maybe this will be our Christmas present!

  • drewfromjacksonville Calculating status...
    Currently Being Moderated
    Dec 24, 2012 9:36 AM (in response to abugbitme)

    As noted you can try this. You will be promted for an admin password after you enter this the command noted here.

     

    You can get more info about the pmset command by typing "man pmset" in the terminal window and then pressing space to advance the pages. Press "q" to quit the "man" app.

     

    http://www.ewal.net/2012/09/09/slow-wake-for-macbook-pro-retina/

  • woofers02 Calculating status...

    Dan Cornett wrote:

     

    This is a result of the 'hibernate' mode:  You can change the delay before the system actually goes into hibernate mode (which is different than sleep mode).

     

    See details and use of the 'pmset' Terminal command here: http://www.ewal.net/2012/09/09/slow-wake-for-macbook-pro-retina/  (This applies to all recent machines, not just Retina and includes Lion as well as Mountain Lion.)

     

    I've done this and tried different delay times and can confirm is does NOT resolve the issue. As others have stated, it happens when my macbook is plugged in. When it isn't, it wakes from sleep immediately after any amount of time. ARE YOU LISTENING APPLE?

  • MikeTheBike2010 Level 1 Level 1 (0 points)

    In response to woofers02 comments I had also noticed that the slow wake from sleep only happened when plugged in (surely the reverse of what one would expect if this is a function designed to save battery power?).

     

    Post Xmas (when I am able to leave laptop plugged in again I will see if I still have this issue.

     

    Perhaps we all need to wait for incoming 10.8.3?

     

    Many thanks for your interest.

     

    Mike

  • mxo11 Level 1 Level 1 (25 points)

    I'm afraid I have to report that changing the delay time in Terminal didn't solve the issue.  I did it yesterday, just before posting my previous message at 12:23 PM.  A few minutes ago, I opened my laptop and the problem was there again: more than a minute to wake up.  So, here I am: waiting for 10.8.3!  What a pathetic situation, Apple!

  • W M R Level 1 Level 1 (145 points)
    Currently Being Moderated
    Dec 25, 2012 7:02 AM (in response to mxo11)

    10.8.3 won't change anything. The last EFI-firmware update caused the problem! I hope for a new firmware update with a logical power management!

  • MikeTheBike2010 Level 1 Level 1 (0 points)

    Ok I seem to have cured the issue?

    Having tried various resets and changed my sleep/hibernate delay via Terminal to 24 hours I was beginning to loose hope.

    Called Applecare today and was talked through the following:-

    Deleted the "Power Management" files under preferences

    Shut Down Macbook

    Pressed shift control option and power key together whilst shut down (SMC reset?)

    Pressed Option Command P & R whilst booting up (waited for a couple of "Chimes")

    So far seems ok on waking from long/deep sleep (I was only getting this issue when charging?

     

    Obviously any one of these things could have been responsible, the only other thing I am aware i have changed is to leave an app called Better Touch Tool out of the "open at Start up" list as I noticed this appeared to be the last thing to open when I had the delays?

     

    Good luck to anyone else trying this!

  • Mark Towns Calculating status...

    I had this same problem and found this thread.  After reading some of the responses on here, I disabled my wifi, and my laptop no longer took 10+ seconds to wake up.  I looked at my wifi network settings, and I was configured to connect go my 5ghz network.  I changed it to my 2ghz network.

     

    BOOM.

     

    Waking from closed lid to open lid worked perfectly.

     

    late 2012 MBP 13" 10.8.2

     

    I'm disabling the 5ghz network on my router, what good is it if my laptop hates it?

1 ... 6 7 8 9 10 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.