Skip navigation

Installing Snow Leopard in new Mac Book Pro with Retina Display

12340 Views 20 Replies Latest reply: Apr 28, 2013 1:47 PM by Knees RSS
1 2 Previous Next
JaviMarti Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 14, 2012 12:41 AM

Hi,

 

I have a problem becasue I'm using some old software only running in Snow Leopard (not Lion or Mountain Lion).

Until now when a new brand Mac came with Lion it was possible to install Snow Leopard so I could run my software.

But now with the new Mac Book Pro comes with Mountain Lion and it is not possible to install Snow Leopard!!!

Also is not possible to use a virtualization software because the Snow Leopard EULA doesn't allow to do it.

 

I would like to know if there is any kind of way, trick, workaround, something.... to be able to install Snow Leopard in the Mac hardware for Mountain Lion.

 

Any help will be very appreciated!!!

Thanks

MacBook Pro with Retina display, Mac OS X (10.6)
  • MrHoffman Level 6 Level 6 (11,695 points)

    It has never been supported to load older software than what was originally shipped with the Mac (HT1159), and Apple specifically recommends against doing that (HT2186).

     

    The oldest software for the MacBook Pro Retina is Lion circa 10.7.4.  (I don't know if it's "pure" 10.7.4, or if it's a build of 10.7.4 with update(s); the necessary build is 11E2620.)

     

    Put another way, Snow Leopard will not operate with the MacBook Pro Retina.

     

    If you're stuck behind the EULA around a virtual machine, contact Apple directly, and see if they'll allow this for your case; running the older software as a guest in a virtual machine.

  • John Lockwood Level 5 Level 5 (5,075 points)

    Tell the makers of the software to get their finger out and upgrade it. Snow Leopard is not merely one generation out of date but two entire generations meaning they have had years to write an upgrade.

     

    Other than that, possible solutions are -

     

    Implement a Mac Terminal Server running on a Snow Leopard Server, if you already have a copy of Snow Leopard Server all well and good otherwise your going to have to search to find an old legal copy. There are two Mac Terminal server solutions available, AquaConnect and iRAPP. I have tested both and they work fine and ended up implementing one for the company I worked for.

     

    In my case the reason was to allow Windows computers to run Mac software but it will equally allow you to run older software on newer Macs. It works by letting the Mac (or Windows) computer connect to the Mac server via Microsoft's Remote Desktop Connect client and then runs the software on (in this case) the Mac server. The concept is identical to a Windows Terminal Server.

     

    The second possible solution is to keep an older Mac and use Screen Sharing to control is and run the old software on the older Mac.

  • emdls Level 1 Level 1 (0 points)

    Download VMWare Fusion for mac, which will let you run Snow Leopard Server as a virtual OS in your Lion or Snow Lion OS.  You can buy SL Server off of ebay, or get it from other means, like a friend.  I'm doing this to run Eudora, a program for which no substitute has been created (for reasons I can't fathom.)  I am not alone.  Lots of people are using it for Quicken and other Rosetta requiring software.  Why Apple doesn't have Rosetta available as a software product for purchase, or why the company that makes the software doesn't release a commercial version, I don't know. 

     

    (Apple of course, wants to maximize profits, and they don't care about the users with special needs, like universities and photographers, and thousands of others, who would like new hardware to be compatible with software and peripherals that either costs tens of thousands of dollars, or aren't made any more.)

     

    Apple feels so strongly about it, they don't every let their users vote with their wallets, other than to not buy new hardware or the latest innovate-in-looks only "Lion" OS releases.

     

    Oops - sorry - soapbox mode deactivated.  Wish there was any way to hack Rosetta onto a single app in Lion, for me and many of my friends and family.  Now that 'Freemium' is the dominant software model for browser and email clients, great products like Eudora can't exist. Even small companies innovating in Email client space get gobbled up and killed, i.e., Sparrow.

  • MlchaelLAX Level 4 Level 4 (1,530 points)

    Another option: Install Snow Leopard (with Rosetta) into Parallels:

     

    Lion-Snow Leopard.jpg

                                  [click to enlarge image]

     

    Full installations instructions here:

     

    http://forums.macrumors.com/showthread.php?t=1365439

  • binaryme Level 1 Level 1 (0 points)

    I'm successfully downgraded the two new Mac Pro ( One 3.2GHz Quad-Core Intel Xeon processor ) on Mac OS X 10.6.8 and Mac mini (2.5GHz dual-core Intel Core i5 )... Hope I can make it on Macbook Pro with Retina Display on January..

  • MlchaelLAX Level 4 Level 4 (1,530 points)

    Has anyone been able to successfully implement trackpad gestures with Snow Leopard on the new rMBP?

     

    Does it require the addition of any specific drivers?

  • MrHoffman Level 6 Level 6 (11,695 points)

    For reference (and on reviewing the whole thread, I see I've already posted this once in this thread, so please ignore this re-post): downgrading to an OS X version prior to what was originally shipped with the box is not supported by Apple, and downgrading to earlier releases is not recommended by Apple.

     

    Work with your vendor(s) and get whatever software you're running, or see if booting and running the software as a guest in a virtual machine will work for you; those approaches don't risk OS X or hardware weirdness, nor does that risk causing problems for your hardware.

  • MlchaelLAX Level 4 Level 4 (1,530 points)

    MrHoffman wrote:

     

    Work with your vendor(s) and get whatever software you're running, or see if booting and running the software as a guest in a virtual machine will work for you; those approaches don't risk OS X or hardware weirdness, nor does that risk causing problems for your hardware.

     

    MacBook Pro trackpad - vendor = Apple

  • MrHoffman Level 6 Level 6 (11,695 points)

    MichaelLAX.  Ok.  The question would be why are you seeking to run 10.6 (and presumably 10.6.8) here?  I had guessed (assumed?) that was due to some application compatibility issues or some software that does not operate correctly on 10.8.2 — the need for an older OS X release for an application issue is the subject of this thread, after all. 

     

    Which was why configuring the application as a guest in a VM was suggested.  Or an application software upgrade.

     

    Strictly for what this comment is worth (and no snark is intended), if you need longer-term support or older systems (and there are various reasons why that happens), then Microsoft Windows or one of the longer-support Linux distributions would probably be a better choice going forward.  Both Microsoft and the long-term support Linux releases target that sort of stability, and usually for much longer than Apple.   Apple does not provide extended support for old software or hardware, and generally does not back-port features and support to earlier releases.

     

    I wouldn't expect a MacBook Pro Retina display would work on older releases; as far back as 10.6.  A Mac Pro has a bit better shot at an older release, as some of that series of boxes are old enough that some of the "fairly recent" Mac Pro systems first shipped with 10.6 releases.  Which means Apple once supported that.

  • binaryme Level 1 Level 1 (0 points)

    @MrHoffman... what would you do if you're the system administrator of a certain multi million company and all there works depend on a program that will work on Snow Leopard only. And they need to add more new mac computers ( for new employee and replacement for old mac ). Considering todays mac are all pure 64bit both hardware and software when they ship... And the third party software company is no longer exist. then how?

     

    Yes its true that Apple will not support if you downgrade your OS. But if you open your mind and be initiative on the situation. All things will be possible..

     

    I will let you know then if Macbook Pro with Retina Display will work on Snow Leopard ( remember ! both 32bit and 64bit will run on this OS ).

     

    Merry Christmas!

  • MlchaelLAX Level 4 Level 4 (1,530 points)

    I am just trying to find solutions for this user's problem from my thread on Macrumors: Installing Snow Leopard (with Rosetta) in Parallels:

     

    Macbook Pro Trackpad


    I have installed Snow Leopard in Parallels 8 under Mountain Lion. I did the install process in Snow Leopard on my older MB Pro and have no multi-touch gestures using my Macbook Pro. It says no trackpad found under system preferences. I have also installed SL under Parallels 7 to see if it makes a difference. Still no trackpad. Has anyone else had this problem?

     

    http://forums.macrumors.com/showpost.php?p=16541570&postcount=360

     

    Do you have any positive information for us?

  • binaryme Level 1 Level 1 (0 points)

    Although the OS is a Mountain Lion but we are not sure if the Macbook Pro is with Retina Display model... Anyway, multi-touch gestures is not so important to our applications... And we don't need Parallel to boot up... we can partition the drive and install different types of Mac OS flavour...

  • MlchaelLAX Level 4 Level 4 (1,530 points)

    Good luck with your attempt to downgrade the rMBP to Snow Leopard.

     

    While gestures may not be important to you, it is important to others!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.