7 Replies Latest reply: Dec 26, 2012 8:53 AM by borbye
Mr..E Level 1 Level 1 (0 points)

Can anyone help? This is what happens on many websites - such that I no longer use Safari : http://screencast.com/t/cmh3eNvkva

Safari gives me two problems:

1. Not formatting sites correctly making them unusable

2. Telling me that Site Certificates are untrusted (when they should be trusted - and are the correct sites)

I have tried everything I can think of - Clearing cashe - uninstalling and re-instaling Safari - upgrading Safari. Everything workd fine in Firefox - thank heaven.

But honestly, what's the point of a Browser - and a Mac one at that, which won't function properly?


MacBook Pro, Mac OS X (10.7.5)
  • 1. Re: Safari opens websites not using HTML formatting- Why?
    Linc Davis Level 10 Level 10 (118,525 points)

    Select Safari Preferences Extensions from the Safari menu bar. If any extensions are installed, disable them and test.

  • 2. Re: Safari opens websites not using HTML formatting- Why?
    Mr..E Level 1 Level 1 (0 points)

    Thanks Linc - Have disabled extensions, cleared cashe and re-started. I get the dreaded Invalid Certificate nonesense, and the same unformatted web-page. Here are the Certificate screenshots:

    http://screencast.com/t/yaBD0l2D

    http://screencast.com/t/2isBZbkm3

     

    Any other suggestions? Mr..E

  • 3. Re: Safari opens websites not using HTML formatting- Why?
    Linc Davis Level 10 Level 10 (118,525 points)

    First, the process by which OS X checks the validity of root SSL certificates doesn't currently work behind the authenticating SOCKS proxies used on some enterprise networks. If applicable, contact your network administrator. The proxy server may need to have its settings changed.

     

    Disable the built-in application firewall, if it's in use. If you're running a third-party firewall such as “LittleSnitch” or “Hands Off,” disable that. Test.

     

    In some versions of OS X, Parental Controls has a bug that prevents loading of secure websites. Turn it off.

     

    Are the current date (including the year) and time shown on your system clock? If not, correct them and test.

     

    Otherwise, launch the Activity Monitor application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Activity Monitor in the icon grid.

     

    Select All Processes from the menu in the toolbar of the Activity Monitor window, if not already selected. Enter "ocspd" (without the quotes) in the "Filter" text field. Is a process with that name listed?

     

    If not, select Go Go to Folder from the Finder menu bar. Into the text box that opens, copy the following line of text:

     

    /var/db/crls

     

    From the folder that opens, move these two files to the Trash:

     

    crlcache.db

    ocspcache.db

     

    You’ll be prompted for your administrator password when you do this. Then reboot, empty the Trash, and try again.

  • 4. Re: Safari opens websites not using HTML formatting- Why?
    Mr..E Level 1 Level 1 (0 points)

    Linc Davis wrote:

     

     

    First, the process by which OS X checks the validity of root SSL certificates doesn't currently work behind the authenticating SOCKS proxies used on some enterprise networks. If applicable, contact your network administrator. The proxy server may need to have its settings changed.

    Thanks Linc - I think I am my own administrator ! and I have two other computers on our network - but we don't use any network connections however, but share the use of our broadband and printers through the broadband router. So authenticating SOCKS proxies is a little beyond me - let me know if I need to do anything here! I have noticed that Safari is giving me certificate warnings for more and more websites - but the formatting problem appears to be only for the website I showed you above.

     

     

    Disable the built-in application firewall, if it's in use. If you're running a third-party firewall such as “LittleSnitch” or “Hands Off,” disable that. Test.

    Done that and no change

     

     

    In some versions of OS X, Parental Controls has a bug that prevents loading of secure websites. Turn it off.

    No kids - and parents gone too sadly! So not used

     

     

    Are the current date (including the year) and time shown on your system clock? If not, correct them and test.

     

    Otherwise, launch the Activity Monitor application etc. etc.

     

    Date and Time are present and correct.....

     

    I did play with the Activity Monitor and found "ocspd" working as it should. Just to be sure I also checked for the two files, and they are not there - which is what I was hoping for.

     

    So Linc ... thanks for taking all this trouble .... Any other ideas?   Michael  

  • 5. Re: Safari opens websites not using HTML formatting- Why?
    Linc Davis Level 10 Level 10 (118,525 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.

     

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • 6. Re: Safari opens websites not using HTML formatting- Why?
    borbye Level 1 Level 1 (5 points)

    Hi all.

     

    This issue is something I have also been struggling with for a long time. The incorrect formatting seems to be an issue not only related to Safari for me as it also is seen in the App Store program and in Skypes own browser when logging in there. Here is a list of what have been done so far to solve this and an additional problem with high CPU usage:

     

    - Repair permissions

    - Remove caches in system, /library and home/library

    - Remove safebrowsing.db

    - Remove SIMBL.osax in /library/scripting additions

    - Resetting permissions (ACLs) as described in another thread by Linc

    - Disable extensions Safari

    - Disable Little Snitch

    - Oscpd process found, crlcache.db, ocspcache.db deleted, reboot and oscpd process found again

    - Guest user account used, App store program still not loading properly

    - Filevault has never been activated. Firewall always off.

    - Parental controls never activated

    - Time/date is correct

    - Safe reboot

     

    I suspect there might be a DNS problem but not sure.. The problem has been seen on both my MBA and iMac located in different countries. Both new and updated to newest software.

     

    Stuck here....

     

    Best regards Jesper

     

    PS: Attached pics shows App Store program and the top of this discussion as redered by my Safari...

     

     

    App Store.jpg

    Apple forum.jpg

  • 7. Re: Safari opens websites not using HTML formatting- Why?
    borbye Level 1 Level 1 (5 points)

    Happy holydays to all!

     

    Linc Davis - where are you ;-)

     

    Would love to hear your very qualified opinion to this...

     

    Take care..

     

    Jesper