7 Replies Latest reply: Dec 27, 2012 3:27 PM by elle online Branched to a new discussion.
elle online Level 1 Level 1 (0 points)

I have an iPad 1 32GB WIFI. Still on 5.1.1 (because I can't do anything else). It has only really started having problems in the last few months. I think it's just two years old - so it was still covered by statutory warranty when the issue arose, despite Apple trying to argue to the contrary. Its main problem is the wifi (there are some problems with sound not working and battery life too, but they're less of a problem).


A few months ago, it decided that it just wasn't going to connect to my home wifi network. Full signal strength, but it would just decide to drop out randomly. And when I tried to reconnect, it would tell me that it was unable to connect to the network. Tried everything I read, but nothing changed: turn the actual modem on/off, renewed lease, forget this network, turned the wifi on the iPad on/off, turned airplane mode on/off, tried hard reset, reset network settings - nada. One day, it just randomly decided to start reconnecting and the world was good again.


However, without notice, on Christmas Eve, it decided that it was time to repeat its little issue. Although now it seems to be more annoying. It hasn't connected at all since Christmas Eve (so three days). It will show as having a WIFI full signal strength on the top bar and it will have the network name against Wi-Fi in Settings, but it won't have actually connected because it will just have the spinning loading circle next to the network itself and also next to 'Choose a network...'. Full signal strength though. For the first time though, it has given me a 169.xxx.xxx.xxx IP address (nothing changes this). [Oh, actually, it finally just appeared with a tickmark next to the network name for the first time in days, but the actual internet isn't recognised (there no WIFI signal in the top bar of the iPad and nothing works) - this appears to be because it somehow changed itself from DHCP to Static IP Address].


There doesn't appear to be any problem with my modem/router - iPhone and other computers connect to it without problems.


The spinning circle next to the network when it's "already detected" just makes me want to break the **** thing (I won't , but it's so frustrating).


What can I do?


Edit: I've already followed the advice on the troubleshooting page (http://support.apple.com/kb/TS1398)

iPad, iOS 5.1.1