Skip navigation

Mountain Lion no Wifi after wake from sleep

101336 Views 421 Replies Latest reply: Aug 18, 2013 8:29 AM by rgotty RSS
  • Julius Cheng Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2012 9:55 AM (in response to satcomer)

    "Another thing for your situation is try to open /Applications/Utilities/Keychain Access and delete the certification cetificate for the iwrlesss. Then rejoin the wirreless network and add  it back to your Keychain, fresh. This also might help."

     

    Nope, did that.  The system asked for the certificates again (and I clicked "Always Allow" for them).  Still get "full-bar dead zones".  Somehow, this was never a problem with my Air under Snow Leopard.

     

    Of course, the big reason I upgraded in the first place was to get whole-disk coverage for FileVault, rather than getting a third-party app... now I might wind up switching to a facility-supported Win7 setup instead.

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)
    Currently Being Moderated
    Dec 17, 2012 3:38 PM (in response to NDKO)

    Hello NKDO, to manually put iMac to sleep, is it still working fine so far?

  • NDKO Calculating status...

    Yes, I have to turn off energy savings.... and manually hit the apple/sleep everytime I am going to leave for a while. Or just shut it down.

     

    It is a shame that the Sleep does not work.

     

    Someone at Apple gotta have this laptop and have this problem daily, or not??

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)
    Currently Being Moderated
    Dec 17, 2012 7:43 PM (in response to NDKO)

    I didn't catch your problem, your laptop loose connectivity when you wake it up, or during sleep?

     

    Mine is, after 4-6 hours of sleep, my iMac disconnect from the network. So I can't perform wake on lan...

  • reidonly Calculating status...
    Currently Being Moderated
    Dec 18, 2012 10:58 AM (in response to garymansell)

    With all the various symptoms and conflicting resolutions in this thread, I think you've hit upon a key:  the network's advertised country code.  Interestingly, this is also a rather esoteric setting that might explain some of the randomness of people's experiences in this thread.

     

    Earlier in this thread, I posted my symptoms for the Mountain Lion operating system not finding its WiFi network when waking from sleep.  I tried many of the solutions posted (ditching cached copies of network associations, eliminating certain applications like Parallels) to no avail.

     

    The first relief I had was when I first stopped my hard drive from sleeping.  This improved matters greatly but did not solve the problem.  I went from multiple freezes a week to infrequent freezes about once every 2nd week.  Still painful but much better than before.

     

    Watching this thread, I noticed your post about the country code.  Looking at my Airport's configuration, I can only see how to set the country code for the Airport's 5GHz network (which I had not been using).

     

    I configured and named my Airport's 5GHz network (ensuring the country code was set to U.S.) and set my Mac to connect to the 5GHz network by default.  I have not had a freeze in over 6 weeks.

  • Julius Cheng Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 18, 2012 11:10 AM (in response to reidonly)

    "I configured and named my Airport's 5GHz network (ensuring the country code was set to U.S.) and set my Mac to connect to the 5GHz network by default.  I have not had a freeze in over 6 weeks."

     

    Now, do we know this is an issue with other access points?  How do we change those settings?

  • botro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 23, 2012 10:36 AM (in response to satcomer)

    Ever since I entered the command

    sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

    then

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

     

    I've had problems with WiFi not staying connected. Very frustrating. I have a MBP 13" 2010, 10.8.2 and FIOS. I never had a problem before entering those commands.

  • julie16 Calculating status...
    Currently Being Moderated
    Dec 26, 2012 6:29 PM (in response to ilovecode)

    I had this same issue after upgrading to ML. I read all the boards and tried all the tweaks. Finally gave in and went to Genius Bar. While they were working on my issue (they hadn't heard this issue happening) I found another board with a solution, showed the genius and he was just about to try this. Turns out so far so good.

     

    1)Delete Contents in /Library/Preferences/SystemConfiguration and /Library/Caches

     

    2)Shutdown computer, turn off main power to mac and leave for 15secs

     

    3)Turn on the main power

     

    4)Power on mac and do a PRAM reset (Press and hold the Command-Option-P-R keys). Wait for 2 audible beeps then let go of keys

     

    5)Test and verify if issue resolved.

  • roxan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2012 5:18 AM (in response to julie16)

    In my case the issue was still but less frequently popping up. Moreover, the performances were very bad for wifi bandwidth.

     

    My solution was to acquire a wifi extender that also act as a bridge between exact wifi protocol, ... But didn't force me to reconfigure anything on the existing router. Only drawback of the extender was the impossibility to configure MAC address filtering security on top of WPA2.

  • botro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2012 5:23 AM (in response to julie16)

    This works! I had cleaned out the /Library/Preferences/SystemConfiguration files before but not the /Library/Caches. The laptop sat all night and when I went to it this morning it was still connected. Great advice! : )

  • applluv Calculating status...
    Currently Being Moderated
    Dec 29, 2012 5:05 PM (in response to botro)

    After installing 10.8.2, my MBP doesnt connect to wifi after waking up. There doesnt seem to be consistent solution to this problem. Can someone explain if this is a known problem? If yes, what is the resolution?

  • leandro_br Calculating status...
    Currently Being Moderated
    Jan 9, 2013 4:13 PM (in response to ilovecode)

    I have the same problem here: no internet connection after wake up from sleep although Wi-Fi is connected to the network.

     

    I am using Time Capsule configured in bridge mode.

     

    I have tried all suggestions here in this thread but no luck at all. Not even a hard resetting my MBP or reseting PRAM solved the problem. Sometimes the internet connection goes back after 5~10 minutes after waking up, but the most of the time I need to restart Time Capsule in order to get Internet back.

     

    Important to say that even if there are other Wi-Fi networks avaiable although I am able to connect to them the result is the same: no internet connection regardless which network I am connected to.

     

    This is extremely annoying and Apple seems to do absolutely nothing about. I am really considering returning my new hardware.

     

    My configs are:

     

    MBP Retina 15"

    OSX Mountain Lion 10.8.2

    Time Capsule

  • botro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2013 4:49 PM (in response to applluv)

    I don't think there is a universal solution. There are so many varibales involved. For example cleaning out the cache worked for me, but it created another problem. I use Verzon FIOS and when now sometimes when a call comes in it knocks me off the network and takes a few minutes to search for the WiFi signal before reconnecting. I know this is probably a Verizon problem but who knows it could be a router configuration issue that is intereacting with TCP/IP protocal stack on my MacBook.

     

    I'm sure Apple must have support engineers monitiroing this site, but it would be really helpful if they can offer solutions when it's related to the users configuration (as opposed to a software bug that Apple has to correct)

  • applluv Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 24, 2013 7:19 PM (in response to botro)

    Does anyone have any clue on whats wrong with the ML OS  and not re-connecting to wifi after waking up?

  • leandro_br Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 24, 2013 7:46 PM (in response to applluv)

    Well, I have been talking to Apple Suport and It is unsure if this is a hardware or a software problem, but after I have tried about everything suggested in this forum, finally adding openDNS IPs in my wi-fi connection instead of using the one my ISP provides worked for me.

     

    Here is how to give it a try:

     

    Go to System Preferences, Network

    Click on Advanced and then on DNS

    Click on the + sign and add 208.67.222.222 and then click + again and add 208.67.220.220 (check out these openDNS IPS here http://www.opendns.com/business-solutions/premium-dns/benefits/)

    click OK

    click on the lock to prevent any modifications (optional)

    click apply

    Restart your Mac.

     

    Since then it has been 1 week without any lost connection after waking up my MBP Retina,

     

    People should give it a try.

     

    Message was edited by: leandro_br

1 ... 23 24 25 26 27 ... 29 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.