2 Replies Latest reply: Dec 30, 2012 1:05 AM by Annemariephi
surewinn Level 1 Level 1 (0 points)

I have problem with my whatsapp and it mentioned that I need a newer os to upgrade. Fyi I using iphone 3GS ver 3.1.2


iPhone 3GS