5 Replies Latest reply: Jan 6, 2013 1:37 AM by Fraenzi
Fraenzi Level 1 Level 1 (0 points)

I tried to add an iMovie project to a iDVD. But I always get the message with the error code -49. I read that it has to do with the time machine. But I do not know what I have to do to fix it. Does anyone know how I can fix this? Thank you   Fraenzi


MacBook Pro
  • 1. Re: -49 error code on iMovie. How can I fix it?
    Bengt Wärleby Level 6 Level 6 (19,160 points)

    Hi

     

    Error -49 opWrErr  File already open with write permission

     

    Trash the preference files while application is NOT Running.

     

    from Karsten Schlüter

    Some users notice on exporting larger projects from within iMovie that this operation is aborted with an 'error -49'

    This issue occours only on MacOs machines using 10.7x

    try switching-off the Local Mobile Backup

    in Terminal copy/paste

     

    sudo tmutil disablelocal

     

    Re-launch Mac

     

    Yours Bengt W

  • 2. Re: -49 error code on iMovie. How can I fix it?
    Cotejaz Level 1 Level 1 (10 points)

    Hello,

    I got that error may times too and just found this answer.

    I shut down Time MAchine and iMovie 11 is not running.

    I now want to "Trash the preference files" as you mentionned. Where do I go to do this properly?

     

    Thanks,

    Cotejaz

  • 3. Re: -49 error code on iMovie. How can I fix it?
    Bengt Wärleby Level 6 Level 6 (19,160 points)

    • Delete iMovie pref. file

     

    iMovie pref. file resides.

    Mac Hard Disk (start-up HD)/Users/"Your account"/Library/Preferences

    and is named. (one or more of these)

    com.apple.iMovie.plist

    com.apple.iMovie3.plist

    com.apple.iMovie7.plist

    com.apple.iMovie8.plist

    com.apple.iMovie9.plist

    com.apple.iMovieApp.plist

     

    and find

    com.apple.iApps.plist

     

    While iMovie is NOT RUNNING - move this/these file/s out on to desk-top.

    Now restart iMovie.

     

    If You run Mac OS X.7 or more - then the Library in the User-account folder is invisibly and need to be set to be viewable. IT IS NOT in the Library on Root level (when opening MacintoshHD - first window = root level)

     

    ( It can be done like this: Open Terminal, then enter: chflags nohidden ~/Library

    Press return, then restart, and it will always be visible until the next major update, when you do the same thing again. )

     

    or - do like this

     

    On the Finder window at the top left of the screen,

    Hold down the Option key and clicked on Go

    This allowed You to see the Library folder and select it. 

    Then keep the Option button pressed down in order to see and select the Library folder. 

    Once found it, You are able to navigate to the iMovie preferences file and move it to the trash.  iMovie then start’s up fine! 

    - - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - - -- - --

    When iMovie doesn't work as intended this can be due to a lot of reasons

     

    • iMovie Pref files got corrupted - trash it/they and iMovie makes new and error free one's

    • Creating a new User-Account and log into this - forces iMovie to create all pref. files new and error free

    • Event or Project got corrupted - try to make a copy and repair

    • a codec is used that doesn't work

    • problem in iMovie Cache folder - trash Cache.mov and Cache.plist

    • version miss match of QuickTime Player / iMovie / iDVD

    • preferences are wrong - Repair Preferences

    • other hard disk problem - Repair Hard Disk (Disk Util tool - but start Mac from ext HD or DVD)

    • External hard disks - MUST BE - Mac OS Extended (hfs) formatted to work with Video

    ( UNIX/DOS/FAT32/Mac OS Exchange - works for most other things - but not for Video )

    • USB-flash-memories do not work

    • Net-work connected hard disks - do not work

    • iPhoto Library got problems - let iPhoto select another one or repair it. Re-build this first then try to re-start iMovie.

    This You do by

    _ close iPhoto

    _ on start up of iPhoto - Keep {cmd and alt-keys down}

    _ now select all five options presented

    _ WAIT a long long time

     

    • free space on Start-Up (Mac OS) hard disk to low (<1Gb) - I never go under 25Gb free space for SD-Video (4-5 times more for HD)

    • external devices interferes - turn off Mac - disconnect all of them and - Start up again and re-try

    • GarageBand fix - start GB - play a few notes - Close it again and now try iMovie

    • Screen must be set to million-colors

    • Third-party plug-ins doesn't work OK

    • Run "Cache Out X", clear out all caches and restarts the Mac

    • Let Your Mac be turned on during one night. At about midnight there is a set of maintenance programs that runs and tidying up. This might help

    • Turn off Your Mac - and disconnect Mains - for about 20-30 minutes - at least this resets the FireWire port.

    • In QuickTime - DivX, 3ivx codec, Flip4Mac, Perian etc - might be problematic - temporarily move them out and re-try

    (I deleted the file "3ivxVideoCodec.component" located in Mac HD/Library/Quicktime and this resolved my issue.)

     

    buenrodri wrote

    I solved the problem by removing the file: 3ivxVideoCodec.component. after that, up-dated iMovie runs ok.

     

    Last resort: Trash all of iMovie and re-install it

     

    Yours Bengt W

  • 4. Re: -49 error code on iMovie. How can I fix it?
    Cotejaz Level 1 Level 1 (10 points)

    Thank you so much for your response.

    I will save these instructions very preciously, but I was actually able to solve my problem by quitting Time Machine and I also deleted an old time machine back-up that was just sitting on my desktop. Then it finalized the project in 1080p perfectly. No need to delete preference files.

    Thanks again,

  • 5. Re: -49 error code on iMovie. How can I fix it?
    Fraenzi Level 1 Level 1 (0 points)

    By trashing the preference files and switching off the Local Mobile Backup, my problem was solved.

    Many thanks,

     

    Francoise