Skip navigation

Logic 9's UI extremely laggy - any fixes?

53450 Views 516 Replies Latest reply: Aug 21, 2013 3:10 PM by nicowieditz RSS Branched to a new discussion.
  • SmokenSound Level 1 Level 1 (20 points)
    Currently Being Moderated
    Dec 17, 2012 3:39 PM (in response to Nick 235)

    Nope, not working ! NOT A FIX ! =(

  • Fredo Viola Calculating status...
    Currently Being Moderated
    Dec 20, 2012 9:13 AM (in response to SmokenSound)

    Logic Pro bug update: I received word a few days ago that the Mountain Lion crew had figured out a fix for the Logic Pro lag issue, which is actually a major Core Audio problem that has effected many other apps as well. So, yay! He said the update should be coming out sometime in January or February and apologized for the continued wait. Just wanted to pass that on to other Lion and ML Logic Pro users.

  • km9898 Calculating status...
    Currently Being Moderated
    Dec 20, 2012 3:46 PM (in response to fluffy)

    Hm, none of those fix'es work for me.. I have a new MacBook Retina 15 and it's UI is laggy as ****, for example, i can't scroll in safari without pictures to start flicker and logic is just, gaaah!

     

    When i have like 4-5 instruments and one open - the meters are lagging as **** like i try to push the computer way to far andgd when i try to pause logic agwith spacebar, nothing happens. When i go to mission control, press a window in there, then all my commands from keyboard or/and mouse is coming in to logic.

     

    I mean, i have a 13 MacBook C2D and it's working like 100 times better machine than this 2000dollar machine.

     

    Im sorry if this message is writthejn with some glitches, because when i write in this window some text suddenly dissapears (retina bug).

     

    I hate my new machine.

     

    EDIT: I have also tried all methods in retina lag UI thread and nothing helped me.

  • composerguy78 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Dec 20, 2012 8:49 PM (in response to km9898)

    Does the activity monitor or console log show anything interesting? (both those apps reside in Applications>Utilities)

  • Wills House Mac Recording Calculating status...
    Currently Being Moderated
    Dec 27, 2012 5:56 PM (in response to Fredo Viola)

    No offense to the Apple guys but they really did not think on thier feet when developing these last two OS. I am a PRO user of Logic and between Apple and Tascam, I dont know who I am more dissappointed in. To solve EVERYTHING EVERYONE is talking about on here, I simply re-installed the original SNow Leopard 10.6.8 and have had not one problem. I will again wait until I see EVERYONE use this update and see it working for all in Logic.

     

    CHEERS!

  • zeugmatis Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2012 9:08 AM (in response to fluffy)

    Same here on a MB Air only a year old.  Open the EQ, turn on the spectrum analyzer and... goodnight.  The EQ window can be moved around smoothly, CPU use is low but Logic itself accepts no standard input anymore.  Cannot stop the track, close the EQ window etc.

     

    Sometimes it will suddenly "catch up" registering dozens of clicks after I switch to another app, but it usually requires a force kill on Logic and I get to lose my work.  EQ + analyzer seems to make it happen 100% of the time although I have noticed this a few times a day at other times when the EQ is closed. 

     

    Since I'm new to Logic and this bug looks to be over a year and a half old, going to go ahead and try the ableton demo that came with my midi keyboard instead.  Particularly for creative stuff, the last thing I want to do is waste time "fighting" with software. 

  • Fredo Viola Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 29, 2012 9:12 AM (in response to zeugmatis)

    Hi Seugmatis,

     

    It is definitely a well-known problem and Core Audio is the culprit.  Right now a fix has been discovered by the Mountain Lion team, but we just have to wait for them to release it.  In the meantime.... be patient.  You do not have to kill Logic to get it to stop.   It will stop eventually, even if it's 2 minutes later.  I know this isn't a great comfort, but at least you don't have to lose your work!

  • Junior.se Calculating status...
    Currently Being Moderated
    Dec 29, 2012 9:15 AM (in response to Fredo Viola)

    Fredo Viola wrote:

     

    Hi Seugmatis,

     

    It is definitely a well-known problem and Core Audio is the culprit.  Right now a fix has been discovered by the Mountain Lion team, but we just have to wait for them to release it.  In the meantime.... be patient.  You do not have to kill Logic to get it to stop.   It will stop eventually, even if it's 2 minutes later.  I know this isn't a great comfort, but at least you don't have to lose your work!

    And how do you know it's been discoverd and that a fix will come?

  • Fredo Viola Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 29, 2012 9:18 AM (in response to Junior.se)

    Because I wrote a letter to Tim Cook, a very long one, and as a professional curtesy Apple had somebody very high up in the staff at Logic Pro write to me.  We have had a lot of communication, even as they were trying to get the Mountain Lion staff take the problem seriously, as it is clearly not something that could be fixed with a Logic update.  He wrote to me just before Christmas saying that the team had found the problem and fixed it, but we'd now have to wait for the release of the Mountain Lion update.

  • km9898 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2012 9:20 AM (in response to fluffy)

    The most wierd thing is the fact that my rMBP has started to work now together with Logic, without any glitches and very few GUI lags.

     

    What i did? I turned on only the dedicated graphic card in rMBP. Now my mac seems to be as quick as my old one.

     

    Logic has some GUI lags here, but very few, it happens when i try to modify this plugins:

     

    Fxpansion GURU

    Xfer Tools LFOTool

     

    All the Logic stock plugins, like EQ and analyzer on many EQs at the same time, all working.

     

    Don't know if this is just that it will be working for now - but it has worked now for about 1 week.

  • Junior.se Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2012 9:21 AM (in response to Fredo Viola)

    Tnx.. Well 10,8.3 dev preview should fix it then.. Any one tryed it?

  • Fredo Viola Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 29, 2012 9:22 AM (in response to km9898)

    I have very similar days, km9898.  Some days I don't have a single problem.  others (like this morning) anytime I open channel eq terrible lag.  Glad to hear you've got a possible fix for yourself though!!

  • zeugmatis Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2012 9:22 AM (in response to Fredo Viola)

    Ahhh, I just saw that up higher in the thread.  It isn't too bad otherwise, maybe a couple times a day but on chapter 9 of Dave Nahmani's pro logic training book (which is *great* btw) there is the whole section on EQ ... that is where it bit really hard.  Otherwise the software is amazing!  A lot of time already invested in learning logic, so I'll just keep this in mind when using the EQ analyzer and look forward to the bugfix.  Thanks for the tip! 

  • Fredo Viola Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 29, 2012 9:23 AM (in response to zeugmatis)

    ususally if you just disable analyzer it won't have the lag. 

  • km9898 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2012 9:25 AM (in response to Fredo Viola)

    Yeah, i know because it was the same lag at my iMac and the only solution was to downgrade to SL and then all worked perfectly. If i had the choice to downgrade this rMBP to SL, i would do it! But i can't and, well, it works for me right now but i know that it will go back to that terrible lag some day. Just tried to be as happy as i can for this problem hehe

1 ... 26 27 28 29 30 ... 35 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.