Skip navigation

Missing lots of instrument files after migrating from Macbook Air to Mac Mini

709 Views 7 Replies Latest reply: Jan 6, 2013 11:39 AM by vick0 RSS
vick0 Calculating status...
Currently Being Moderated
Dec 29, 2012 3:41 PM

Hello all, I know this issue is very old on these forums but nevertheless I can't find the solution, even after having read whatever I found around here.  I had a perfectly working setup with several GB jam packs including the ones that come with MainStage 2. Recently I moved my content from Macbook Air onto Mac Mini (late 2012) and that's where problems began… I get errors about missing instrument files (and I do find see respective folders in /library/ "instrument library"). I tried: 1. Removing both Garage Band and Mainstage2 and then reinstalling them. 2. Reinstalling individual jam packs from DVDs or backups. 3. I even "touched" my old folders to make sure that the date was correct on them (not sure if this does anything useful though).  I still have the content missing, EG "Liverpool Bass", "Glockenspiel", "Steinway Piano", violins and related. When I look under "/library/Application Support/Garage Band/Instrument Library/Sampler/Sample Files", I do not see the folders with samples even though the instrument definitions are in "/library/Application Support/Garage Band/Instrument Library/Sampler/Sample Instruments".  Does anyone have any ideas as to what else I can try? Thanks, Vic

Mac mini (Late 2012), OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,330 points)

    How did you migrate, Vic?

    Did you use Migration Assistant? Then probably your Instruments Library has not been copied properly, see Christoph Drösser's post:

    Migration doesn't copy Instrument Library

     

     

    To fix this, replace the complete Instruments Library by the corresponding folder from your old mac

    /Library/Application Support/GarageBand/Instrument Library/

     

    Regards

    Léonie

  • Maccaguy Calculating status...

    I'm seeing the same thing after purchasing MainStage and downloading the additional instruments, which were the old Jam Packs. I'm missing the Steinway grand and a good bit of the stringed instrument section. The only thing I can think of is that I had the Symphony Orchestra Jam Pack installed before, and there must be some conflicts somewhere.

  • léonie Level 8 Level 8 (46,330 points)

    There must be some configuration file somewhere on the disk that makes GB and MainStage believe all the content is installed properly.

    You could try to remove the whole Instrument Library and Loop Library, and then reinstall GarageBand and Mainstage.

     

    At some time back a few instrument samplers have been renamed. And if you have a mixture of the old instruments and new samplers installed, this may be inconsistent.

     

    Remove the folders (but don't delete them):

    • /Library/Audio/Apple Loops/
    • /Library/Audio/Apple Loops Index/
    • /Library/Application Support/GarageBand/Apple Loops/
    • /Library/Application Support/GarageBand/Apple Loops Index/
    • /Library/Application Support/GarageBand/Instrument Library/

     

    Then reinstall GarageBand and Mainstage 2.

     

    If you want to reinstall from the AppStore, you have to deleteboth applications from the Applications folder.

     

    Regards

    Léonie

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.