1 2 3 Previous Next 33 Replies Latest reply: Feb 17, 2013 9:17 PM by WPWoodJr
greenfish29 Level 1 Level 1 (0 points)

Hi,

when I put my MacBook Pro into sleep, after 4 hours it turns into hibernation. So the awakening is slower and progress bar is showed after lid open. I change nothing manually, so maybe Apple change this behaviour in some update? Here is my pmset -g output:

 

Active Profiles:

Battery Power         -1

AC Power               -1*

Currently in use:

standbydelay         4200

standby                 0

womp                    1

halfdim                  1

hibernatefile           /var/vm/sleepimage

sms                      1

networkoversleep   0

disksleep              10

sleep                    8

autopoweroffdelay 14400

hibernatemode      3

autopoweroff         1

ttyskeepawake      1

displaysleep          6

acwake                 0

lidwake                 1


MacBook Pro, OS X Mountain Lion (10.8.2)
  • 1. Re: Change Apple sleeping policy?
    Arc676 Level 1 Level 1 (135 points)

    I'm not actually sure about this, but I think that unless your mac has flash storage, waking from a long period of sleep should be a little slow. (I could be wrong)

  • 2. Re: Change Apple sleeping policy?
    Shootist007 Level 6 Level 6 (16,640 points)

    Turn off hibernate and dump the Sleepimage file and you won't have this problem.

     

    Is this on a NEW Mac or slightly older model? IIRC OS X, Mac's, are only supposed to go into Hibernate when the system is running on battery only and the battery get drawn down to a critical level, like below 5%. It then saves what is in RAM, Sleep state holds everything in RAM, to the hard drive and puts the system into a DEEP SLEEP mode (better known as hibernate). So when that happen yes it takes longer for the system to wake up as everything has to be read from the HDD and placed back in RAM for the system to come out of sleep fully.

  • 3. Re: Change Apple sleeping policy?
    greenfish29 Level 1 Level 1 (0 points)

    It's MacBook Pro Mid 2012. I have MacBook pluged in all night, but it happens anyway. I know, how to solve this, but I just want to know, if Apple change this or if is something wrong. I try find official expression, but there was no mention.

  • 4. Re: Change Apple sleeping policy?
    Shootist007 Level 6 Level 6 (16,640 points)

    There are some other threads on Slow wake from sleep and the system not coming out of sleep without a hard Restart, power button held down unti system shuts off then power back up, but I don't recall any with your specific problem.

     

    Not sure about my late 2011 as one of the first things I did was dump the SI file. Mine has been sleeping, connected to AC which is on a light switch so it goes off when the light for my desk it turned off, for a coupple of days..

     

     

    I just opened the lid and the logon screen came up in two snaps of my fingers.

  • 5. Re: Change Apple sleeping policy?
    greenfish29 Level 1 Level 1 (0 points)

    Solution is turn "autopoweroff  1" settings turn into "autopoweroff  0". But I think, that this is change from Apple. Just for longer battery life. Can anyone from Apple answer us?

  • 6. Re: Change Apple sleeping policy?
    Shootist007 Level 6 Level 6 (16,640 points)

    No one here from Apple. This is a User to User forum.

     

    Even if someone at Apple is looking at and reading some thread they will not answer.

  • 7. Re: Change Apple sleeping policy?
    greenfish29 Level 1 Level 1 (0 points)

    Ok, so how can I contact Apple via email or with writing text? I just found telephone contact possibility.

  • 8. Re: Change Apple sleeping policy?
    Shootist007 Level 6 Level 6 (16,640 points)

    Apple doesn't do Email. You have to call them. If you are still within the 90 days from date of purchase or have Applecare extended warranty it is free. If not they want to charge you.

  • 9. Re: Change Apple sleeping policy?
    leodanger Level 1 Level 1 (0 points)

    This is the closest thread I've found to my issue, which is currently with an Apple senior engineer. They've been excellent, and hopefully I'll hear back soon and post the result here.

     

    My mid 2012 MBP (pre-Retina) is suffering the same problem. When waking from an extended sleep, you can hear the optical drive activate (as if the machine is being fully restarted), then the screen washes out and I get a progress bar. After a few seconds, the bar is full, then it stays there for about ten-twenty more. After that, the screen clears, but the machine is unresponsive for about 30 more seconds. Before opening the lid, the sleep light has extinguished completely, as if the machione is shut down.

     

    BUT... this ONLY happens when the AC adaptor is plugged in. I can leave the computer asleep as long as I like with just battery power, and it will wake instantly. The time to the light going out (and the machine effectively being almost shut down) is 4 hours, which of course is 14400 seconds, as seen on the autopoweroffdelay. This doesn't make sense when its plugged into the mains!

     

    The only way I've found to cure this is to boot into recovery, erase the hard drive, then restore from Time Machine, but without restoring settings. I've tried PRAM, SMC, Permission, quitting powerd... everything I can think of over the last 3-4 months, but the problem invariably comes back.

     

    Once it's sorted, I'll post the answer, but I thought I'd add some details on how I've narrowed this down.

  • 10. Re: Change Apple sleeping policy?
    lci3341 Level 1 Level 1 (0 points)

    leodanger

    did you get a fix for this? I am having similar problem. hope you found an answer....

  • 11. Re: Change Apple sleeping policy?
    greenfish29 Level 1 Level 1 (0 points)
  • 12. Re: Change Apple sleeping policy?
    leodanger Level 1 Level 1 (0 points)

    Hi there... sorry for the delay in posting what happened – I've been trying a few other things.

     

    Okay, the long and the short of it is that Apple didn't have an answer. It was referred to an Apple engineer by the senior technician, but they came back after a week with queries over a couple of files in my plist folder. These were indeed causing problems, but seem to be an unrelated issue.

     

    I pointed out that the problem always happens after exactly 4 hours, which is when autoshutoff comes into effect. Looking at my wife's Macbook, which is running Snow Leopard, there is no autoshutoff in there.

     

    Having spent a long time looking into this, I decided to turn autoshutoff OFF (0), and it's cured the issue entirely. This leaves the hibernate mode alone (and in the same state as it is on the wife's SL MB).

     

    First of all, open Terminal (in utilities) and type pmset -g

     

    This shows you your power management settings. It's different depending on whether you have your power supply plugged in or not.

     

    In terminal, enter

     

    sudo pmset -c autopoweroff 0

     

    This will give you this message:

     

    "WARNING: Improper use of the sudo command could lead to data loss

    or the deletion of important system files. Please double-check your

    typing when using sudo. Type "man sudo" for more information.

     

    To proceed, enter your password, or type Ctrl-C to abort."

     

    Type your admin password, then press enter. If you want to check that it's taken, enter pmset -g into terminal.

     

    You'll need the power supply plugged in to see the change. The -c in the command used means this setting only relates to the power supply. I'm going to try it with -a too, which will also relate to the battery. (-b would be battery only). If you wanted to turn autopoweroff back ON, you'd put a 1 at the end, instead of a 0.

     

    I'm going to try -a tonight, as I have one issue now where if I unplug the sleeping laptop from AC, it enters a dark wake, and is unresponsive for 20-30 seconds, with a black screen. However, the settings I've changed mean I no longer get the huge list of errors in Console after a wake, or if I look at the sleep log with pmset -g log

     

    I've got one more thing to try, before I get back to the technician delaing with my request. Once I've narrowed everything down to this, I want to ask what autopoweroff really does!

     

    Hope this helps... It's great for me to have my machine running correctly again. Unfortuntately Apple did seem to indicate that they'd not come across this problem before, which seems unlikely, but they did say they thought it was an issue with files migrated from an old OS. Did any of you with this issue do 100% clean installs, and not migrate anything? The issue definitely seems to have happened when I installed the update, but I wouldn't be able to say for certain.

     

    Please do post how you get on...


  • 13. Re: Change Apple sleeping policy?
    SwankPeRFection Level 4 Level 4 (1,435 points)

    Here's more info on when and how this behavior was introduced by Apple.  They really need to fix this as it shouldn't be entering hibernation when plugged into power and sleeping but not when it's on battery and sleeping.  Seems reversed and counterintuative.

     

     

     

    This is a problem with all 2012 MacBook Pros that have applied the update DL1609 via Software Update.  This update is called MacBook Air and MacBook Pro Update 2.0.  The only fix that exists for this is to reinstall OSX and just not install this update when it shows in the available updates list in the AppStore.  Just hide it until this issue is fixed by Apple.

     

    If your OSX 10.8.2 version is anything after version (12C60) then you will have this problem.  The problem is as follows.  With the system asleep with clamshell closed, plugging and unplugging the power cable causes the system to wake up and go back to sleep.  Additionally, leaving the system plugged into power for over 4 hours will cause the system to go into hibernation, but only when plugged in.  If it's not connected to AC power while sleeping for that long, it will not enter hibernation.

     

    Please call Apple and complain about this problem.  I have been working with them for over a month and a half trying to get them to fix this and it's a major hand-holding process because they didn't initially understand the issue.  Add to that the fact that they insisted that this problem doesn't exist and it just made it that much harder to get them to see the issue.

     

    You need to call them AppleCare and let them know you're having this problem.  Along with that, email the rep you're working with links to every Apple Support Forum thread you can find on this.  Trust me, there are several with this same exact problem.

  • 14. Re: Change Apple sleeping policy?
    leodanger Level 1 Level 1 (0 points)

    Thanks Swank – I'll pass this on...

     

    Further to my post, I've found that it's best to totally turn off autopower off, so use this setting in Terminal (found in Utilities):

     

    sudo pmset -a autopoweroff 0

     

    This returned my 2012 MBP to the way it always used to work. The difference is using -a to affect autopoweroff in both AC and Battery power. Using -c to turn it off with AC only resulted in some slow wakes if I opened the lid just after pulling the plug.

     

    Once again - this has solved my issue, without having to change the hibernate mode.

1 2 3 Previous Next