Skip navigation

Magic Mouse not working with Lion

32428 Views 37 Replies Latest reply: May 21, 2013 7:50 AM by tumlinso RSS
  • Northman Calculating status...
    Currently Being Moderated
    Feb 18, 2012 3:34 PM (in response to Keith Randy)

    Hi Keith

     

    On my system it does not solve the problem. It improves the uptime between the mouse going haywire and all erratic. But it bombs out on an average of 2-3 days between errors. System restart solves the probem until the next time it shows.

    I've resetting the SMC and zapping the PRAM and I have reinstalled Lion and I use the latest upgrad. But no. When using gfxcardstatus set only on integrated graphics the machine works doesn't quit on me any longer. But as soon as I need to use my 21" Cinema Monitor I have to go back to dynamic switching and with the GeForce card in operation the machine still just quits from time to time.

    I was hoping that the new Lion update would solve the problem but it didn't.

    Maybe a Class Action Suit would get Apple working on fixing the problem...

  • rembly Calculating status...
    Currently Being Moderated
    Feb 23, 2012 12:50 PM (in response to Anthony Curcio)

    My gestures work just fine... only they work on the lower half part of the magic mouse.

    This is reeeeeally annoying and frustrating.

    Does anyone know how to fix this problem???

  • woodygee Calculating status...
    Currently Being Moderated
    Feb 26, 2012 3:09 AM (in response to Anthony Curcio)

    The Problem:

     

    I had the same symptoms on my Mac Pro, but discovered my issue was different.  I don't have bluetooth built-in and so had bought a Belkin bluetooth adapter - tiny USB device.  After a reboot or sometimes logging back in, either the mouse wouldn't be recognised at all, or would not have the scrolling features because from the System Preferences it looked like my mouse wasn't a Mighty Mouse and so I didn't even have the option to check for scrolling.  I hadn't had this issue for some time because I had been using the Belkin adapter plugged into a powered external USB hub, but the problem had re-occurred after the HUB died and I had to plug the Belkin adapter directly into the Mac Pro again.

     

    The Fix:

     

    Unplugging the Belkin bluetooth adapter and plugging it back in re-initilased the adapter and possible associated the correct Bluetooth profile with my Mighty Mouse.  Once the screen showed "Connected" again for the mouse, I was able to use the scrolling function.  I'll probably get a new powered USB hub to replace the dead one, so that I don't have to resort to this removing/re-inserting of the Belkin adapter.

     

    Message was edited by: woodygee

  • nualaj2 Calculating status...
    Currently Being Moderated
    Apr 1, 2012 9:23 AM (in response to chriskalie)

    Please help!! bought the Imac 2 weeks ago, first mac we ever bought, and with a hubby as an IT Director it was a big thing for him to move from windows to mac... anyway, everything was working fine this morning... ive come to the computer this afternoon and the scrolling has completly stopped... the pointer has also gone black (but cant remember if it was before, although im sure it was white) it is now only working as a standard mouse... ive gone into the mouse preference settings and everything is clicked as it should be, ive restarted the computer, unpaired the mouse etc but nothing is working... i dont know what this magic pref is, i cant find it anywhere... what has happened to the mouse and how can i fix it...

  • katarax Calculating status...
    Currently Being Moderated
    Apr 13, 2012 3:50 AM (in response to Anthony Curcio)

    I got it!

    after a brief googling I found this http://gdgt.com/question/help-my-magic-mouse-no-longer-recognizes-scrolling-gej/

    And in fact, when I was installing USB Overdrive, it said that it may render magic mouse useless.

    Deleted Overdrive, restarted my mac and voila - all working now.

     

    In fact, MM goes crazy as it's handled by USB Overdrive, which doesn't support multitouch gestures at all.

    In my case, both overdrive and MagicPrefs were handling it, so it was unpredictable and maaaaad.

    But all good now

  • Dean Eller Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 14, 2012 2:49 PM (in response to Anthony Curcio)

    See Captfred's solution: I pasted it below.

    I just followed it and it worked perfectly! I would have never thought to look under the Universal Access preferences. (I salute you Cap'n.)

    _______________________________________________________________

     

     

    Anthony,

     

    Sometimes the scroll function gets unchecked in the conversion.  The option has moved to System Preferences > Universal Access > Mouse & Trackpad tab > Mouse Options... button > Check Scrolling.

     

    Regards,

    Captfred

  • SquitHiHat Calculating status...
    Currently Being Moderated
    Dec 30, 2012 10:26 AM (in response to Anthony Curcio)

    Hi Anthony,

     

    I see your problem goes back a while, and you may have fixed it in the meantime - but I came across your thread when I suffered the same fate recently. I had, however, been running 10.7 for some time where my mouse was working.

     

    So, this may work for you . . .

     

    I tried restarting my Mac in SafeBoot mode (basically all extensions are disabled)- something I've been doing for quite some time at home and work - and not as scary as it sounds!

     

    1. Shut down your mac
    2. Restart it - and right away hold down the shift key until you see the apple logo - and maybe the familiar lozenge shaped progress bar - don't be alarmed by this it's normal
    3. Your Mac will reboot and possibly ask you to type your password to log-in
    4. Log-in
    5. At this stage open a window and see if scrolling works again - it may be jerky - that's cos your extensions are turned off at this point . . .
    6. When it's started up - shut the Mac down again and wait 20-30 secs - not sure why - but just give it some time
    7. Start your Mac again in the normal manner - and hopefully your mouse will work again

     

    Basically - safeboot can solve a multitude of niggles - and I always make it my first port of call!

     

    Here's a link on apple site but it doesn't really explain much - for verification - http://support.apple.com/kb/PH11212

     

    Good luck - I hope this works for you!

  • tumlinso Calculating status...
    Currently Being Moderated
    May 21, 2013 7:50 AM (in response to cjbacca)

    I had the symptoms described in the OP: magic mouse would click and do basic tracking, but there was no scrolling and the tracking was jerky. I *knew* it was the MBA/bluetooth itself, not the mouse, because I tried another Magic Mouse I have on the same MBAir and had the same problem. I tried this solution, resetting the SMC, exactly according to the instructions for my machine (a late '11 MBA). It worked! The MM now scrolls correctly and tracks like normal. No idea what causes the problem, but it comes on suddenly.

     

    Thanks for the fix!

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.