Skip navigation

iMac drops Wifi connection after 10.7.4 update

79898 Views 234 Replies Latest reply: Feb 13, 2014 7:17 AM by Bikermanjohn RSS Branched to a new discussion.
  • yadah Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2012 7:44 PM (in response to clwen)

    I have the same problem

  • dstreufert Calculating status...
    Currently Being Moderated
    Nov 12, 2012 5:37 PM (in response to theneb.bstl)

    My wifi is dropping every 5-7 minutes also. I just have to turn wifi off and then right back on and it will work again for another 5-7 minutes. Waiting for a solution for this.....

  • peraleju Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2012 5:56 PM (in response to theneb.bstl)

    Hate to say and I know some of you may not like my answer but I had the same problem and it was frustrating to the point I wanted to return my iMac.  Instead I spent $150 on an apple router and have never had any issues again.  My wifi never drops.  When the Mac comes back from sleep, wifi is there ..no issues whatsoever in over two months.

     

    just my $0.02...

  • oldgranddad Calculating status...
    Currently Being Moderated
    Nov 13, 2012 6:57 AM (in response to peraleju)

    I have had an apple router for some time but still have the dropouts. Yesterday morning I could not watch any video more than a few seconds, later in the day one would run for several minutes before dropout. I'm using 10.8.2. When is apple going to correct this fault.

  • Palmolive44 Calculating status...
    Currently Being Moderated
    Nov 25, 2012 8:14 AM (in response to theneb.bstl)

    Hi,

    I had the same problem,

    I tried most of all solutions given in this post, but none of them worked. I finally solved the problem.

    I'm using a Freebox HD (which is the router) and in my original parameters : channels on the wifi configuration were automatically chosen.

    So I unchecked this and I manually chose the channel 1, restart the freebox and Voilà... Problem solved.

     

    For this :

    1) Go to your freebox Parameters panel : https://subscribe.free.fr/login/

    2 ) Go to "My Freebox" / "Wifi Parameters" / Wifi Canal

    3) Uncheck automatically and choose the channel 1 (you can also try the 6 and the 11)

    4) Restart your freebox and "Voilà!!"

     

    What is strange is this paramater (Automatic channels) on the router never disturbed my wifi connection before the update 10.7.4 (& also 10.7.5)

     

    Hope this will help some of you maybe on other brand routers !!

  • Rockin_R Calculating status...
    Currently Being Moderated
    Nov 26, 2012 6:23 AM (in response to Palmolive44)

    My 10.7.4 Mac drops my wifi too. Totally frustrating. Here's what I do to get back on: Go to System Preferences / Network / Diagonostics / Assist Me.

     

    As I go through the steps of the "Assist Me" script it asks me to select my wifi network. I click on my network and it reconnects from there. This is better than having to shut down the Mac and goes pretty fast but it still ***** that I have to do it in the first place.

     

    Apple, fix this crap.

  • dstreufert Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 6:36 AM (in response to Rockin_R)

    I ended up buying an apple router and it has worked great since then. not a cheap fix, but whatever.

  • dslieker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 26, 2012 5:32 PM (in response to theneb.bstl)

    I have a 1GB Time Capsule, and it's been dropping my 10.8.2 27'' iMac mid-2011 whenever I am uploading for too long. It's always the exact same pattern: I upload a large file, it bursts at a high speed, then goes to 75% speed for a minute, then cuts to 0kb/s

     

    I changed the channel to 1 on the Time Capsule, but it did not help.

  • Agentorange333 Calculating status...
    Currently Being Moderated
    Dec 30, 2012 2:49 AM (in response to theneb.bstl)

    I had problems with this too. Since this summer I´ve been really annoyed by wifi drops. The status bar showed full connection but I couldn´t access anything from the network.

     

    I´ve tried about "every" solution there is on different forums and now I´ve finally found something that worked.

     

    It seems that my iMac 27" doesn´t work with WEP password on my router. I changed it to WPA2 and it haven´t dropped since then.

     

    Hope this works for you!

  • philkdc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2012 11:12 AM (in response to Agentorange333)

    Had a similar experience.  A post in this forum suggested changing from WEP to WPA2 to address the drop problem.  I made this change and it addressed most of the drop problem.  There were still occassional unexplained drops.  But recently drops following sleep have become much more of a noticeable and annoying problem.

     

    Because of this drop issue I've not moved to Mountain Lion since I'm reluctant to introduce another new operating system after my unpleasant Lion experience. 

  • OutStandingApps Calculating status...
    Currently Being Moderated
    Jan 15, 2013 12:31 PM (in response to theneb.bstl)

    Well for me the problem was caused by my routing settings. It was 11/B/G/N Mixed mode and i have had constant WiFi dropping, since i have set to 11/G/N i have not had a single drop.

     

    Happy if it helped.

  • pdbowers Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 18, 2013 2:40 PM (in response to theneb.bstl)

    Here is what worked for me. Called Apple Support.  My iMac was not connecting to my wireless network, or would sporadically.  The kind agent told me that if I were to change the security settings in my router to WPA2 that more than likely would solve my problem. Prior to this I was simply using WEP encryption.  I thought he was nuts, but did as he suggested.  Well.  Its working absolutely flawlessly now. For those still using WEP, change your security settings and see if this works. I am happy again and not ready to use my Mac for scrap.

  • philkdc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 8:43 AM (in response to pdbowers)

    I too received this tip in this forum regarding changing to WPA2 from WEP.  This fix worked for me for several months with only occassional drops.  Within the past week however, my 2010 iMac consistently fails to connect to the internet upon waking from sleep.  Connection must be achieved manually using the network tray icon or system preferences.  Seems like WPA2 wasn't a permanent fix for me.

  • pdbowers Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 8:52 AM (in response to philkdc)

    Oh Lord....I hope this isnt the case for me. This will give me something to obsess over....

  • Nichter98 Calculating status...
    Currently Being Moderated
    Mar 4, 2013 7:45 PM (in response to pdbowers)

    Glad to see I'm not alone. I am running 10.8.2 Intel Core Duo.  Everytime my computer wakes up from sleep I have to reconnect manually from the wifi icon at the top right of the screen.  At a complete loss on this one.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.