Skip navigation

Sudden latency problems - any ideas?

964 Views 8 Replies Latest reply: Jan 25, 2013 1:54 PM by Pancenter RSS
greenfeld69 Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 16, 2011 3:43 AM

Hi all

 

I am recording on my iMac 27 Quad Core using an Apogee Duet.  I've got a track up-and-runnng with only a small amount of stuff going on.  Last night, while recording, I had NO latency whatsoever.  Now, the next day, when I arm a track to record, I am getting a noticable delay.

 

Why would it suddenly start like this?  Any ideas?  I can normally handles tens of tracks with no problem at all.

 

Thanks!

 

Steve

  • Eriksimon Level 6 Level 6 (10,410 points)
    Currently Being Moderated
    Jul 16, 2011 3:58 AM (in response to greenfeld69)

    Have you added any latency inducing plugins?

     

    If not, it often helps with these sudden long latencies to restart Logics' coreaudio. Go to Logic Pro>Preferences>Audio>Devices>Coreaudio, untick and retick Universal track mode, the Apply Changes button becomes available, you can click it, or you can simply dismiss the dialog window. Coreaudio will be restarted within Logic, often dissolving "overnight latency".

  • Rosenfred Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2012 2:22 PM (in response to greenfeld69)

    This is an old post but for anyone else who searches this and wants a soultion I've found a great workaround:

     

    - Go to your Ultilities > Audio MIDI Setup

     

    - A list should apper on the left of all interfaces. The interface you are trying to use should be on the list.

     

    - Click on the '+' symbol on the bottom of the list and select 'Create Agggregate Device', this should add a new virtual audio interface. Name it whatever you want, but make sure it's different then all of the others on the list.

     

    - On the right should be a list of available interfaces with inputs and outputs. Select the interface you would like to fix to be part of the virtual device.

     

    - Open up Logic and go to Logic > Preferenes > Audio

     

    - There should be an input and output device listed. Open up the drop down menu for the input device and the device you just created should be there. Select it as the input (and output as well if you're using it for the output) and it shouldn't have anymore issues. I don't know why this is, but it worked perfectly for me after I had this issue.

  • Eriksimon Level 6 Level 6 (10,410 points)
    Currently Being Moderated
    Dec 30, 2012 4:06 PM (in response to Rosenfred)

    Yes, doing all what you did includes what I prescribed back then: it reboots coreaudio (do anything in the prefs window that makes the Apply Changes button active, and then pressing that button or closing the window)

    That is what 'resets' the latency.

    Using an aggregate device doesn't prevent it from happening again though (mst common cause: using another program that also usescoreaudio, such as iTunes, or any other soundcapable program (internetbrowsers). Your recipe, though wel intended, is like going from Glasgow to London via Rio de Janeiro. Nice trip and you'll get where you set out to go, but it took more time than strictly necessary.

  • Rosenfred Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2012 10:33 AM (in response to Eriksimon)

    Well maybe I had a specifically straneg problem then because I tried your solution as well as many others and the latency would return shortly after. In fact, it would suddenly dissapear everytime any change was applied, only to come back a few minutes later. I realize my workaround is quite crude, but in my case and possibly others it may be the only immediate solution.

  • howardfromlondon Calculating status...
    Currently Being Moderated
    Jan 25, 2013 11:25 AM (in response to Eriksimon)

    I've got a similar issue. Got massive sudden latency - never had it before - On new project - with just a click running so no idea what's going on.

     

    Tried all the usual stuff - Buffer size down to 64 - Low Latency icon clicked and you're suggestions of ticking and untick universal track mode - but still not changing anything.

     

    Very very confused - any and all suggestions most gratefull recieved - Am on Apogee Duet - OS 10.7.5 Imac 3.4 Ghz with lots of empty memory - Just two inputs and latency coming in from scratch, even when I start a new project from Logic template.

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Jan 25, 2013 11:53 AM (in response to howardfromlondon)

    Unless you need Pro Tools compatibility leave Universal Track Mode selected, that's Logic's default condition, it has nothing to do with latency anyway.

     

    Also, unless you're running Latency inducing plugins (there are very few) there's no reason to select Low Latency Mode, that does nothing as well, might want to read up on what Low-Latency mode does, and why.

     

    Ok, so what changed recently, did you update the Operating System, is your Mac set to auto-update, a bad idea if running Logic is important.

     

    Any new plugins?

     

    In Logic's audio preferences, try selecting Built-In audio as the Input then switch back to the Apogee.

  • howardfromlondon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 25, 2013 1:13 PM (in response to Pancenter)

    First off - Thank you for taking the time to respond - seriously appreciated

     

    I have been auto updating - I'll switch that off.

     

    Good news it that I figured it out after prowling the boards - Turns out the recording delay had set itself off zero to +2000 or something riduclous like that! Reset it to zero and all is good.

     

    No idea how that happened as I've never used that option for anything before.

     

    Cracking on now - Very much appreciate the effort you made in replying though - Cheers for that.

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Jan 25, 2013 1:54 PM (in response to howardfromlondon)

    Seems like that's happened to  a couple of people lately, the recording delay shift. That function is to compensate for audio drivers that don't correctly report positioning info to Logic.

     

    Glad you got it sorted.

     

    btw, that's my middle name.

     

    p.s. see this thread for another "recoding delay" problem that can occur.

     

    https://discussions.apple.com/message/21027887#21027887

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.