Skip navigation

iPhone5 issues with WPA2/AES Wifi

186158 Views 537 Replies Latest reply: Feb 22, 2014 7:49 AM by jenniefromnew york RSS
  • McProtis Calculating status...
    Currently Being Moderated
    Dec 19, 2012 7:18 AM (in response to Paul Slatin)

    After updating to 6.0.2 and reseting the network settings, it does seem to be fixed.


    my ip5 is no longer loosing packets when connected to a WPA2  / AES cypher wifi network.


    hurray for apple.

  • Sebby* Calculating status...
    Currently Being Moderated
    Dec 20, 2012 5:09 AM (in response to McProtis)

    Last night I ran into the same problems as before. So I reset network settings, which perhaps is a necessary step. It now seems fine so I'll see how it goes. I really hope that these wi-fi issues are truly sorted this time.

  • JonnyITokyo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 20, 2012 6:38 AM (in response to Sebby*)

    I installed iOS 6.0.2. Still wifi as slow as ever.(iPhone 5)

    I tried resetting network settings didn't help. Slow slow hardly getting any data, well below 3G speeds.


    iPhone 4 etc still working good with normal wifi speeds.

  • pjbatten Calculating status...
    Currently Being Moderated
    Dec 20, 2012 9:16 AM (in response to Gabbana)

    Apple Care gave me a solution for my wifi problem.  I have a Netgear router with WPA2-PSK [AES] security enabled.  I keep loosing my wifi connection with an 2 week old iphone5.  Everytime I have to select my network and reenter my password.  Huge pain! Same thing happens if I leave the house and come back or if I cycle power.


    The Apple tech told me the OS is loosing the profile that automatically recognizes a known network and enters the password for you.  The solution was to manually enter my wifi connection.  You do this in the settings menu.  Rather than choose the network that the phone finds automatically you select "other".  You have to put in the name of your router exactly (caps or no caps) and you have to select the type of my case is was WPA2.


    So far it's working.  I've turned off wifi and turned it back on and cycled power on the phone.   Both times in connected automatically.  The Apple tech says this workaround seems to work most of time.  He told me to be on the lookout for the next OS version for a fix.  I currently have 6.0.2


    Good luck!

  • dgold1055 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 20, 2012 12:33 PM (in response to JonnyITokyo)

    Agreed - same slowness for me as well. Iphone 4S works fine. iPhone 5 slow on Wifi for most things. 6.0.2 has not fixed this - even after resetting network setttings.

  • kenalker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 20, 2012 2:40 PM (in response to C4RLOCO)

    IOS 6.0.2 fixed the problem for me.  I have a Linksys WRT54GL router running firmware v4.30.15.  I have the router set to WPA2-Personal.  My iPhone 5 has never been able to connect to the router successfully, yet my iPhone 4 always worked.  IOS 6.0.2 now allows me to connect and utilitize WiFi just fine.  I've only tried it for a few minutes, but so far, so good.

  • Marcofon Calculating status...
    Currently Being Moderated
    Dec 24, 2012 12:50 AM (in response to C4RLOCO)

    iOS 6.0.2 and same issues.. Well it is a bit worse for real. My iPhone 5 MAC address starts with 78:6C but I'm unable to know who is the manufacturer on hw address. Anyway, I think that is a true sowtware bug of iOS 6.X that is related with some kind and type of modems/routers. For a proof, even my iPhone 4 had the same issues, and all began with the development of iOS 6.

  • chiefgadd Calculating status...
    Currently Being Moderated
    Dec 27, 2012 7:59 AM (in response to C4RLOCO)

    my original iphone 5 would connect to my Linksys router when I selected it, but would not retain the connection long and would not automatically find and connect when I returned home.  All other Apple devices in my house work just fine.  I talked to Applecare and was sent a replacement, which does not work correctly either.  I don't know the production information on that one, but my replacement is a generation 7, production week 38, Factory is F1.


    My wife bought one just last week and we are having the same issues with it.  This iphone is from production week 46, generation 7, factory is C3.


    I have all the updated software on both of these.  Why can't Apple figure this out or do they not see it as a real issue?

  • Sebby* Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2012 3:55 PM (in response to Sebby*)

    I thought I'd post back now that I've had 10 days or so to test this update. Although a network settings reset was required, I can confirm that this update has, at long last, resolved the issue for me. My home wi-fi, which was previously unusable, now works perfectly.

  • luxtiger Calculating status...
    Currently Being Moderated
    Dec 31, 2012 12:46 AM (in response to C4RLOCO)

    After a 8 weeks waiting time i got my new Iphone 5 2 weeks ago.

    Before i was using an Iphone 4s

    I upgraded a couple days ago to ios 6.0.2

    Since then my phone is useless since Wifi is not working correctly anymore.

    Tried to reset network settings ->> no success

    Reinstall as a new Iphone --> no success.


    So the problem got worse for me with IOS 6.0.2

    I hope Apple fixes this problem soon with a new release, since my phone is unusable for me right now

    Seriously thinking about changing to another Phone manufacturer after 5 Iphones

  • don\'t look back Calculating status...
    Currently Being Moderated
    Jan 1, 2013 4:04 AM (in response to pjbatten)

    fantastic, this helps !!! I have been  searching for  a solution for my ihphone IV S and iphone 5 since ios 6 comes up. German apple support had no idea. now it works, thank you


    dont' look back

  • Anders Sjöström Calculating status...
    Currently Being Moderated
    Jan 3, 2013 7:26 PM (in response to C4RLOCO)

    Mine have the same problems and its start with 40:B3

    So it's more iPhones with this problem

  • Anders Sjöström Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 7:31 PM (in response to C4RLOCO)

    Nothing works this *****

  • chiefgadd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 4, 2013 1:14 PM (in response to pjbatten)

    Your solution did the trick!  I reset the network settings, then typed in the name of my local network and it worked.  It stays connected while here and reconnects when I return, just like it should!


    Thanks for the great idea!

  • marouim Calculating status...
    Currently Being Moderated
    Jan 5, 2013 9:34 PM (in response to BigZ12)

    You are absolutly right BigZ12!


    I have the same issue with Wifi, disconnects.


    After playing with my config on my Cisco access-point, setting-up to TKIP only without AES solve the issue!


    On top of that, Pages with iCloud wasn't working since the begining and it start syncing with iCloud as soon as I change my AP settings.


    Thanks a lot BigZ12 !

1 ... 29 30 31 32 33 ... 36 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (29)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.