7 Replies Latest reply: Dec 30, 2012 10:31 PM by Warwick Teale
Lewis Kopp Level 1 Level 1 (0 points)

I'm running Compressor 4.0.6 under 10.6.8 and it has been working great until a couple of days ago when my QuickCluster disappeared as an option for the cluster when submitting a job.  The only thing that showed up was base, single process mode.  Since I'm running on a 12-core MacPro, that doesn't come close to fully utilizing the machine and takes drastically longer to run - if it even completes the job as it often crashes.  It turned out that some memory I had added was flaky.  I took the extra memory out, removed Compressor 4 and Qmaster, reinstalled the 10.6.8 update, reinstalled Compressor 4 and still no go.  But to make matters worse - now the cluster option only has None as available.  So I can't submit anything.

 

When I look at the processes running in Activity Monitor I see Compressor only.  No qmaster or related processes are running.


I'm running out of ideas.  Any suggestions?  The only thing I can think of at this point is trying to restore from a backup of the OS drive or totally reinstalling the OS and updates.  Both of those options are a pain, but may be my only choice unless you folks can come up with something.

 

:-\

 

Lew

  • 1. Re: Qmaster won't start
    Russ H Level 6 Level 6 (14,255 points)

    A couple of things you should try.

     

    From Compressor in the menu toolbar, click Reset Background Processing.

     

    Downloading and running Compressor Repair may be able to re-establish any broken connections between Compressor and Qmaster (make sure the Trash Preferences box is checked).

     

    Good luck.

     

    Russ

  • 2. Re: Qmaster won't start
    Lewis Kopp Level 1 Level 1 (0 points)

    Russ:

     

    Thanks, but I tried both of those along with uninstalling Compressor using FCS Remover.  I even made sure I had the latest versions of both Compressor Repair and FCS Remover.  And I trashed the Preferences too.

     

    This one really has me confused.  I've had Compressor fail on certain videos before, but I was always able to at least submit jobs.  Now I can't even do that. :-\

     

    I'm starting to think that intermittent memory DIMM may have really screwed some things up.

     

    Lew

  • 3. Re: Qmaster won't start
    Russ H Level 6 Level 6 (14,255 points)

    Not sure it's memory related. A very similar thing happened to me (first losing my Quick Cluster option  – then losing all submit options). Interestingly, my C3.5 cluster options also got changed, although they still worked.

     

    I ended up uninstalling ALL the new downloadable pro apps. Then reinstalling (following Apple's recommendations for having both FCS 3 and FCPX on a non-partitioned drive); repairing permissions, then re-running Compressor Repair – all prior to reopening C4. Voila, things returned to normal.

     

    So my "technique" was to throw a lot of stuff at the problem. The downside is I don't know what worked or why.

    It's also interesting in that I've used Compressor routinely in the past three  versions with very seldom a glitch that wasn't an obvious operator error. A couple of the C4 updates, however, seem to have precipitated some flaky behavior.

     

    Good luck in resolving your issues.

     

    Russ

  • 4. Re: Qmaster won't start
    Lewis Kopp Level 1 Level 1 (0 points)

    Russ:

     

    Well, I uninstalled FCX, Motion, & Compressor 4, as well as FCS 3.  I then redownloaded & installed FCX, Motion and Compressort 4, repaired permissions, reran Compressor Repair, shutdown, started up, and I can at least submit a Compressor now.  So that's an improvement. :-}  But while I can see the compressord processes in Activity Monitor, the QuickCluster isn't showing up.  I've resubmitted the job I couldn't run yesterday to see if it will complete.  When it is done (success or failure) I'm going to rename the Mac in both Compressor and the Sharing options so that the name is not just the same, but all one word and see if that helps.

     

    This wouldn't be quite so bad if I could save the dmg of the install downloads, but even with my fairly high speed connection, it takes a long time to download and to have to keep retrying is a major pain.

     

    Thanks for the suggestions!  Hopefully full functionality will be back before to much longer. :-}

     

    Lew

  • 5. Re: Qmaster won't start
    Russ H Level 6 Level 6 (14,255 points)

    Well, that's a hopeful start.

     

    Perhaps something changed in Qmaster settings? Could you post a screen shot of the Computer Sharing settings?

     

    Russ

  • 6. Re: Qmaster won't start
    Lewis Kopp Level 1 Level 1 (0 points)

    Russ:

     

    Well, for now I've given up on Compressor 4.  I'm still not sure what happened, but while it will work with a single process, and while I can see the compressord processes sitting there waiting for work when I use Activity Monitor, nothing I do will get the cluster to show up and be selectable.

     

    So for now I'm just using Compressor 3.5.3.  It works just fine.  I'm processing the file I'd been having problems with right now, with 7 instances of CompressorTranscoderX and it looks like it is going to finish in about 46% of realtime.  Which is the best I've seen so far on the Mac. :-)  And Compressor 3.5.3 isn't even close to using up all of my 8GB of RAM like Compressor 4 does.

     

    Thanks for the help!

     

    Lew

  • 7. Re: Qmaster won't start
    Warwick Teale Level 3 Level 3 (575 points)

    Hi Lew, yeah you might want to quickly check this

    link https://discussions.apple.com/message/17356372#17356372

     

    If look down there and you will see a post from me on the qmaster objects you might want to purge (delete | rm) and a very detailed procedure I use when I get glitches in qmaster in my set up. It's also worked for many others and is worth a try.

     

    Generally these issue are related to stale or "possibly damaged" parms.

     

    Post your results for others.

     

    HTH

     

    cheers

     

    w