4 Replies Latest reply: Dec 31, 2012 1:59 PM by Joe Felice
Joe Felice Level 2 (150 points)

Ok, I've had a look and can't seem to find any recent discussions on this issue - the last one I could find was in the Mac OS X Lion community and there hasn't been a post since 2011.

 

So, the title says it all. Basically, whenever I press a key on the AppleTV remote my iMac wakes up. It doesn't matter whether I'm playing a movie, a YouTube video, a trailer, etc etc - If I press a button on the remote then the iMac wakes up. This is especially annoying when watching YouTube videos or trailers because you're using the remote every couple of minutes.

 

So, my configuration is as follows:

 

- AppleTV 3 running the latest software.

- iMac (mid-2010) running the latest version of Mountain Lion.

- iTunes 11.0.1 installed, Home Sharing turned on, not paired with any remotes.

 

Now, I could turn off home sharing as all my music, podcasts, movies etc are actually located in iTunes on my MacBook Pro, not the iMac, but I'd prefer not to have to do that as the iMac is located in a convenient location in terms of my home theatre setup, so it's easy for me to use it to access my iTunes Library on the MacBook regardless of where it is.

 

So, any suggestions anyone?

 

Thanks!

 

Joe.

  • Winston Churchill Level 10 (95,666 points)

    If you don't want to use a remote with your computer the easiest thing to do is just to turn the IR off. (System Preferences/Security/General)

     

    If you still want to use your computer remote then you must pair your computers remote with the computer AND the Apple TV remote with the Apple TV.

     

    To pair a remote with a device hold down the menu and FF buttons together for six seconds or until you see a chain icon on screen (best take the computer into another room, or turn it off, when you do this)

  • Joe Felice Level 2 (150 points)

    Thanks for taking the time to reply!

     

    Winston Churchill wrote:

     

    If you don't want to use a remote with your computer the easiest thing to do is just to turn the IR off. (System Preferences/Security/General)

     

     

     

    Unfortunately I don't have that option. That is, if I go to System Preferences/Security & Privacy/General there is no setting in relation to IR.

     

     

    Winston Churchill wrote:

     

    If you still want to use your computer remote then you must pair your computers remote with the computer AND the Apple TV remote with the Apple TV.

     

     

    I don't have a computer remote, only the Apple TV one and at present iTunes is not paired with any remotes. That said, I'm not sure whether the Apple TV remote is actually "paired" with the Apple TV - but it certainly controls the Apple TV when I use it, but I can't use it to watch movies on the iMac - so I assume that it's not paired to the iMac in any way whatsoever.

     

    Note sure whether I'm confusing matters here or not, but I've also set up my Harmony One universal remote to work with the Apple TV and that's the one I normally use, although I do occassionally use the Remote app on my iPhone. Both the Universal Remote and Apple TV remote result in the same behaviour (that is, waking up the iMac). I don't recall whether the Remote app on the iPhone also does the same thing, but will have to test that.

  • Winston Churchill Level 10 (95,666 points)

    Pairing the Apple TV remote with the Apple TV alone won't help.

     

    I'm not sure about the IR option, it should be there.

  • Joe Felice Level 2 (150 points)

    Winston Churchill wrote:

     

    I'm not sure about the IR option, it should be there.

     

    Ok, this got me thinking so I decided to delve a little deeper. I unlocked the padlock and the Advanced button became active, clicked on that and saw the option to "Disable remote control infrared receiver". Checked the box and all seems to be okay now!

     

    Thanks for leading me into the right direction.