1 Reply Latest reply: Dec 31, 2012 11:05 AM by BDAqua
waterflute Level 1 Level 1 (0 points)

I recently bought this modem in Indonesia. The specifications on the box says that it is compatible with Mac: OS X 10.5, 10.6, 10.7. My Macbook is on OS X 10.5.8, but when I installed the driver, I can't use it. I went back to the place I bought it, but my Indonesian is not that good and the counter staff just told me that the modem is fine, just that it can't be used on a mac and was told to buy another modem that might work.

 

Does anyone have any ideas on how to fix this issue before I actually I have to go and buy another modem. I just don't understand how the specifications say that it can work but it doesn't.


MacBook, Mac OS X (10.5.8)