Skip navigation

restore a 5th generation ipod touch

816 Views 5 Replies Latest reply: Jan 1, 2013 1:07 AM by AAmommy RSS
Kaitlin98 Calculating status...
Currently Being Moderated
Dec 28, 2012 1:23 PM

I accidentally unplugged my 5th generation whilst it was downloading a software update and now its stuck  - when I plug it into the laptop, itunes recognises it but then says it needs to be restored - I click OK and it says its got to update and restore - it then downloads software (circa 45 mins) but then doesn't update or restore - tried 4 times now - anyone any ideas please?

iPod touch

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.