11 Replies Latest reply: Jan 3, 2013 3:50 AM by De
De Level 1 Level 1 (0 points)

Each time I close pages it reverts to the 'english' setting - how do I save the changes as default for all documents?

 

Even the Apple Shop couldn't help, and being dyslexic I need the help of a spell checker.

 

Thank you for your help.


Pages, Mac OS X (10.7.5)
  • 1. Re: My pages keeps loosing the British English setting!
    PeterBreis0807 Level 7 Level 7 (29,640 points)

    Open:

     

    Menu > Apple > System Preferences > Language & Text > Edit List > check British English > OK > drag it to the top of the list

     

    Now when you restart Pages British English will be the default language.

     

    Peter

  • 2. Re: My pages keeps loosing the British English setting!
    De Level 1 Level 1 (0 points)

    Hi Peter,

     

    Many thanks for the help - I have already tried this and it keeps reverting to 'English' not sure why - but I changed the dictionary to the british thesorus and the problem seems to have stopped - I posted this in reply in case it helps someone else.

     

    As a recent convert from PC's it seems strange that all the settings dont align.......

     

     

    De

  • 3. Re: My pages keeps loosing the British English setting!
    PeterBreis0807 Level 7 Level 7 (29,640 points)

    The settings do align.

     

    The System Preferences apply the default language for both Dictionaries and the User Interface (menus etc).

     

    You can override that inside Pages and other applications with local language settings eg apply French to french quotes within English text.

     

    A mistake a lot of people make is copying and pasting or dragging in material from the Internet or other sources which has its own settings. Think of language as like bolding or a font or color applied to specific text. You can also have a language of "None" which will ignore that text in the spell checker.

     

    Being an attribute of the Text, language is also part of any Styles you may apply and if you set selected text to a particular language when you save the document that is what sticks.

     

    The defaults however apply when you start new documents, that is the definition of default. It is the setting when no other setting has been applied. It does not apply retrospectively. It only applies if you select the text and make it what you want it to be, just like any other styling.

     

    You don't expect all text in a document to be bold, just because you slected bold for some text, the same is true for language as well. It stays what it was when you opened it, or pasted it until you change it. Newton's Law of Inertia.

     

    Peter

  • 4. Re: My pages keeps loosing the British English setting!
    De Level 1 Level 1 (0 points)

    Peter,

     

    Thank you for your comprehensive info - its gretly appreciated.

     

    I had assumed that the system would be as you said, having set my system preferences for language and text as English and British English  for spelling and then installed Pages. I was amazed to find that when I typed 'relise' the system wanted to make me type 'realize' in Pages the spelling setting hadn't transferred; and when I set it in a new document it didn't retain for future documents. I tried many web solutions without success- then found the dictionary when I set that to British thesaurus all seems well and the document opens in a default British English spelling.

     

    Whilst it seems ok - I am not sure if my solution is proper or just a work around as the spell check in here is still in US English!

     

    Thanks again for contributing - its greatly appreciated.

     

    De

  • 5. Re: My pages keeps loosing the British English setting!
    fruhulda Level 6 Level 6 (15,110 points)

    Only the new documents will have British English as default. Those already created you have to change the language for if needed by selecting the text and in the Inspector palette > T > More > Language change ti to B.R.

  • 6. Re: My pages keeps loosing the British English setting!
    PeterBreis0807 Level 7 Level 7 (29,640 points)

    I think you may be confusing "English" and "British English".

     

    Apple uses the term "English" for American English. All non-American versions are labeled with their country names.

     

    Peter

  • 7. Re: My pages keeps loosing the British English setting!
    De Level 1 Level 1 (0 points)

    HI fruhulda,

     

    Thanks for your help - I understand your point - the issue I had was that pages would not default to Brit Eng, for new documents.

    I don't have any old docs as I just migrated to Apple from a pc.

     

    Thank you

     

    De

  • 8. Re: My pages keeps loosing the British English setting!
    PeterBreis0807 Level 7 Level 7 (29,640 points)

    You are confusing us. You said you had set your Language to both English and British English.

     

    How do you do that? It is one or the other and if you have it set to British English it correctly spell checks unless you have done something else with the text. Like set the language of selected text in Pages to English or none.

     

    Peter

  • 9. Re: My pages keeps loosing the British English setting!
    De Level 1 Level 1 (0 points)

    Sorry Peter,

     

    The system preferences under language and text are set, on the Language tab to English - there is no other English option, then on the Text tab the spelling is British English, under formats the region is United Kingdom. Input sources is set to British.

     

    Since I changed the dictionary to British Dictionary and thesaurus it seems ok as does keynote.

     

    In Pages when I open a doc the inspector shows English not British English, but now spells British, if there is no document open the language option isn't available in inspector  - if i open the document then it is available but doesn't save for future documents. There doesn't seem to be a save option?

     

    I feel like I found a work around but not a fix.

     

    I hope that helps clarify?

     

    De

  • 10. Re: My pages keeps loosing the British English setting!
    PeterBreis0807 Level 7 Level 7 (29,640 points)

    You didn't follow my instructions above.

     

    You have to go into Edit list and check British English then drag it to the top of the language list.

     

    You currently still have (American) English as your default.

     

    You must have omitted a large part of the set-up when you first started up your Mac because that sets up your location and would have made the correct British English setting, along with metric measures etc.

     

    Peter

  • 11. Re: My pages keeps loosing the British English setting!
    De Level 1 Level 1 (0 points)

    Peter,

     

    Thank you so much for your patience, I hadn't realised that menu wasnt exhaustive and there is a whole range of hidden languages in there under edit.

     

    Not sure what I missed or if I assumed a UK MacBook set to English was correct - but thats it - job done sorted!

     

    Thank you so mutch!

     

    De