Skip navigation

Apple TV 5.1.1 update fails

9652 Views 11 Replies Latest reply: Jun 22, 2013 3:50 PM by Sunny Kenora RSS
speedracer1999 Calculating status...
Currently Being Moderated
Nov 30, 2012 6:28 AM

I tried to update my brand new Apple tv 3 to v5.1.1 firmware and it goes through Step 1 " Preparing Update" it get about 95% and then the process aborts and says Update Failed, please restart and try again. I restarted the device and tried again. Same issue. Currently using V5.1 firmware.


Apple Please HELP!

Apple TV, iOS 5.1.1


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.