Skip navigation

Mail receiving but not sending

908 Views 5 Replies Latest reply: Jan 3, 2013 6:49 PM by plcmms RSS
plcmms Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 8, 2011 7:54 PM

I am helping a friend troubleshoot an issue where he is unable to send email from his MacBook.  Here's the situation.


He recently moved to central Texas from North Dakota and is using Suddenlink as his ISP while in Texas.  However, he would still like to continue using Midco, his North Dakota ISP, as his email service provider while he is in Texas.  He is using a wireless modem/router and connects to it with a newly purchased iPad and a MacBook running Snow Leopard v 10.6.8.


Since connecting up to Suddenlink a couple of weeks ago he has been able to send and receive emails from his iPad using the Midco incoming and outgoing mail servers with no problems.  However, his MacBook is not able to send email out using the Midco outgoing mail server.  He does receive email from the Midco incoming server, however.


I have helped him troubleshoot this problem on his MacBook and can not fix the outgoing server issue.  Here's what I've done with no success;


verified all input fields, passwords, selection boxes, and radio buttons (Keychain also has the correct password for both servers).  Also checked the settings against the iPad.

deleted the file and recreated his mail account

tried using the default port selection (25, 465, and 587), and also tried the Custom port setting 465.  (Midco only accepts email from port 25 and 465 so it wasn't necessary to try port 587.  Suddenlink blocks all incoming traffic from port 25 unless it goes thru their outgoing mail server (to confirm this I ran the telnet command in Terminal and successfully communicated with Midco's outgoing server on port 465, but port 25 did fail to communicate, so I did not bother to use Custom port 25.)

Checked his iPad to determine what port it was using for the outgoing server and it was 465.  Tried this on the MacBook several different times through all of these efforts.

created a new user account and set up his Midco email account in that new user account

Repaired permissions

ran fsck command in single-user mode

restarted in Safe Mode and tried to send mail from both user accounts

spent an hour and a half on the phone with Midco tech support trying every thing they could think of, which was basically what we had already tried.  They were stumped.  They told us we did not have to use their outgoing mail server and that we could use the Suddenlink outgoing mail server.


So, after exhausting everything we could think of trying, he called Suddenlink and got an email account.  Now he is using the Suddenlink outgoing mail server and the Midco incoming mail server and everything is working.


This is indeed perplexing to us.  Why, oh why, is his MacBook not able to send email using the Midco outgoing server?  What are we overlooking?


Your help is greatly appreciated.

  • brettfromsd Calculating status...
    Currently Being Moderated
    Jan 2, 2013 8:07 AM (in response to plcmms)

    did you ever get a response from this question? 

  • brettfromsd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 8:42 AM (in response to plcmms)

    Thanks for the reply.   My problem seems somewhat similar, except it is my desk top that is acting up and the mobile devices are working.  Seems to be one or the other. 


    Midco is a cable company so I do wonder if it is a matter of "if they can" over "they don't allow" service outside their area...  But in my case they swear up and down that it is not them and I have to contact apple.   So I am going to bring my desktop in to my local shop and I have to pay someone for what I increasingly believe is a Midco problem and the solution should come with the service.


    Thanks again it was informative.  



  • brettfromsd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 6:43 PM (in response to plcmms)

    Just wanted to say thanks for pointing me in the right direction again.  Got my computer back from my local apple shop and it was Midco.   They don't update something on their end as much as they should and it makes things go out of wack for verifing and trusting passwords and such.   So we got it figured out. 


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.