Skip navigation

My pages keeps loosing the British English setting!

672 Views 11 Replies Latest reply: Jan 3, 2013 3:50 AM by De RSS
De Calculating status...
Currently Being Moderated
Jan 1, 2013 10:29 AM

Each time I close pages it reverts to the 'english' setting - how do I save the changes as default for all documents?

 

Even the Apple Shop couldn't help, and being dyslexic I need the help of a spell checker.

 

Thank you for your help.

Pages, Mac OS X (10.7.5)
  • PeterBreis0807 Level 7 Level 7 (27,340 points)
    Currently Being Moderated
    Jan 1, 2013 2:00 PM (in response to De)

    Open:

     

    Menu > Apple > System Preferences > Language & Text > Edit List > check British English > OK > drag it to the top of the list

     

    Now when you restart Pages British English will be the default language.

     

    Peter

  • PeterBreis0807 Level 7 Level 7 (27,340 points)
    Currently Being Moderated
    Jan 1, 2013 3:25 PM (in response to De)

    The settings do align.

     

    The System Preferences apply the default language for both Dictionaries and the User Interface (menus etc).

     

    You can override that inside Pages and other applications with local language settings eg apply French to french quotes within English text.

     

    A mistake a lot of people make is copying and pasting or dragging in material from the Internet or other sources which has its own settings. Think of language as like bolding or a font or color applied to specific text. You can also have a language of "None" which will ignore that text in the spell checker.

     

    Being an attribute of the Text, language is also part of any Styles you may apply and if you set selected text to a particular language when you save the document that is what sticks.

     

    The defaults however apply when you start new documents, that is the definition of default. It is the setting when no other setting has been applied. It does not apply retrospectively. It only applies if you select the text and make it what you want it to be, just like any other styling.

     

    You don't expect all text in a document to be bold, just because you slected bold for some text, the same is true for language as well. It stays what it was when you opened it, or pasted it until you change it. Newton's Law of Inertia.

     

    Peter

  • fruhulda Level 6 Level 6 (14,740 points)
    Currently Being Moderated
    Jan 2, 2013 9:10 AM (in response to De)

    Only the new documents will have British English as default. Those already created you have to change the language for if needed by selecting the text and in the Inspector palette > T > More > Language change ti to B.R.

    MacBook Pro, Mac OS X (10.6.8), 4 GB DRAM, and Mountian Lion 10.8.2
  • PeterBreis0807 Level 7 Level 7 (27,340 points)
    Currently Being Moderated
    Jan 2, 2013 9:43 AM (in response to De)

    I think you may be confusing "English" and "British English".

     

    Apple uses the term "English" for American English. All non-American versions are labeled with their country names.

     

    Peter

  • PeterBreis0807 Level 7 Level 7 (27,340 points)
    Currently Being Moderated
    Jan 2, 2013 1:27 PM (in response to De)

    You are confusing us. You said you had set your Language to both English and British English.

     

    How do you do that? It is one or the other and if you have it set to British English it correctly spell checks unless you have done something else with the text. Like set the language of selected text in Pages to English or none.

     

    Peter

  • PeterBreis0807 Level 7 Level 7 (27,340 points)
    Currently Being Moderated
    Jan 2, 2013 5:14 PM (in response to De)

    You didn't follow my instructions above.

     

    You have to go into Edit list and check British English then drag it to the top of the language list.

     

    You currently still have (American) English as your default.

     

    You must have omitted a large part of the set-up when you first started up your Mac because that sets up your location and would have made the correct British English setting, along with metric measures etc.

     

    Peter

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.