Skip navigation

HT4974: OS X Server: Changing the service data storage location

Learn about OS X Server: Changing the service data storage location

HT4974 Changing file service location for Groups

768 Views 7 Replies Latest reply: Jan 2, 2013 5:32 PM by tim_r_66 RSS
tim_r_66 Level 1 Level 1 (30 points)
Currently Being Moderated
Dec 30, 2012 11:26 AM

Who has found the "separate interfaces" for File Service data mentioned in the referenced article?  I cannot figure out how to get Mountain Lion OS X Server to move away from the /Groups folder for Group Services.





Mac mini, OS X Server
  • FromOZ Level 2 Level 2 (400 points)
    Currently Being Moderated
    Jan 1, 2013 5:54 AM (in response to tim_r_66)

    Hi there


    I have been looking at this also and am also very annoyed that Apple has chosen not to surface this functionality in the Server administration GUI for system administrators. It must be part of their drive to 'prettify' OS X Server — a terrrible mistake and the persons responsible should be sacked and some people with real (painful) sysadmin experience be put in responsibility. Strong words I know, but read on...


    The minute someone decides to install OS X Server they go from being a 'user' to being, whether they like it or not, a 'sysadmin'. It is no trivial thing being a systems administrator, and sysadmins very quickly, with respect to touching systems, become familiar with this sentiment : "Be afraid, be very afraid..."


    The functionality to change the location of the File Sharing  — Groups, Server Public (Shared Items) & Users — mount points exists in OS X Server. In fact it can (should be able to I believe — I have not tried it... yet) be changed with one command... if necessary preparations have been done.


    To view all the server settings for file sharing issue this command in Terminal:


    sudo serveradmin settings sharing


    we will then see the following for Groups (there is more listed for users etc. folders I haven't shown), I have blanked out some site specific information.


    sharing:sharePointList:_array_id:/Groups:dsAttrTypeStandard\:GeneratedUID = "xxx"

    sharing:sharePointList:_array_id:/Groups:smbName = "Groups"

    sharing:sharePointList:_array_id:/Groups:afpIsGuestAccessEnabled = no

    sharing:sharePointList:_array_id:/Groups:smbDirectoryMask = "0755"

    sharing:sharePointList:_array_id:/Groups:ftpIsShared = no

    sharing:sharePointList:_array_id:/Groups:afpName = "Groups"

    sharing:sharePointList:_array_id:/Groups:smbCreateMask = "0644"

    sharing:sharePointList:_array_id:/Groups:ftpIsGuestAccessEnabled = no

    sharing:sharePointList:_array_id:/Groups:nfsExportRecord = _empty_array

    sharing:sharePointList:_array_id:/Groups:path = "/Groups"

    sharing:sharePointList:_array_id:/Groups:smbIsGuestAccessEnabled = no

    sharing:sharePointList:_array_id:/Groups:name = "Groups"

    sharing:sharePointList:_array_id:/Groups:smbInheritPermissions = no

    sharing:sharePointList:_array_id:/Groups:ftpName = "Groups"

    sharing:sharePointList:_array_id:/Groups:smbIsShared = yes

    sharing:sharePointList:_array_id:/Groups:afpIsShared = yes

    sharing:sharePointList:_array_id:/Groups:isIndexingEnabled = yes

    sharing:sharePointList:_array_id:/Groups:dsAttrTypeNative\:sharepoint_group_id = "xxx"

    sharing:sharePointList:_array_id:/Groups:mountedOnPath = "/"


    This is based on, in my installation, of having the Groups folder in the original default location of "/Groups". One of the lines shows clearly what needs to be changed to move (change mount point) '/Groups' to a new location...


    The concern I have with the way you moved the Groups folder is it may not work cleanly long term because just symbolically linking the folder may not be sufficient.


    Also using rsync with '-avvE' options copies the extended attributes (ACLs) but setting/copying the (traditional) Unix owner and group ownership & permissions (which are also used by OS X) are not done. If the command is executed as root then all the copied files & directories will change owner & group to root's. The following rsync switches should be used






    preferably though the Unix 'cp' command should be used with the '-a' switch, something like this:


    cp -a /Groups /Volumes/VolumeName/SomeNewFolder


    N.B. no trailing '/' is used.


    Of course this is untested by myself as yet, and you should check and confirm yourself. I have a Parallels OS X virtual machine I will install OS X Server on to try this, I will not do on my production server.


    You will note that I have not listed the the serveradmin settings command to change where OS X Server should look for the '/Groups' folder can you see what it should be? I can post what I believe it should be if you wish, let me know.


    Of course all of the above relies on the fact that OS X Server will not get 'upset' with us changing a setting outside of a, non-existant in the first place, GUI surfaced settting function. Which again is why I would like to test this on a virtualised server. Of course you can give it a try, I would be obviously interested to hear how it goes — I would do a full backup first though. After making the serveradmin settings change I would reboot the server.

    Mac mini, OS X Server
  • FromOZ Level 2 Level 2 (400 points)
    Currently Being Moderated
    Jan 2, 2013 1:17 PM (in response to tim_r_66)

    I would have thought the command would be


    sudo serveradmin set sharing:sharePointList:_array_id:/Groups:mountedOnPath = "/Volumes/User_Data/"


    because the (additional path) for groups is defined in


    sharing:sharePointList:_array_id:/Groups:path = "/Groups"


    which you don't need to change.


    The original (well on my system) setting for the mountedOnPath is:


    sharing:sharePointList:_array_id:/Groups:mountedOnPath = "/"


    From the root path "/" on my machine I see this


    drwxrwxr-x+  5 root  admin      170 Dec 27 18:31 Groups


    so the 'mount point' is going to change from "/" to "/Volumes/User_Data/"


    The 'localaccounts' and 'workgroup' folders come off /Groups/.


    The only thing I am not sure of is whether it should be "/Volumes/User_Data/" or "/Volumes/User_Data", without the trailing slash. Obviously "/" is a special case. Try it and see


    Also one hopes that there is no other location where path settings have to be changed...

    Mac mini, OS X Server
  • FromOZ Level 2 Level 2 (400 points)
    Currently Being Moderated
    Jan 2, 2013 1:49 PM (in response to tim_r_66)

    Documentation about the meaning of mountedOnPath vs path would sure be nice ;-)


    Any (decent) documentation would be nice


    I was really disappointed to see the drop in quantity and quality of server documentation from Snow Leopard to Lion/ML.


    Also given that the lowest cost for server based support from Apple is $ 6000 per year (ouch) for 10 incidents per year we need all the docs we can get!


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.