Skip navigation

email Disconnect after HELO

1150 Views 33 Replies Latest reply: Jan 4, 2013 9:06 AM by BioRich RSS
1 2 3 Previous Next
BioRich Level 1 Level 1 (65 points)
Currently Being Moderated
Jan 2, 2013 1:36 PM

Hi there. 

 

I'm trying to troubleshoot my middleware (Lasso) that's trying to send emails into my mail server.  Both the middleware and the mail server are on the same machine.  The log states the following:

 

Jan  2 15:53:16 alpha.mydomain.com postfix/postscreen[43828]: CONNECT from [192.168.1.7]:58759 to [192.168.1.7]:25

Jan  2 15:53:16 alpha.mydomain.com postfix/postscreen[43828]: PREGREET 20 after 0 from [192.168.1.7]:58759: HELO [192.168.1.7]\\r\\n

Jan  2 15:53:16 alpha.mydomain.com postfix/smtpd[43829]: connect from alpha.mydomain.com[192.168.1.7]

Jan  2 15:53:16 alpha.mydomain.com postfix/smtpd[43829]: lost connection after HELO from alpha.mydomain.com[192.168.1.7]

Jan  2 15:53:16 alpha.mydomain.com postfix/smtpd[43829]: disconnect from alpha.mydomain.com[192.168.1.7]

 

The middleware's log states that it couldn't connect to the mail server (under directives for alpha.local and alpha.mydomain.com), and I am assuming that its log is less informative due to the lack of feedback from the mail server.  The mail server's log above indicates that a HELO was received, then the disconnection happens.  Over and over again, under all kinds of scenarios.

 

There's a valid username and password for a user on the server that's being used for authentication.  I've loosened up the authentication methods on the server, set to "automatic".  Didn't work.  Set it up to "Custom" (APOP, CRAM-MD5 and Digest-MD5).  Didn't work.  A developer for the middleware wants me to test to see if it's an authentication issue.  I don't think it is, but I want to make sure. 

 

Just for comparison, I tried setting it up using smtp.gmail.com and it worked.  There is no un/pw combination needed for that SMTP system, and it went through just fine. 

 

Is there a way to take away authentication?  Yes I know it's a real problem, but it's for a couple of minutes for testing purposes only.  This might lead to them reviewing their protocol for authentication if I can prove it's their software.

 

Thanks for any insight.  Truly appreciated.

 

Cheers

Mac Pro, OS X Mountain Lion (10.8.2), Hypercard UG!
  • pterobyte Level 6 Level 6 (10,910 points)
    Currently Being Moderated
    Jan 3, 2013 2:01 AM (in response to BioRich)

    Since your Lasso/FM Server is on your internal subnet, simply add its IP to the mynetworks parameter in main.cf and don't set Lasso to authenticate.

     

    If you still wish to authenticate, you may want to try clear/plaintext first for the sake of troubleshooting. Many software packages have problems with different authentication methods.

  • pterobyte Level 6 Level 6 (10,910 points)
    Currently Being Moderated
    Jan 3, 2013 5:22 AM (in response to BioRich)

    Simply add this:

     

    mynetworks = 127.0.0.0/8, [::1]/128, 192.168.1.0/24

     

    at the end of:

     

    /Library/Server/Mail/Config/postfix/main.cf

     

    (Don't worry about the duplicate parameter, Postfix will keep the last one it encounters. This has the benefit that you can put all your manual changes at the end of the file for easier reading and less interference with Server.app)

     

    When done, issue:

     

    sudo postfix reload

     

    HTH,

    Alex

  • pterobyte Level 6 Level 6 (10,910 points)
    Currently Being Moderated
    Jan 3, 2013 9:21 AM (in response to BioRich)

    Could you please post the output of:

    postconf -n -c /Library/Server/Mail/Config/postfix

    Maybe some other parameters are not OK.


    Also, did you modify the correct main.cf file inside /Library/Server/Mail/Config/postfix ? The one in /etc/postfix gets overwritten with the one inside /Library/Server/Mail/Config/postfix

  • pterobyte Level 6 Level 6 (10,910 points)
    Currently Being Moderated
    Jan 3, 2013 10:01 AM (in response to BioRich)

    Try adding this to the end of that main.cf as well:

     

    smtpd_helo_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname

     

    If it still doesn't work, make sure your Lasso/FM app is not trying to authenticate. Also, try sending once more and please post the relevant bits of:

    /var/log/mail.log

    /Library/Logs/Mail/mailaccess.log

    /var/log/system.log

    for the timeframe of your sending attempt.

  • UptimeJeff Level 4 Level 4 (3,390 points)
    Currently Being Moderated
    Jan 3, 2013 7:39 PM (in response to BioRich)

    A couple questions/thoughts

     

    - In lasso, did you specify a hostname or IP address?

         did you try: 127.0.0.1

     

    - In lasso, can you specify a port?

         If so, try:   127.0.0.1  port 10025

     

    - In lasso- disable authentication, you shouldn't need it.

     

    - are you sure the suggestion Alex posted is in place

    smtpd_helo_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname

  • pterobyte Level 6 Level 6 (10,910 points)
    Currently Being Moderated
    Jan 4, 2013 2:16 AM (in response to BioRich)

    127.0.0.1 or localhost won't work if Lasso is not on the same machine as the mail server

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.