1 2 Previous Next 18 Replies Latest reply: Jan 4, 2013 7:25 AM by lexar123
lexar123 Level 1 Level 1 (0 points)

I updated Aperture to 3.4 and as before sharing my iPhoto library.

 

When I try and use any plug-ins like dfine or others I get the following error.

 

Editing Error.

One or more of the selected versions has a original files which is still being imported.  Please wait for the file to copy to complete and try again.

 

 

I tried this with several different plug-ins and many different pictures.

However If I import a picture into the aperture library then I can use the plug-ins but if I try and do it using the iPhoto library I cannot.

 

Any ideas??

  • 1. Re: aperture 3.4 plug-ins give Editing Error..
    lexar123 Level 1 Level 1 (0 points)

    No one is having a simiar issue???

  • 2. Re: aperture 3.4 plug-ins give Editing Error..
    mb999 Level 1 Level 1 (0 points)

    I too have the same problem with all plugins.

     

    I had been using iPhoto for quite a while building up a whole catalogue of pictures and albums.Whern I purchased Apperture I told it use the iPhoto libraries rather than create a new one.

     

    I noticed the same as you that only the NEW images that were loaded into Aperture can be edited by the plugins.

     

    Please can someone tell us how to fix this.

  • 3. Re: aperture 3.4 plug-ins give Editing Error..
    lexar123 Level 1 Level 1 (0 points)

    Yes you are correct.. it seems only the previous pics before moving to Aperture.

     

    I also tried instead of sharing to move everything to the Aperture library and that did not fix anything!

    However no one seems to have an answer and no replies so far

  • 4. Re: aperture 3.4 plug-ins give Editing Error..
    léonie Level 9 Level 9 (51,730 points)

    What are the Aperture versions you are using exactly? I just made several tests with one of my iPhoto libraries - opened it in Aperture and tried the plug-ins PT Lens, BorderFX, ToonIt!  None of the images have been imported using Aperture, and all plug-ins worked as expected.

     

    So it seems not to be a general plug-in problem, but must be depending on something else, maybe the version of the plug-in or the Aperture version.

     

    My Apeture version is 3.4.3 and iPhoto 9.4.2;

  • 5. Re: aperture 3.4 plug-ins give Editing Error..
    mb999 Level 1 Level 1 (0 points)

    Hi

     

    (Answering this from work machine so can't give exact version)

     

    I'm using the latest version 3 just downloaded from the app store Jan 1st 2013.

    The plugin that works with new images but not the images from iPhoto is: Depth of Field (Human Software)

    It's the only plugin I've tried so far.

    iPhoto is always kept uptodate with the latest updates.

    So all new versions.

     

    I have wondered whether I have to export all my photos from iPhoto.

    Delete the library in Aperture and create a new library and import all images

    This sounds like a bit of nightmare and we really shouldn't have to do this!!!

  • 6. Re: aperture 3.4 plug-ins give Editing Error..
    lexar123 Level 1 Level 1 (0 points)

    I did that... I exported from iPhoto to a brand new Aperture library and it did not work !

    I have Topaz and Nik plugins and they both don't work.

     

    Both are the newest versions:

     

    My iPhoto version is 9.4.2

    My Aperture version is 3.4.3

  • 7. Re: aperture 3.4 plug-ins give Editing Error..
    léonie Level 9 Level 9 (51,730 points)

    I have Topaz and Nik plugins and they both don't work.

    But have you checked, if this plug-ins are compatible with Aperture 3.4.3 on the manufacturer's web site?

  • 8. Re: aperture 3.4 plug-ins give Editing Error..
    lexar123 Level 1 Level 1 (0 points)

    All the plugins work with newer imported pictures in Aperture.

     

    Only the pictures that were importing into iPhoto prior to sharing with Aperture I get:

    Editing Error.

    One or more of the selected versions has a original files which is still being imported.  Please wait for the file to copy to complete and try again.

     

    I can even delete the prior pictures and reimport into Aperture directly and then the plugins work fine with those pictures.

     

    I am sure this is some kind of database flag that is not set correctly by iPhoto and misunderstood by Aperture.

  • 9. Re: aperture 3.4 plug-ins give Editing Error..
    léonie Level 9 Level 9 (51,730 points)

    Only the pictures that were importing into iPhoto prior to sharing with Aperture I get:

    Editing Error.


    I am still puzzled by what the difference might be between your and my iPhoto library and plug-ins. As I said, all my plug-ins work well, when I open an iPhoto library from Aperture. It must either be something specific to your plug-ins (that is why I keep asking for the version number of your plug-ins - are they confirmed releases for Aperture 3.4.3 and Mt. Lion?) or something different in your iPhoto Libraries. Are your iPhoto libraries referenced? Mine are managed. And my iPhoto libraries have been originally created in very early iPhoto versions and upgraded to iPhoto '11.

  • 10. Re: aperture 3.4 plug-ins give Editing Error..
    lexar123 Level 1 Level 1 (0 points)

    I agree its odd!

     

    I thought the same thing about the plugins.. so I downloaded the latest version from their websites and still did not work.

    This problem was happening on Lion and now Mountain Lion as well...

  • 11. Re: aperture 3.4 plug-ins give Editing Error..
    mb999 Level 1 Level 1 (0 points)

    This is the same for me.

    All software/plugins are up-to -date.

     

    I purchased and dowloaded Aperture on the 1st Jan 2 days ago and when it started and asked if I wanted to create a new library or use the iPhoto library I chose the iPhoto library.

     

    Have all the same problems as above.

     

    I SPOTTED ANOTHER BUG.

    In the Photos section I have all of my images duplicated.

    One can be edited with the plugin and one cannot!

     

    This is getting silly

  • 12. Re: aperture 3.4 plug-ins give Editing Error..
    lexar123 Level 1 Level 1 (0 points)

    There is one difference..

     

    My pictures are referenced and not managed.  Maybe this has something to do with it?

     

    mb999 are your pictures referenced or managed?

  • 13. Re: aperture 3.4 plug-ins give Editing Error..
    léonie Level 9 Level 9 (51,730 points)

    My pictures are referenced and not managed.  Maybe this has something to do with it?

    Maybe.

     

    How about the following test:

    • Consolidate one of the images in question into the library (File > Consolidate original). Try to edit it with the plug-in. Does it work?
    • Relocate it again to a folder outside (File > relocate original). Does it (still) work?
  • 14. Re: aperture 3.4 plug-ins give Editing Error..
    mb999 Level 1 Level 1 (0 points)

    Consolidating an image (and selecting 'move to aperture') I was then able to edit it with the plug-in.

1 2 Previous Next