Skip navigation

Aperture library suddenly won't open

665 Views 8 Replies Latest reply: Jan 10, 2013 7:58 AM by TStam RSS
Richard Hallas Calculating status...
Currently Being Moderated
Jan 1, 2013 9:42 AM

OK, I've been putting off updating to the latest version of Aperture (3.4.3) because I had a sort of premonition about something bad happening to my library. But I finally got around to doing the upgrade, having felt this version had been around long enough to be stable. Big mistake. It worked OK initially, but suddenly today won't open my library, no matter what I do.

 

When I launch Aperture, it opens a little window with a spinning marker in it and the message "Opening Aperture Library". This is normal prior to the main window opening, but usually I see it for no more than a second or so. Now, it's all I see; the main window never appears.

 

Oddly, Apertur's menu structure seems to work OK while this 'loading' window is open. I can, for example, open the Activity window. However, it contains no useful information to say what's going on; the entries are just blank in this window. Also, I can quit Aperture normally (whereupon it says 'updating previews' as usual).

 

I've tried all three of the database-reparing options that Aperture offers if you hold down Option-Command when starting: repair permissions, repair database, rebuild database. In all three cases, it goes through the repair process and then just reverts to showing the little 'opening library' window and nothing has improved.

 

The upgrade to version 3.4.3 apparently went OK the other day, and I've opened and quit the software a few times since I upgraded it, and I thought everything was fine. The one thing that wasn't quite right (and I wonder if this has somethnig to do with my problem now) was Photo Stream. It didn't seem to be working properly. If I clicked the Photo Stream entry in the list at the left of the window, what I saw was just the 'welcome' message with buttons below it to sign in or turn off the service ("No, thanks" button). I didn't see any actual Photo Stream content. In this window, however, it *did* say that I was signed in with my usual Apple ID, so it wasn't very clear to me whether it was OK or not.

 

There's a photo I took on my iPhone which I was expecting Aperture 3.4.3 to download from Photo Stream, but it never did. I.e. just one shot that failed to download; all the previous ones had been downloaded by my previous version of Aperture. I couldn't see why the missing picture was failing to download, so I tried turning Photo Stream off and on again from within Aperture. I'm really not sure whether this worked or not; there didn't seem to be any meaningful feedback from the software.

 

Anyway, after having tried to launch Aperture today (and failed), I checked System Preferences and found that Photo Stream was turned off. So I turned it on again. Unfortunately it makes no difference: Aperture still won't load its library at all now.

 

I have tried all of following:

 

1. Rebooting my Mac

2. Verifying the disk contaning my Aperture library (it was fine)

3. All three of Aperture's database-repair options

4. Turning Photo Stream on in System Preferences

 

...and nothing makes any difference. Aperture simply will not open my library but just sits there, twiddling its spinner.

 

NB My library still appears to be OK, in that I can access its contents from other software successfully using the media browser.

 

What I haven't yet attempted is to create a blank new library and import my existing library into it. Failing any better ideas I'll try that next, but it's going to be a big operation that will take a lot of time and disk space, so I'd like to see if there are any better things to try first.

 

I must say I'm very disappointed that Aperture can apparently break so easily. I haven't lost any actual pictures because I'm paranoid and keep a separate copy of all my shots just in the Finder, external to any management software. But I've lost access to lots of photo books I've created over the years and various other resources, not to mention all the editing work I've done on thousands of shots within Aperture (which I haven't retained separately).

 

This is supposed to be professional level software. How can it seriously (a) break this easily and (b) not be able to retrieve itself via its database repair options?I'm very disappointed.

Mac Pro, OS X Mountain Lion (10.8.2), 8-core 2.8GHz (2008), nVidia 8800GT
  • léonie Level 8 Level 8 (46,380 points)
    Currently Being Moderated
    Jan 1, 2013 11:30 AM (in response to Richard Hallas)

    When I launch Aperture, it opens a little window with a spinning marker in it and the message "Opening Aperture Library". This is normal prior to the main window opening, but usually I see it for no more than a second or so. Now, it's all I see; the main window never appears.

    Richard, you have already covered a lot of ground with your tests. But we need to narrow the problem down further:

    Typical reasons for the main application window not to appear and Aperture hanging:

    • You may have imported a currupted image file or video - did you import something before the problem started?
    • Your library may be corrupted: To check this, create a new Aperture library, but do not import your current library - just check if Aperture launches at all and import a few images, if possible. Does it work? If yes, we will know for sure, that library needs fixing.
    • If Aperture does not even launch on a new library, try launching Aperture from a different account. If it works from a different user account, we will know, that the Aperture installation and the system are o.k., but settings in your regular account are causing problems.

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,380 points)
    Currently Being Moderated
    Jan 3, 2013 8:27 AM (in response to Richard Hallas)

    In all three cases, the file appears to be an alias that points to itself (i.e. original path is the same as the alias's path in each case). That seems weird but I hope it's right, given that it applies to all three (and the files alongside these plists in the folders in which they reside).

    The folder /Users/rghallas/Library/Containers/com.apple.Aperture you have found in your library is the sandbox of Aperture - it contains data to be shared with other applications in a save way.

    I checked with my own user library - most of the aliases "/Users/rghallas/Library/Containers/com.apple.Aperture/Data/Library/Preferences/c om.apple.iLifeAssetManagement.agent.plist" are broken links; they do not point at anything; if I try to open the referenced file, I get the error message "... theoriginal item cannot be found". The aliases that are not broken point directly into the classical "Preferences" folder in the user library, in your case this would be "/Users/rghallas/Library/". 

     

    It looks like Aperture were trying to replace the dead aliases wby new aliases, if it creates a new Preferences file, but cannot write it.

     

    Are you running Aperture logged in as an administrator or as a simple user?

    Have you already checked the permissions and ownership in your user library?

  • TStam Level 1 Level 1 (75 points)
    Currently Being Moderated
    Jan 10, 2013 6:50 AM (in response to Richard Hallas)

    Same is happening to me. 3.43 with Mountain Lion. Have tried every posted fix here and in other posts. Deleting plists, photostream, loading with iPhoto first, rebuilding, creating a new library to test, etc. Nothing works. The only fix is to reinstall Aperture. Then all works fine for a few days. Then it happens again. It's not the library because if I reinstall aperture without repairing the same library that was not opening it loads fine..........for a few days. Also, the same library, which is now compatible, loads just fine in iPhoto.

     

    I'm on my 5th reinstall now. Last was a few days ago. I reinstalled Aperture again and as some have suggested created a new library and imported the old one into the new. So far, so good, but I fear it will happen again.

     

    I don't get it. I am getting frustrated enough to dump the program as much as I love(d) it.

  • TStam Level 1 Level 1 (75 points)
    Currently Being Moderated
    Jan 10, 2013 7:58 AM (in response to Richard Hallas)

    I have the same Mac Pro. Some have reported that deleting the plist works, others that opening first with iPhoto works. Nothing has worked for me, except reinstall. That works every time.............for a few days. If you do this and you install from an old CD you must make sure to install the update from the App Store first or your library will be incompatible. I'm hopeful that importing my old library into a new one works, but doubt it. Time will tell.

     

    I have no issue with Photostream.

     

    There are many posts on this. Just google "Opening Aperture Library" and you will see.

     

    This "just doesn't work". Apple needs to fix it.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.