Skip navigation

No WiFi after 5.1.1 iPhone OS upgrade

184660 Views 180 Replies Latest reply: Oct 15, 2013 12:53 PM by mouche RSS
  • Coolhandluke1 Calculating status...
    Currently Being Moderated
    Sep 23, 2012 5:00 AM (in response to pmyrick)

    I'm also having problems with staying connected to wifi. Seems that when my phone is in sleep mode it drops the connection. Basically some neat stuff on ios6 but a real let down so many buggs,  wish I never updated

  • Gypsy67 Calculating status...
    Currently Being Moderated
    Sep 24, 2012 6:12 PM (in response to SuzeRam)

    I am also having the same issues!!!! after upgrade I can't access wifi at work or home. I've never had any problem in the past. I am very upset I wiped my phone out and it still won't access wifi.  Needless to say I am not happy..

  • Dgigman2 Calculating status...
    Currently Being Moderated
    Sep 25, 2012 5:17 PM (in response to SuzeRam)

    Today, I broke down and went to the Genius Bar with my 4s due to not having any WiFi capabilities at all, i.e. the on/off was greyed out as of the 6.0 update. The 5.1.1 update caused my 4s to not be able to search for or connect to WiFi.

    They took my phone and attempted to do a complete system reset on it, but the result was the same. I am lucky that my phone was under warranty and they replaced it. I overheard the tech working on my phone talking to the tech that had initially been attempting to help me and he said that the phones are made in different places and the hardware parts aren't always the same, but they are comparable parts. He then said that some of these parts are not compatible with the software updates and the phones are not able to recognize them. So, for all of you that are having issues with bluetooth or WiFi, it is a hardware problem created by the software update. The software is not compatible with those parts. Your best bet is to get to an Apple store if you can.

  • subhash vodafone Calculating status...
    Currently Being Moderated
    Sep 25, 2012 11:02 PM (in response to Dgigman2)

    After upgrade the iphone 4S with IOS 6, there are No wifi , bluetooth and  some countrys only .


  • billtroyer Calculating status...
    Currently Being Moderated
    Sep 28, 2012 8:59 AM (in response to SuzeRam)

    Turn on "Airplane Mode", then turn on "WiFi", then turn off "Airplane Mode". Worked for me!

  • janetsantafe Calculating status...
    Currently Being Moderated
    Oct 4, 2012 8:27 AM (in response to SuzeRam)

    I have iPhone 3s, and updated to 5.1.1, then lost my home wifi access, as many of us have discussed. After reading through many of the things people have tried, this is what someone suggested that worked immediately for me, no fuss, no muss:


    Reset your network settings on the iPhone:


    Settings > General > Reset > Reset Network Settings


    When the phone came back up, I had to return to Settings > Wi-Fi to choose a network (the phone of course no longer had knowledge of my preferred networks).

  • JVernel Calculating status...
    Currently Being Moderated
    Oct 7, 2012 3:46 AM (in response to billtroyer)

    Turning the airplane mode on and off worked for me.

  • Joetofu Calculating status...
    Currently Being Moderated
    Nov 2, 2012 11:23 AM (in response to SuzeRam)

    I too have a 3GS. I just updated to iOS6 (had to reinstall the OS for other reasons, and the only OS offered by iTunes was iOS6...) and now have the wi-fi problem that everyone's been describing in this thread.The "airplane mode" fix worked for me once, but now the problem has returned. I will try your suggestion of calling AT+T.


    But in the meantime, I think you are wise not to give iOS6 a go, if the setup you've got is working.

  • FelixTheMatt Calculating status...
    Currently Being Moderated
    Nov 21, 2012 2:55 PM (in response to iexpertiphones)

    How can you have worked with iPhones for 7 years?! the 1st iPhone came out in 2007.. dum dum dum dum dum

  • Joetofu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 21, 2012 4:30 PM (in response to Joetofu)

    Update: I didn't try calling AT+T, after all, but I did take the phone into the Genius Bar at my local Apple store. They acknowledged the problem, admitted that they had no way of fixing it, and ordered a replacement 3GS for me for free. I picked it up a few days later and it's been working fine ever since (about 2 weeks). This replacement phone is running iOS 5.1.1, and I'm defnitely NOT planning to install any system updates nor to 'upgrade' to iOS6.

  • bryma Calculating status...
    Currently Being Moderated
    Dec 5, 2012 1:41 PM (in response to SuzeRam)

    Does anyone have a solution for this problem on a 3rd Generation iPod touch? Obviously I can't remove a non-exsistent SIM card, or even log out of the App Store without Wifi. All of the solutions seem to be for iPhones. My iPhone 4S had no problems whatsover after upgrading, but my daughter's iPod touch can't even search for a Wifi network. The device worked perfectly before the update, and it's about 3 years old so of course no AppleCare. I've spent days trying to restore, etc and I haven't found a solution that has worked for even a second! Help!!!

  • Mazen78 Calculating status...
    Currently Being Moderated
    Jan 3, 2013 9:23 AM (in response to iexpertiphones)

    i have problem in my 4s 5.1.1 (no wifi) can u help me pz

  • Joetofu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 9:33 AM (in response to bryma)

    Take it to the genius bar at an Apple store. Even without AppleCare you can still make an appointment and they'll be happy to look at & troublshoot your device. My iPhone 3GS was 3.5 years old and long past the warranty (I never bought the extended AppleCare warranty for it, either). But they still gave me a new one for free when they couldn't fix it.

  • Joetofu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 9:34 AM (in response to Mazen78)

    If you've already tried all the solutions suggested in the discussion thread, I suggest making an apppointment at the genius bar at your local Apple store and seeing if they can fix it. This worked for my 3GS, even though I didn't have an AppleCare plan.


More Like This

  • Retrieving data ...

Bookmarked By (9)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.