Skip navigation

aperture 3.4 plug-ins give Editing Error..

679 Views 18 Replies Latest reply: Jan 4, 2013 7:25 AM by lexar123 RSS
1 2 Previous Next
lexar123 Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 23, 2012 1:56 PM

I updated Aperture to 3.4 and as before sharing my iPhoto library.

 

When I try and use any plug-ins like dfine or others I get the following error.

 

Editing Error.

One or more of the selected versions has a original files which is still being imported.  Please wait for the file to copy to complete and try again.

 

 

I tried this with several different plug-ins and many different pictures.

However If I import a picture into the aperture library then I can use the plug-ins but if I try and do it using the iPhoto library I cannot.

 

Any ideas??

  • mb999 Calculating status...
    Currently Being Moderated
    Jan 2, 2013 11:31 AM (in response to lexar123)

    I too have the same problem with all plugins.

     

    I had been using iPhoto for quite a while building up a whole catalogue of pictures and albums.Whern I purchased Apperture I told it use the iPhoto libraries rather than create a new one.

     

    I noticed the same as you that only the NEW images that were loaded into Aperture can be edited by the plugins.

     

    Please can someone tell us how to fix this.

  • léonie Level 8 Level 8 (46,465 points)
    Currently Being Moderated
    Jan 2, 2013 3:02 PM (in response to lexar123)

    What are the Aperture versions you are using exactly? I just made several tests with one of my iPhoto libraries - opened it in Aperture and tried the plug-ins PT Lens, BorderFX, ToonIt!  None of the images have been imported using Aperture, and all plug-ins worked as expected.

     

    So it seems not to be a general plug-in problem, but must be depending on something else, maybe the version of the plug-in or the Aperture version.

     

    My Apeture version is 3.4.3 and iPhoto 9.4.2;

  • mb999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 4:32 AM (in response to léonie)

    Hi

     

    (Answering this from work machine so can't give exact version)

     

    I'm using the latest version 3 just downloaded from the app store Jan 1st 2013.

    The plugin that works with new images but not the images from iPhoto is: Depth of Field (Human Software)

    It's the only plugin I've tried so far.

    iPhoto is always kept uptodate with the latest updates.

    So all new versions.

     

    I have wondered whether I have to export all my photos from iPhoto.

    Delete the library in Aperture and create a new library and import all images

    This sounds like a bit of nightmare and we really shouldn't have to do this!!!

  • léonie Level 8 Level 8 (46,465 points)
    Currently Being Moderated
    Jan 3, 2013 6:43 AM (in response to lexar123)

    I have Topaz and Nik plugins and they both don't work.

    But have you checked, if this plug-ins are compatible with Aperture 3.4.3 on the manufacturer's web site?

  • léonie Level 8 Level 8 (46,465 points)
    Currently Being Moderated
    Jan 3, 2013 10:21 AM (in response to lexar123)

    Only the pictures that were importing into iPhoto prior to sharing with Aperture I get:

    Editing Error.


    I am still puzzled by what the difference might be between your and my iPhoto library and plug-ins. As I said, all my plug-ins work well, when I open an iPhoto library from Aperture. It must either be something specific to your plug-ins (that is why I keep asking for the version number of your plug-ins - are they confirmed releases for Aperture 3.4.3 and Mt. Lion?) or something different in your iPhoto Libraries. Are your iPhoto libraries referenced? Mine are managed. And my iPhoto libraries have been originally created in very early iPhoto versions and upgraded to iPhoto '11.

  • mb999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 10:58 AM (in response to lexar123)

    This is the same for me.

    All software/plugins are up-to -date.

     

    I purchased and dowloaded Aperture on the 1st Jan 2 days ago and when it started and asked if I wanted to create a new library or use the iPhoto library I chose the iPhoto library.

     

    Have all the same problems as above.

     

    I SPOTTED ANOTHER BUG.

    In the Photos section I have all of my images duplicated.

    One can be edited with the plugin and one cannot!

     

    This is getting silly

    Aperture 3, OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,465 points)
    Currently Being Moderated
    Jan 3, 2013 11:26 AM (in response to lexar123)

    My pictures are referenced and not managed.  Maybe this has something to do with it?

    Maybe.

     

    How about the following test:

    • Consolidate one of the images in question into the library (File > Consolidate original). Try to edit it with the plug-in. Does it work?
    • Relocate it again to a folder outside (File > relocate original). Does it (still) work?
  • mb999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 12:27 PM (in response to léonie)

    Consolidating an image (and selecting 'move to aperture') I was then able to edit it with the plug-in.

    Aperture 3, OS X Mountain Lion (10.8.2)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.