0 Replies Latest reply: Jan 3, 2013 12:06 PM by magdalen23
magdalen23 Level 1 Level 1 (0 points)

iCal has preferences that let you decide how many hours per day you want to see, and which hours of the day you want to make appointments. For example, I need to see 7 a.m. to 8 p.m. and I don't need to make appointments for the night. If I specify in my prefs that my "day starts at 7 am" and "day ends at 8 pm," when I look at my screen it still shows me all 24 hours---with nighttime grayed out.


This also happens if I change the number of hours I ask to be shown, in preferences again. For example, if I specify that I want to make appointments for 7 a.m. to 5 p.m., that totals ten hours. Whether I click "Show 24 hours" or "Show 10 hours," I still have those grayed-out, useless nighttime hours taking up my screen and forcing me to scroll when I don't want to scroll. I don't want my day to start at 1 a.m. When I click onto a day, I want to see 7 a.m. at the top of the screen.


I'm on Snow Leopard, iMac intel duo, running iCal 4.0.4 .




Here are the official support directions/instructions for this.


"To change the time range that appears in the main calendar view, choose iCal > Preferences and click General.To change the range of time when you’re normally available each day, choose your daytime hours from the “Day starts at” and “Day ends at” pop-up menus. All times outside that range are shaded in the day or week calendar view.To set the number of hours that are displayed when you view your calendar in Day or Week view, choose a number from the Show pop-up menu."




It mentions these unavailable hours will be "shaded," but my issue isn't whether or not they are shaded (I don't much care) but the fact that I don't want to see them on my screen and be forced to scroll a lot.




I took screen grabs of these calendars and corresponding Preferences settings, but apparently I'm supposed to go into Photoshop and resize them, etc etc, in order to upload them to this forum. Not going to do it. I hope my description above is clear enough.