Skip navigation

New Apple TV loses connection to iTunes 10.0.1

115050 Views 187 Replies Latest reply: Jun 7, 2013 6:42 PM by Rathbone Hall RSS
  • JMac12 Calculating status...
    Currently Being Moderated
    Sep 11, 2012 6:53 AM (in response to Toasty!)

    Hello,

     

    I have come across a fix for this issue that has been working for me now for three days.  I'm using iTunes in Windows 7.  I have spent hours on this issue trying to figure out what the problem is.  I have tried using wired and WiFi connections, resetting my router, changing firewall settings, disabling sleep on my computer (windows 7 machine), disabling sleep on my Apple TV 3, reinstalling iTunes and nothing seemed to work.

     

    I narrowed the problem down to iTunes.  The only way my homesharing would work is if I closed and re-opened iTunes or signed out of HomeSharing and signed back in.  This tells me that either iTunes or Bonjour are at fault.

     

    I did two things and this seems to have fixed the issue:

    1.) Turn off TCP/IP V6 in network card settings (this suggested by another user in one of the threads).  You can do this by going into your network adapter settings, clicking on properties, and unchecking TCP/IP V6.

    2.) The other thing I did was go into Add/Remove Programs and clicked on Bonjour and chose the repair option.  Once that was finished I restarted my computer opened iTunes and it has been working since (three days now!)

     

    Now... because I did both of these fixes at the same time... I'm not sure which one fixed the issue but I'm not going to change anything or touch anything because it is finally working for me.  As the old saying goes... if it ain't broke don't fix it!

     

    I'm really dissapointed that Apple has not fixed this issue because there is a lot of complaints about it and it's been going on for a long time.  When I called Apple's tech support they really did not do much to help and told me this was not a common issue or something they were familiar with.  No solution was offered.

     

    This solution may not work for everyone but it worked for me and I wanted to share this because I know how annoying it is.  I hope it works for you... good luck!

  • fronesis Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 11, 2012 7:43 PM (in response to JMac12)

    I had issue 1: everything on my system works fine except iTunes on my mac cannot stream to the ATV3. I'm running an Apple-only system with the newest Airport Extreme router and airplay works fine from all my iOS devices. The ATV3 also works fine when it connects to my Mac from the ATV3 (homesharing works fine). But when using either Airplay mirroring or just sending to the ATV3 from iTunes, the connection is lost (I think after the ATV3 goes to sleep) and the only solution was a reboot of the ATV3.

     

    I read everything in this thread and had no luck, but I did find a solid solution for my problem in another thread. Let me past it here. It's from the User Tesserax

     

    One option to try that seems to resolve iTunes streaming with OS X Lion [and for me, Mountain Lion] is to disable IPv6. In previous versions of OS X, IPv6 was disabled by default. Not so in Lion and there is no option in the Network panel to do so.

     

    However there is a method to do so using Terminal:

     

    • Applications > Utilities > Terminal
    • To determine what are all of your Mac's network interfaces are, issue the following command: networksetup -listallnetworkservices
    • To disable IPv6 for wireless, issue the following command: networksetup -setv6off Wi-Fi; to disable IPv6 for Ethernet, issue the following command: networksetup -setv6off Ethernet
    • To re-enable IPv6, use -setv6automatic instead

     

    Immediately after turning off IPv6 in the terminal I was able to connect from iTunes to the ATV3.

  • trevc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 30, 2012 7:43 AM (in response to Toasty!)

    So ... with the recent Apple TV firmware update, I haven't had this issue since?  Seems like it's fixed.

  • fronesis Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 1, 2012 4:56 AM (in response to trevc)

    Yes, I think you might be right. I changed my ipv6 back to "auto" in the terminal and so far streaming from my iTunes to the ATV still seems to work. I haven't tested it extensively, but if it ends up failing again I will definitely report back here (and if not, then it looks like apple solved this one).

  • Scoff77 Calculating status...
    Currently Being Moderated
    Dec 3, 2012 7:30 AM (in response to Toasty!)

    Hey.

     

    Think I'm in the right place here for this issue! ^^

     

    When I'm streaming a movie from my Imac (Itunes) to my Latest (New) ATV when my Imac goes to sleep..

    so does the movie.. it just stops playing and redirects me back to ATV-Home screen!

     

     

    When I move the mouse and log on in again.. (further I do nothing) I CAN reconnect to home-sharing and
    play my movie again.. until it goes to sleep again!

     

    Didn't have this befor the latest updates! Itunes 11 & ATV....what is it? (latest update) ><

     

    Thank you!

  • Mike5906 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 7:34 AM (in response to Toasty!)

    After the latest iTunes and ATV firmware this problem appears to be erdicated.  I haven't has the issue in a week and it was happening daily before the updates.

  • Scoff77 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 7:37 AM (in response to Mike5906)

    So I'm like this 1 in a Mil. who has this problem?

     

    I should fill in the lottery!.. feeling lucky today!!

  • frust rated Calculating status...
    Currently Being Moderated
    Dec 3, 2012 7:47 AM (in response to Scoff77)

    I am having this issue also - I can start movies/tv shows stored in the cloud or on my computer on my Apple Tv but after a few minutes it automatically stops and i get a message saying "not connected to the network" but i have full "bars" and i can stream Netflix/Hulu without an issue. i unplugged, reset, etc. with NO luck. This seems to be an Apple issue, not a connection issue

  • RabbitRancher Calculating status...
    Currently Being Moderated
    Dec 11, 2012 5:21 PM (in response to JMac12)

    I had the same problem with with iTunes 11.0.0.163 and all of my Apple TVs (3 units). I went into Add/Remove Programs and clicked on Bonjour and chose the repair option.  Once that was finished, all started working even without a restart. Before I repaired Bonjour, I had checked network connectivity, reset one of the units to factory defaults, etc.

  • Harry Teasley Calculating status...
    Currently Being Moderated
    Dec 21, 2012 1:18 PM (in response to Toasty!)

    I have this problem, with a Mac running 10.7.5, iTunes 11, and a new, updated ATV. The ATV is on the network, has internet access (Netflix, Hulu work fine), but cannot connect to my iTunes library. I just get a "Cannot connect to Library" error if I try to choose the Computers button on the ATV.

     

    iTunes is running on the Mac, and what's more, I can use the ATV as the output for whatever music or movies I wish to, if I do it from iTunes. It's works fine. There's something on the ATV side, it seems to me.

     

    If I unplug and replug the ATV, it will connect to iTunes. But after a day or so, it gets into this "lost but not really" state, and will never again see iTunes correctly until rebooted. iTunes happily sends videos to it while it's in this state.

     

    It's annoying.

  • tstep Calculating status...
    Currently Being Moderated
    Jan 3, 2013 8:40 AM (in response to janericster)

    I guess if you step back and ask yourself, Why would Apple make a product that requires a service contract to fix? .....it all makes sense.

     

    Just like every other appliance you buy nowadays is designed to have a small part failure so you have to have a service tech come out and replace a $1.00 part and charge you $300. Or, similar to the inexpensive printer and expensive printer cartridges, are you getting it?

     

    If you just buy Apple TV and it works fine, there is no new revenue for them, except for happy customers buying movies and music. Ah, the old days of good products and happy customers for life. But that does not seem like enough, especially since Steven Jobs died (too soon?). He must have been the ethical leader keeping them on the old Apple path.

     

    Well it may be a coincidence, but after I called and complained, Apple said I had to buy their Apple service contract, either the one-time or one-year agreement in order for them to help me. Or, I could bring it to a Apple store. The Apple tech said he is unaware of any problem related to Apple TV losing the network connection. I asked him if he did a Internet research on the issue in, say the last year? He was very nice but denied there was an issue. I opted for neither the contract or returning my Apple TV to the store feeling it was an internal software fix with the upgrades to itunes and hoped this online forum would yield a solution.

     

    I don't want to be the only guy with a conspiracy theory, but are if you ask the right questions you will see the answer. Now I do understand there may be other issues which can affect connectivity; but for my Apple TV to be working for 6 months and then stop, defies what little logic I have. Help me Apple and thanks for letting me vent my frustrations!

  • MyrkridianRhapsody Level 2 Level 2 (470 points)
    Currently Being Moderated
    Jan 3, 2013 10:35 AM (in response to tstep)

    There is no "conspiracy". It's bonjour. When it works, it works. When it doesn't, have fun.

  • tstep Level 1 Level 1 (0 points)

    What does Bonjour do?  and how does it work? is it like the Wifi dejour, you never really know what you are getting for that day, aka special of the day?

  • MyrkridianRhapsody Level 2 Level 2 (470 points)
    Currently Being Moderated
    Jan 3, 2013 2:49 PM (in response to tstep)

    As the article says, it is Apple's zeroconf protocol. The whole idea is that you as the end user just click a button and mutliple devices now have an established network. It usually works great for home users but has no use whatsoever in the enterprise environment. It becomes increasingly harder to troubleshoot when a product is described as "it just works", so when it doesn't work, there is nothing to really monkey with. Apple is very strict on wireless standards and yes, they want all of your equipment to be Apple branded including routers. All software needs to be fully updated and relatively new hardware or it can't be guaranteed to function properly.

     

    I used to work at the Apple store so I understand exactly why the Genius told you there were no issues. Apple usually does not look at nor respond to information on these forums, nor do they take the information seriously when presented with it. It is understandable in a sense, since there could literally be ten different causes to everyone's single shared symptom. I was always told it's like a doctor's office, there can be ten different people with fevers but they may all be sick with ten different viruses. You can't assume everyone's problem/solution is exactly the same just by the symptom. Each problem is a case by case basis and needs special attention. And I agree with that. Then again, there ARE chronic issues that do occur and bugs that are widespread. We all know that. I just don't think Apple is doing anything on purpose as you had originally stated.

     

    Verify your router settings are set up properly, check them against Apple's recommendations.

     

    http://support.apple.com/kb/HT4199

    http://support.apple.com/kb/TS1398

     

    Power cycle your router, reset your router to factory settings, turn off all wireless devices in the house other than your AppleTV and Mac. If possible, trying streaming from another computer's iTunes Library and see if the same issue occurs. The goal is to find one constant that can be isolated, and then removed. You should probably also verify everything is okay with your ISP. Check your speed settings at speedtest.net and make sure they aren't crawlng at a snail's pace.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.